[WP34S] Once Working TVM Now Broken



#8

The TVM library routine was working very well thanks to improvements to the solver, but when I revisited tonight for the first time in a couple of weeks it throws an "Out of Range" error whereas once it gave a correct result.

My test problem is basically a mortgage of PV = 153295, FV = 0, PMT = -976.25, with N = 300, NP = 12, NI = 2. The correct interest rate is around 5.95%/yr, which the program used to spit out to high accuracy. Now the solver proceeds very quickly to the error noted.

I'm baffled. I am using the latest version, and I can produce this on the real calc and the emulator.

Just thought I would share this to see if anyone else can reproduce it.

Les

Edited: 7 May 2012, 4:50 p.m. after one or more responses were posted


#9

The solver itself is broken in general.

Attempting to solve even the basic x^2-2 = 0 equation with guesses 1.4 an 1.42 on the stack generates the Out of Range error.

Hope this helps,

Les


#10

We'll have a look.

Edit: I did have a look. My shame. :-(

I wonder why this hadn't surfaced earlier. It was a typical "always" against "never" programming mistake.

Edited: 7 May 2012, 3:24 a.m.


#11

Glad it was fixed. Looking at the SVN comment I am surmising it was a a pretty basic issue that could have implications whenever POPUSR was called in XROM.

Nice to see my beloved TVM back to normal.

Les


#12

Glad you like it. Was hard work to get it in the function set over a year ago :-)


#13

Quote:
Glad you like it. Was hard work to get it in the function set over a year ago :-)

And whose work was it?

#14

Yours. Appreciated!

WP 34S is a real group effort. :-)


Possibly Related Threads...
Thread Author Replies Views Last Post
  Broken keys on HP Prime? Tarcisi C 0 313 12-10-2013, 05:59 PM
Last Post: Tarcisi C
  HP Prime Save Power Turn Off Not Working Timothy Roche 12 973 10-27-2013, 01:41 PM
Last Post: Michael de Estrada
  Temporary User Mode Key Programs not working in RPN BruceTTT 7 675 10-14-2013, 01:46 PM
Last Post: BruceTTT
  Is my HP Prime broken ? Michael de Estrada 10 748 10-13-2013, 11:16 AM
Last Post: Mike Powell
  TVM again ;-) fhub 17 1,189 09-02-2013, 11:03 AM
Last Post: fhub
  Broken HP-97 to spare? davorin 3 417 08-29-2013, 01:08 AM
Last Post: davorin
  TVM WP34s trouble Jim P 4 520 06-28-2013, 07:31 AM
Last Post: fhub
  HP-97 suddenly not working Brad Barton 10 737 02-25-2013, 08:15 PM
Last Post: Brad Barton
  [41CL] Problem with PowerCL ... not working Doug (NYC) 5 517 01-22-2013, 07:18 PM
Last Post: Doug (NYC)
  TVM-Solver for the PC fhub 14 994 12-26-2012, 03:24 PM
Last Post: fhub

Forum Jump: