Flashing of WP34S, entering SamBa via keyboard


I have now converted a second unit with my usb flash adaptor. But I still have trouble reflashing the device. See this post

I have tried two different ways of flashing. One works, and the other one doesn't. Both use my integrated USB adaptor to connect the PC to the 34S.
Using ON+D, ON+S+S, reset, ON, then flashing, reset, ON results in the calculator displaying "restored" and the firmware NOT being updated. However MySamba transmits and tells me it took 24s (as usual)
Following these instructions:

Hold down the ERASE button on the cable (do not release it).
Press and release the RESET button on the cable.
Press and release ON/CE on the calculator to turn it on again.
Release the ERASE button on the cable that you pressed a few steps earlier.
Press and release the RESET button on the cable.
Press and release ON/CE on the calculator. It will not appear to turn on.

followed by flashing with MySamba (again tells me it took 24 seconds) is succesfull. After reseting and turning on the calculator it comes up displaying "erased" and contains the new firmware.

I suspect I am making a mistake in my ON+D, ON+S*S.... procedure, but can't see it. This has worked for me in the past. Am I missing a step?!? If not, the only thing that is different is the firmware.

It is almost as if the SAMBA bootloader is active, but just dicards the data instead of writing it to flash.

I still have exactly the same issue. This is staring to bug me, as it very much limits the usefullness of my flash adaptor. I still need the normal cable just to press the erase button on it.

I am sure this has worked for me before. Can someone else please try falshing without using the erase button and report the procedure used if successfull?



I do this all the time:

ON+D, then ON+S+S, then ON. Flashing works most of the time. If not, a RESET, followed by ON does the trick always.

My cable is a modified serial cable with all the guts in the blob (except the buttons) removed and connected to a 3V3 FTDI-TLL cable.


What do you do after flashing? Reset and then ON?
Or am I making a mistake here?

I am beginning to think my adaptor is at fault. I just don't see how, as it works if I use the erase button instead of ON+D, ON+S+S.

I am probably looking at the problem from the wrong angle.....

How the heck can MySamBa transmit the data and the calculator NOT contain the firmware afterwards? If MySamBa is happy, that means the calculator MUST have given the correct reply, therefore it MUST also have entered the bootloader. So would you agree the problem must lie in something that happens after flashing? What does happen after flashing? Anything that could go wrong there?

Sorry to bother you with this, I just don't seem to be able to work out what is going wrong on my own....



The ON+D, ON+S+S sequence clears the boot bit (to enable the boot loader) and then turns the calculator off. Hence the necessity to press ON afterwards.

MySamba first sets the boot bit with the SAM-BA built-in commands and then downloads and starts a special communication program which is contained as a hex dump in the MySamba sources. This program is responsible for actually flashing the device. Since this program never reaches its programmed end condition (the full 128KB) the calculator sits there waiting for more data. So after the send completes it's necessary to press RESET once and then ON.


Strange. I still can't see a reason why it would kind of "half work" with the ON+D... procedure and work fine with the other.

Would you be interested in testing the flash adaptor? I don't have the one with the resistor for the IR LED and the transistors to switch between battery and USB power yet. So you could choose between the one with Li-Ion handling and the basic just USB one. Email me your address and I'll send you one. h dot pott at gmx dot net. Forum mail doesn't seem to work.


PS: And thanks for your patience with all those stupid questions...

Possibly Related Threads…
Thread Author Replies Views Last Post
  WP-34s ISP (flashing cable) again ;( Bernhard 16 5,785 11-01-2013, 05:02 PM
Last Post: Bernhard
  Re: [WP34S] Flashing Issues Les Wright 22 5,824 10-30-2013, 02:16 PM
Last Post: Les Wright
  Entering,Saving,and Analysis /Fitting X Y Data on the Prime Harold A Climer 6 2,436 10-26-2013, 01:54 PM
Last Post: Tim Wessman
  HP-Prime: issues in entering expressions fhub 30 7,714 10-02-2013, 12:32 AM
Last Post: Tim Wessman
  help flashing a hp30b to a wp34s john mantooth 3 1,638 09-25-2013, 08:58 AM
Last Post: Thomas Chrapkiewicz
  Flashing cable for HP 20 / 30B Stefan Koenig 3 1,939 09-19-2013, 05:53 AM
Last Post: Marcus von Cube, Germany
  USB flashing/Li-po boards patryk 6 2,393 09-08-2013, 12:31 PM
Last Post: patryk
  Help with flashing HP30s John Ioannidis 14 4,134 09-04-2013, 09:37 PM
Last Post: John Ioannidis
  Flashing at HHC2013 Kiyoshi Akima 1 1,122 08-30-2013, 09:12 AM
Last Post: Matt Kernal
  Self-made WP-34s flashing cable? Victor Koechli 6 2,892 08-15-2013, 10:11 AM
Last Post: Les Wright

Forum Jump: