Nov-64: Complete Newbie Needs Help



#18

I address this very basic query to the Clonix, etc., community here.

I just got my Nov-64 and USB programmer. I have installed the appropriate Prolific driver for the USB-Serial interface on Windows XP. I have downloaded the CD zip file through Diego's site and I have made sure that absolutely everything is in a short-named directory at the root so as to avoid a "too long filename" error.

I have oriented the connector and the Nov-64 appropriately as shown in a photo in the relevant manual. I started out with something simple at first, like trying to load PPCL and PPCU in the first two free blocks (1-C and 1-D). I have the correct COM port set.

When I hit "Proceed" the ASM and HEX files build as they are supposed to--only 5 warnings which we are told not to fret about. Then the programmer app opens. When I hit the "Program" button, a dialogue appears indicating that several things will NOT be erased. I press okay, the "Programming ROM" progress bar appears, followed by the "Programming EEPROM" bar. When that is done I get the error "ROM Error at 0x0005, Good 0xD063, Bad 0xD041." During the "Programming" phase, the red light is solid--so I know my computer is talking to the board.

I am really baffled about this! I do admit that my initial motivation for this was to get my hands on the HEPAX functionality relatively affordably, but it would be so nice to be able to fill those free pages with other ROMs to test.

The HEPAX functionality works fine in my HP41CV, so I know I haven't erased or fried anything. But I am afraid without a little hand-holding I will.

Can I prevail on the gurus here to help me and offer me a relatively jargon-free, step by step approach to trouble shoot this?

Many thanks!

Les

Edited: 3 May 2012, 11:17 p.m.


#19

I know it shouldn't be possible, but somehow I managed to corrupt my Nov-64. I don't know what happened, but when I plug it into my 41CV CAT 2 doesn't even list the built-in HEPAX contents any more. In fact, it lists nothing.

When I "read" the ROM contents in the programmer interface, I see an ominous bunch of 0000's where the HEPAX code presumably once resided.

I have tried, in vain, to simply "burn" the HEPAX stuff back, but I get tripped up again with one of those "ROM Error at" messages I mentioned already.

Can Diego or anyone help me out of this mess?

So grateful for guidance...


#20

I should also report that I learned of how to clear the module with CLR_RAM4.HEX, but when I try to burn the module with this file I get the old "ROM Error at" in the "Verify" stage at the end. I have fresh batteries, but no chance to use them since I don't get that far.

I must admit I am a little frantic here... This doesn't look good.

Grateful for direction.

Les

#21

Hi.

I would very much like to help, but I have just left the hospital right now to get back there in a flash (my 20 YO daughter has symptoms of some virus infection since yesterday). Get back later.

Cheers.

Luiz (Brazil)


#22

Hi Luiz

Hope your daughter recovers quickly.

Best wishes

James

Edited: 4 May 2012, 8:41 a.m.

#23

Hi Luiz, hope everything OK and quickly for your daughter, buona guarigione!

#24

Hi there,

First of all Luiz, I join previous comments and hope your daughter gets well soon and see your always enlightening comments posted as usual.

Back to the problem detailed by Les:

1- Sorry, this sort of things are not supposed to occur. Fortunatelly they don't really happen quite often... (since they're, most of the times, my fault...) although it's the second time in the last month's batch, and this means a 25% of the occurences in the past 9 years, may be my hand is not as steady as it used to be... :-(

2- Don't pannic, no matter what you have done. If the module hasn't suffered severe physical abuse it can (and it will) be fixed.

3- Preliminary checkings (the easiest part):

- Make sure the module's connector has all its pins properly aligned and the gap between the rows is not too wide to ensure a good electrical contact.

- Once confirmed, use a pencil eraser to clean the contact pads in the programmer's adapter. Also check that all six pins of said programmer's adapter are present and properly aligned (no bents).

- Try ClonixConfig.exe again and let me (us) know what you find and if the above hints fix the programming error problem.

- Otherwise, please take down the Error message(s) you receive ("ROM Error at 0x0005, Good 0xD063, Bad 0xD041") and see if they are consistent; i.e. same address and same data.

For now please do not use the CLR_RAM4 utility. I'll get back to this point once we see if the module's HW is not compromised.

All the best from Dominican Republic.

Diego.

Edited: 4 May 2012, 10:00 a.m.


#25

Diego, I don't think it is your fault this time, since somehow enough of a programming job was completed for me to corrupt the chip.

I've cleaned the contacts on the connector. The pins are present and straight. The module's contacts seem to contact the connector fine--not too snug, but no gaps. Just for good measure I have tried this on more than one computer running XP and the same thing occurs. I have ensured that the USB cable is connected directly to the computer at a fully powered port and not a hub.

I know that the module is correctly oriented on the connector and the connector is correctly inserted into the programmer, because when it isn't microbrn tells me it can't detect the chip.

Still, I get the same bad ROM error, and this time it is consistent--only this time the address is 0x0000, "Good" is 6AF2 and "Bad" is 6A42, so at the very first address. "Good" refers to data in the hex file, and "Bad" refers to what already lives at that address when I do a "Read" of the corrupted ROM contents.

I should admit that I recall being able to complete one programming of the module--I got all the way to verification--but it was after that even HEPAX wasn't there anymore. Before that the ROM error was at address 0x0005. I have a sinking feeling that I inadvertently overwrote the module with something other than the appropriate HEX file.

The module did not endure any physical abuse by me. It looks fine on inspection and I trust it survived the long journey.

I am glad you are willing to help with this. I know that the technical aspects of the Clonix family could be quite sophisticated, but I figured that if I could just burn in one or two favourite modules like PPC to get started and enjoy the HEPAX functionality I would certainly get my money's worth until I learned the finer points about blocks, pages, potential conflicts, etc.

Look forward to rescuing this.

Les

PS: Before I get started with a programming attempt, I get a dialog box stating "ROM = Not Erased, EEPROM = Not Erased, ID = Not Erased, ID = Not Erased, Fuse = Not Erased. Continue to erase and program this chip?" Is this normal behaviour? Don't I want the ROM to be erased and overwritten with what's in the HEX file? I should also mention that I get the above-mentioned ROM error without attempting to program--I click Verify and it immediately tells me the same thing. It is as though the programmer is telling me the module is bad from its very first address and it doesn't want to put my new HEX data there.


Edited: 4 May 2012, 6:10 p.m. after one or more responses were posted


#26

Hi Les,

Now let's see if the trouble comes from the erasing or the programming part of the sequence.

To confirm erasing procedure please try the following:

- Have your programmer/adapter connected.

- Launch "microbrn.exe".

- Confirm "18F2620" is selected in the "Chip selector" field.

- Plug your NoV-64.

- Click the "Blank" button, choose "Erase Chip", and "OK".

- Then click "Blank" again and choose "Erase Check".

Let me know the results. You should find ROM, EEPROM and ID erased while FUSES are NOT Erased.

Cheers.

Diego.

PS: The warning pop-up window stating "ROM = Not Erased, EEPROM = Not Erased, ID = Not Erased, ID = Not Erased, Fuse = Not Erased. Continue to erase and program this chip?" is normal, just a "STOP point" to make sure you *really* want to reconfigure your (already programmed) module.

It is also normal that you get the ROM error when "Verifying" since the data in de buffer (.HEX file) and the data in the device are not the same.

Edited: 4 May 2012, 5:32 p.m.


#27

Diego, I will try this when I get home once again, but I have indeed tried this before and I can attest that the things the three things that should erase are NOT erased. The erase check simply gives the "ROM not erased EEPROM not erased, etc." message that I have seen before.

I am pretty sure it is at the "erase" stage, if that helps you until I get home in an hour and try it out yet again. I can attest when I have tried to erase the chip before the procedure goes to swiftly for me to believe that anything is actually erased at all.

Eager to learn the next thing to try!

Les

#28

Diego, I am home now and can attest that those three areas are NOT erased when I try to erase and do the Erase Check.

Does this help?

Les


#29

Hi,

Eventually it may help Les.

From previous experience, non-erase trouble is mostly caused by a faulty programmer and not from a faulty module. So, in this case, it seems that you were right and I was wrong: It wasn't my fault after all... :-)

However, your programmer, as every other one I've supplied, was tested prior shipping. Assumed nothing traumatic has occurred to it (which seems not the case), both previous programmer's failures were due to a "cold solder", and this may well be your case too.

Will you please send to my mail account a hi-res picture (as big and focused as you can) of the solder side of your programmer?

I'll try to find any suspictious solder and if this was the case, point it out so you or some skilled-handyman friend could just correct the solder and get the programmer back to operational status.

In case nothing obvious was seen in the pics and if you have such a friend, he may also be able to find it himself and rework the damage.

Should none of the above was possible, just mail me to arrange the replacement and shipping details.

All the best from Caribbean Sea.

Diego.


#30

Photo sent.

Hope we find something.

Les

PS, on the connector, one of the contacts has a little black spot right in the centre of it that doesn't "erase" away. Mind you, the contact in question has no circuit attached to it, so I gather it is inert. And I also assume it is normal for the connector to have contacts only on the upper surface and not the underside, even though the module has connectors top and bottom.

Edited: 5 May 2012, 1:04 a.m.

#31

I just wanted to let the community know that Diego and I suspect a defective USB programmer to account for troubling behaviour I have encountered. He is kindly exchanging the lot for me, and for his patience with my novice status with Clonix I am grateful.

Reportedly my experience is very uncommon and I hope it doesn't dissuade others who are considering the Clonix family for the HP41. It may take some time, but if there is a problem there is no doubt Diego will make it right.

Cheers to all,

Les

#32

Best wishes Luiz! Hope she gets well soon.

Massimo

#33

Quote:
Hi.

I would very much like to help, but I have just left the hospital right now to get back there in a flash (my 20 YO daughter has symptoms of some virus infection since yesterday). Get back later.


Luiz, you are very kind to write under the circumstances, but Diego has replied and is on the case. Please take care of your daughter and don't worry about me.

Cheers,

Les

#34

You have been so concerned I could not help posting about this...

In brief: I was actually in a hurry, my daughter at the hospital (now she's home, still recovering), and I just decided to look at the messages when I saw Les' three ones about the NoV-64 with no reply at that moment, so I started to read them in order to find a way to help. Suddenly I remembered I had to go back and felt somehow guilty about that and also frustrated not being able to help.

I was so taken by surprise with all of the circumstances I just did not notice I simply wrote my thoughts in the thread while planning what should I take to the hospital.

After reading the supportive follow-ups I felt somehow embarrassed and also glad to know we are all (still) amongst actual people, no exceptions.

So, thanks again. And back to calculators, right?

Cheers.

Luiz (Brazil)

Edited: 6 May 2012, 8:41 a.m.


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP-41 Clonix&NoV's SW Update. (For the non-Primer's guys out there... :-) Diego Diaz 21 1,859 11-13-2013, 09:00 AM
Last Post: Ángel Martin
  SandMatrix Released - The trilogy is complete. Ángel Martin 3 620 08-30-2013, 05:35 PM
Last Post: Marcel Samek
  The 'Complete' Collection Keith Midson 8 1,310 05-12-2013, 09:52 PM
Last Post: Namir
  HP-41CL & NoV(-64): Race condition? Geir Isene 11 1,178 05-03-2013, 01:59 PM
Last Post: Diego Diaz
  My Mostek collection is complete Michael de Estrada 15 1,989 04-10-2013, 10:01 PM
Last Post: Michael de Estrada
  Latest Clonix/NoV's SW update. Diego Diaz 5 691 02-15-2013, 12:12 PM
Last Post: Ángel Martin
  [Clonix/NOV] NoV-64 backwards compatibility Doug (NYC) 0 334 01-20-2013, 11:21 AM
Last Post: Doug (NYC)
  Complete list of PPC members Gonzalo Fernandez 0 291 01-04-2013, 03:01 PM
Last Post: Gonzalo Fernandez
  NOVRAM 64 / HEPAX bug? M. Joury 2 430 11-03-2012, 02:49 PM
Last Post: M. Joury
  HP12C 'complete' collection Keith Midson 9 1,378 08-07-2012, 07:51 PM
Last Post: Keith Midson

Forum Jump: