hp49g ADDTMOD Error



#2

In 11 years of working with this great machine, this is first thing I haven't been able to solve by just reading the manual.

This for the ADDTMOD command from both the soft key and when called within a << >> program.

I am getting an intermittent error condition when, with two integers on the stack, (in RPN Mode, of course) I am getting a generic, "Bad Argument Type".

What makes this even more frustrating, is that it is intermittent. For reasons I still seem to be unable to determine I can still get the command to work and return the correct value, just not all the time.

Any help would be greatly appreciated.

Many Thanks


#3

Hi

Are you sure there is not one of the 2 numbers that is a real number instead of an integer ?

If you use a program, insert a HALT just before the ADDTMOD command : if one (or the 2) number have a point ( for exemple 2. and not 2), this will cause a "Bad Argument Type" error.

What is your version of ROM ? There were many bugs in the first releases of the 49G ROM. I have the 1.19-6,but I no longer use my old 49G.

Edited: 26 Apr 2012, 5:02 a.m.


Possibly Related Threads...
Thread Author Replies Views Last Post
  MS advert shows spreadsheet with obvious error BruceH 3 726 11-14-2013, 09:50 AM
Last Post: Bill (Smithville, NJ)
  HP Prime: Rounding error in determinant Stephan Matthys 3 564 10-25-2013, 09:29 PM
Last Post: Walter B
  Prime Error or Mine? toml_12953 12 1,293 10-22-2013, 10:35 AM
Last Post: toml_12953
  Explaination on How to Reset Caculator in Users guie: error Harold A Climer 5 787 10-15-2013, 02:11 AM
Last Post: cyrille de Brébisson
  Repair of HP-34C - Error 0 and Error 9 Jeff Kearns 3 558 10-11-2013, 12:29 PM
Last Post: Randy
  Do You Think a Listing Error Was Made? Jim Johnson 13 1,207 09-04-2013, 09:23 AM
Last Post: Eddie W. Shore
  HP Prime: Error reports : Here Patrice 111 5,602 07-24-2013, 05:52 PM
Last Post: Thomas Klemm
  PARTFRAC error. Romeu Medeiros 2 474 06-23-2013, 10:27 PM
Last Post: Romeu Medeiros
  WP-34s Documentation error Marcel Samek 9 913 06-13-2013, 10:25 AM
Last Post: Miguel Toro
  HPIB Syntax Error at Status command inaki 3 815 04-06-2013, 07:57 PM
Last Post: Paul Berger (Canada)

Forum Jump: