[WP34S] Mac OS Flashing Tool Won't Flash



#4

This is one for Pascal.

Even though I have no trouble communicating back and forth between my calc and Mac OS X emulator, especially since finding and installing the most up-to-date FTDI driver for Mac, I can't seem to flash using the new flashing tool.

I am preparing the calc for flashing as I do with MySamba--turn ON with EXIT, hold ERASE, RESET, ON, release ERASE, RESET again, ON--but the flashing tool tells me it can't communicate with the calc after I press Send, even though I have chosen the correct port from the list presented.

I know this isn't a dead battery issue, since I can simply go into Windows and flash with MySamba just fine.

Am I doing something wrong here? Is there a different way to prep the calc for flashing? I am pretty sure this is not a hardware issue, as I am up and running perfectly in serial communication between emulator and calc. In particular the SENDA-RECV combo, which is what I use pretty well exclusively right now, works just fine both ways.

I have a 30b, the FTDI usb-serial converter sold by Eric Rechlin, up-to-date FTDI drivers installed, and am trying to flash with the most recent calc.bin file (2706) from the Sourceforge SVN. I am running Lion 10.7.3 on an old iMac with plenty of RAM.

Many thanks in advance.

Les


#5

The new flashing tool is new and in beta status. It works fine on my Mac running Lion 10.7.3 but as not been tested on many machines with many adapters.

If you can communicate from the iMac using SEND/RECV, this is strange. Can you try again with the debug option checked?

Also, you can try to unplug/plug the USB adapter (once) or do reset/ON the WP34s.

Of course, you need to be sure that your XP/Fusion is not running and using the port at the same time.

Another thing: can you download the Windows version of WP34sFlash and try it on the same (virtual) machine you are running MySamba?

Edited: 23 Mar 2012, 2:27 a.m.


#6

I've done some extra tests and whilst the exact same code seems to work 100% of the time from a PC, it has trouble initializing the communication from a Mac. Works sometimes but not always.

I don't know why yet but I'll investigate.

In the meantime, unplugging/replugging the USB adapter works for me.


Possibly Related Threads...
Thread Author Replies Views Last Post
  DIY HP 30b WP 34s serial flash/programming cable Richard Wahl 2 758 12-04-2013, 11:14 AM
Last Post: Barry Mead
  Writing RPL programs on OS X Sean Freeman 18 1,800 11-30-2013, 03:59 PM
Last Post: Sean Freeman
  HP Prime - definitely no education tool bluesun08 5 639 11-17-2013, 11:35 AM
Last Post: Alberto Candel
  "HexZombie - a tool for real programmers" Thomas Chrapkiewicz 8 949 11-16-2013, 12:46 AM
Last Post: Kiyoshi Akima
  HP-Prime firmware update on a Mac Javier Goizueta 5 853 11-15-2013, 10:52 AM
Last Post: Javier Goizueta
  PRIME: re-format the flash drive to recover the operating system Harold A Climer 2 563 11-06-2013, 12:22 AM
Last Post: Michael de Estrada
  WP-34s ISP (flashing cable) again ;( Bernhard 16 1,798 11-01-2013, 05:02 PM
Last Post: Bernhard
  Re: [WP34S] Flashing Issues Les Wright 22 2,461 10-30-2013, 02:16 PM
Last Post: Les Wright
  Bad Flash in HP Prime Han 11 1,246 09-27-2013, 12:38 PM
Last Post: Han
  help flashing a hp30b to a wp34s john mantooth 3 560 09-25-2013, 08:58 AM
Last Post: Thomas Chrapkiewicz

Forum Jump: