Still problems flashing WP-34S



#8

Hi again,

As mentioned in previous postings, I was unable to flash my 30b from Linux or Mac, but I managed to flash it into WP-34S's from a Win7 computer. I experienced a few hangs (as also reported by others) and decided to try latest firmware, but now I am stuck again.

What I did:

on-D
on-STO (reported "Saved...")
on-S

I then connected the cable and tried to upload latest firmware using the "MySamba" program in the same way as for the initial reflashing. No connection.

I have since tried the "erase-reset" combination described here several times, with various combinations of reboots, pulling batteries etc, but still no luck.

Suggestions welcome!


#9

You need to press ON to start the device in SAM-BA mode. Do not leave the batteries in for any length of time if you are unsuccessful. Fresh batteries are always a good idea for flashing.

If the "No connection" error appears instantly then the comport is not recognized by the system. Use the hardware manager to check if the port is available.


#10

Thank you, Marcus!

That was exactly the hint I needed to proceed, MySamba was trying to talk to the wrong port. I rarely have to touch Windows computers, so when I try I am more than a little lost. Looking forward to having a Linux alternative, and if I can help with testing such a program, let me know.

#11

If you simply want to flash you WP-34 then send it to me and I'll do it for you for free.

If you want to help on doing it from a Mac I'm happy to help. I flash mine using a VMWare Fusion system.


#12

Thanks, but my interest is as much in getting it to work, as in the finished product itself. :-)

In your VMWare setup, you run some version of windows in the virtual machine?


#13

I run Windows XP under VM Fusion 4. I can't be bothered to upgrade to Windows 7 as I don't need it. The Windows session is only used for odd things like VMWare session management and stuff like this.

Rob.

#14

Tom, I run XP under VMWare Fusion on two machines. No problem with flashing and re-flashing, provided I follow the erasing and resetting steps set out in that hpcalc.org link.

Les


Possibly Related Threads...
Thread Author Replies Views Last Post
  [WP-34S] Unfortunate key damage with update to V3 :( svisvanatha 5 2,371 12-10-2013, 11:37 PM
Last Post: Les Bell
  WP-34S (Emulator Program Load/Save) Barry Mead 1 1,310 12-09-2013, 05:29 PM
Last Post: Marcus von Cube, Germany
  DIY HP 30b WP 34s serial flash/programming cable Richard Wahl 2 1,880 12-04-2013, 11:14 AM
Last Post: Barry Mead
  WP 34S/43 ?'s Richard Berler 3 1,566 11-10-2013, 02:27 AM
Last Post: Walter B
  My FrankenCulator (wp-34s) FORTIN Pascal 4 1,643 11-09-2013, 06:18 PM
Last Post: FORTIN Pascal
  WP 34S Owner's Handbook Walter B 5 2,064 11-09-2013, 05:34 PM
Last Post: Harald
  wp 34s overlay and programming. FORTIN Pascal 6 2,251 11-08-2013, 01:28 PM
Last Post: Nick_S
  m.dy in display of WP-34S Harold A Climer 3 1,475 11-05-2013, 11:28 AM
Last Post: Andrew Nikitin
  WP 34s : An old problem coming back Miguel Toro 2 1,323 11-05-2013, 03:00 AM
Last Post: Marcus von Cube, Germany
  [WP 34s] Pressure Conversion Factors Timothy Roche 8 2,485 11-04-2013, 07:17 PM
Last Post: Dave Shaffer (Arizona)

Forum Jump: