Flashing a 30B from Linux or Mac?


Has anyone done this?

I tried Atmel's sam-ba for Linux, with a prolific PL2303 USB serial port. Having connected the calculator and prepared it for flashing, I started sam-ba. Sam-ba recognized the serial port, I selected the at91sam7l128-ek board from the drop-down list and pressed the "Connect" button. Sam-ba prints the following lines:

-I- Waiting ...
-I- TCL platform : Linux
-I- SAM-BA CDC 2.11 on : linux
-I- Connection : /dev/ttyUSB0 (target(comType) = 0)
-I- Board : at91sam7l128-ek
-I- Traces Level : 4
-I- target(handle) : file7

(the last of these is printed after pressing "Connect".) Nothing else happens.

Has anyone else tried this? Made it work?


For what it is worth I would also be quite interested in hearing whether anyone has had success with this ...




I understand that the CDC thing has something to do with the fact it won't work.


If that was a tip for me, I hope you can make it a bit more explicit.


I got hold of an Eee running W7. Using that, with MySamba and the same USB<->serial cable, the flashing worked on the first try.

Now how much work would it be to develop a tool like MySamba which works under Linux?


Once again, this is planned and should be available in a few months.


For what is worth, I am flashing all the wp34s with a Mac running Samba in XP in a Parallels session. At the same time, I connect to the store from Safari - seamlessly.

I have been using Windows since I left my father's HP85 in 1983 - and once made the jump to Mac, I am not looking back...

No experience with Linux, though.


José, why SAM-BA and not MySamba? The latter is much faster, it takes about 20 seconds for the complete flash.



Sorry, I meant "mySamba". It is not only much, much faster but as well less prone to stop in mid-download (in case there is any other I/O going on, it is very likely that the download stops with the normal Sam-Ba)


"wine MySamBa.exe" works from Mac and Linux just fine. I never got the Atmel code to work.

More info:


My reflash notes:

To flash existing 34S:

1. Connect cable.
2. Turn ON 34S.
3. Press and hold ON, then D S S (D 6 6), then release ON. Calc will turn off.
4. Press and release ON.
5. Flash with "wine MySamba.exe".
6. Press and release reset button on the cable.
7. Disconnect cable.
8. Press ON. Check VERS and BATT.


The Prolific USB-serial chips seem to be problematic. The FTDI ones seem to work much better.


The Prolific USB-serial chips seem to be problematic. The FTDI ones seem to work much better.

I see this statement repeated but I use a Prolific adapter and all works fine. I shall add that my serial/USB adapter is from 4/5 years ago.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Is Linux common among us RPN types? db (martinez, ca.) 46 9,494 12-11-2013, 08:25 PM
Last Post: Paul Guertin
  EMU41; Dosbox on Linux; Excruciatingly sloooow Geir Isene 9 2,150 12-01-2013, 05:10 PM
Last Post: Geir Isene
  HP-Prime firmware update on a Mac Javier Goizueta 5 1,383 11-15-2013, 10:52 AM
Last Post: Javier Goizueta
  WP-34s ISP (flashing cable) again ;( Bernhard 16 3,968 11-01-2013, 05:02 PM
Last Post: Bernhard
  Re: [WP34S] Flashing Issues Les Wright 22 4,088 10-30-2013, 02:16 PM
Last Post: Les Wright
  help flashing a hp30b to a wp34s john mantooth 3 1,137 09-25-2013, 08:58 AM
Last Post: Thomas Chrapkiewicz
  Flashing cable for HP 20 / 30B Stefan Koenig 3 1,322 09-19-2013, 05:53 AM
Last Post: Marcus von Cube, Germany
  Any 30b cables left? patryk 7 1,747 09-16-2013, 02:54 PM
Last Post: Marcus von Cube, Germany
  HP-30B (WP-34S) Technical Documentation Barry Mead 3 1,177 09-09-2013, 03:07 PM
Last Post: Harald
  USB flashing/Li-po boards patryk 6 1,709 09-08-2013, 12:31 PM
Last Post: patryk

Forum Jump: