Can't seem to flash 30b


I tried to follow the instructions to erase and flash my 30b, but I fear I may have bricked it. I am running Win XP with a direct serial connection (COM1) and am getting "unable to connect" messages with the MySamba Flash Tool from the sourceforge page.

If someone can enlighten me as to the next step to correct this, I'd sure be appreciative.


I'm sure it's not bricked, but the flash has been erased. You will not get anything on the LCD at this stage, as the bootloader does not output to it.

It could be that the batteries are drained (the 30b drains the batteries quickly in this "zombie" state) or that there is a bad connection. Try with new batteries and ensure the pogo connector is properly seated.



Try all the other com ports that show up. When I did this, I wound up needing to use COM8.


COM1 and COM3 are the only ports that are listed. Both have same result.

New batteries did not change the result.


Were you sure to press the calculator ON button after erasing & before connecting with Samba?


So basketballs aren't the only things that can be "bricked?"


I don't know, but I will say that the 30b cannot be bricked, so I can't help your argument.



Here is what I do when it happens:

I follow the whole procedure again, erase, reset, etc
I launch the SAM-BA program, the Atmel one.

It usually connects. Then I quit and launch MySamba and use it to flash.


Admittedly, I use the Atmel Samba to flash and have never used MySamba.


Both work but MySamba is much quicker and less picky with the serial adapter.

To Matt: Pressing ON after inserting batteries or pressing RESET is essential!


If I remember correctly I had this situation once. It only worked when I removed the batteries from the 30b, reinserted them and started the whole procedure from the beginning: connecting the cable, pressing buttons on the cable and the 30b, starting programs exactly as described, even as the display of the 30b didn't display anything.
I only use Atmel's SAM-BA, not MySamba.

Edited: 16 Feb 2012, 12:36 p.m.


I have been able to sporadically achieve a new error (using SAM-BA v2.11):

The applet did not return
Please check the connection and reconnect the target device.


I had a similar problem when trying to use a serial port in a docked computer (where the serial port was on the dock rather than attached to the computer itself.) Changing to a computer with a native serial port solved this. Don't know if this is of any use but there you go.


I am working with a docked laptop. I will try on a desktop with a serial port as soon as I can find one.


Ok, that seemed to be the problem. All is well now. Thank you all for your help.

Possibly Related Threads...
Thread Author Replies Views Last Post
  DIY HP 30b WP 34s serial flash/programming cable Richard Wahl 2 1,649 12-04-2013, 11:14 AM
Last Post: Barry Mead
  PRIME: re-format the flash drive to recover the operating system Harold A Climer 2 1,199 11-06-2013, 12:22 AM
Last Post: Michael de Estrada
  Bad Flash in HP Prime Han 11 2,245 09-27-2013, 12:38 PM
Last Post: Han
  Flashing cable for HP 20 / 30B Stefan Koenig 3 1,402 09-19-2013, 05:53 AM
Last Post: Marcus von Cube, Germany
  Flash Flood Warning: 9/16/2013 (One Week from HHC13) Eddie W. Shore 8 2,078 09-17-2013, 09:20 PM
Last Post: Craig Ruff
  Any 30b cables left? patryk 7 1,839 09-16-2013, 02:54 PM
Last Post: Marcus von Cube, Germany
  HP-30B (WP-34S) Technical Documentation Barry Mead 3 1,243 09-09-2013, 03:07 PM
Last Post: Harald
  HP's thinking behind the 20b/30b? John Ioannidis 3 1,223 09-07-2013, 10:21 AM
Last Post: Tim Wessman
  30b/34s interfacing? ross sponholtz 5 1,541 06-26-2013, 01:41 AM
Last Post: Walter B
  FLASH? command Andrew Nikitin 1 921 06-18-2013, 01:02 AM
Last Post: Walter B

Forum Jump: