Using SAM-BA on Linux and flashing WP34s


I'm trying SAM-BA for Linux and Windows to get it to the point where I can specify a file to upload. I'm using an FTDI USB-to-rs232 port. All I get is two frozen dialog boxes. I can't even get the Windows version running in Wine. Help!

Update: I've gotten the Windows version... but it's sam-ba_cdc.exe, not sam-ba.exe (which still barfs with "abnormal program termination". This time I can select the com port and board type, but the dialog just goes away and the process freezes.

Edited: 13 Feb 2012, 9:26 p.m.


Another update: Managed to get MySamba working under Wine, but I'm not sure if anything is happening. I have /dev/ttyUSB0 linked to com1 but it just keeps saying it can't connect to the calculator. I managed to find a Windows XP machine to try this with. Ran MySamba there, and THAT can't communicate with the calculator. What do I do with a stone dead calculator that I can't tell if it's on or off? Do I need to do the dance of the buttons with the programming cable again?

Update: After insisting that Windows check to make sure the USB-to-RS232 dongle was enabled, I tried again. Oh, look, here's a new com device... com8. Why not? I tried everything else. THAT one did the trick. Now I have a freshly flashed wp34s and am waiting for some more overlays because I botched it the first time.

Quick question: Why can't I key in numerator-dot-dot-denominator to enter a fraction? Instead I have to key in 0-dot-numerator-dot-denominator.

Edited: 13 Feb 2012, 11:59 p.m.


> After insisting that Windows check to make sure the USB-to-RS232 dongle was enabled, I tried again.

...out of curiosity, how do you manage to do that on windows?

(I reached the point of having a dead/bricked 30b, after a couple of hours developing murderous urges towards microsoft... well, an hour is kinda standard just to boot a windows machine, I know, I was prepared, but still...)

Also tried Wine by the way, same issue...


I went through the control panel, add new hardware, and pointed it at the usb-to-rs232. It said the drivers were already installed. After that it was a matter of guessing which com device was the right one.

If I could get the source code to MySamba, I might be able to cook up something for use with Linux natively.

Edited: 14 Feb 2012, 12:43 a.m.


Still no luck; will try with a different setup this week... I find it encouraging though that your formerly bricked 30b came back to life when you solved the communication issue.


Try this sequence: plug in the calculator then press reset and hold for five seconds. Press and hold the on button for five seconds. Now start MySamba.


I'll try that (and Marcus' suggestion as well); but if I start rebooting under windows now (bootcamp'ed Macintosh), I'll end up losing way too much sleep tonight :-)

(There are also a couple of USB->serial adapters that I can borrow with which I'd like to experiment as well).


Check the batteries! A common problem is that the boot loader drains the coin cells with no visible sign of activity. The cable itself draws a significant amount of current, too, even with the calculator turned off. If you are unsuccessful and want to do other things in the meantime then remove the batteries to save their juice! After putting good batteries in you need to press the ON button for a second or two.

If you have the crystal installed and can download the firmware but it does not come up, try the version without _xtal in its name. Then use ON+C to activate it. If the modification is working you will see OK on the display. You can then use the _xtal build which features the stop watch function and does not need an extra activation of the modification.

Edit for typo.

Edited: 14 Feb 2012, 10:11 a.m.


We plan to do it and integrate it in the next emulator.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Is Linux common among us RPN types? db (martinez, ca.) 46 16,037 12-11-2013, 08:25 PM
Last Post: Paul Guertin
  EMU41; Dosbox on Linux; Excruciatingly sloooow Geir Isene 9 3,062 12-01-2013, 05:10 PM
Last Post: Geir Isene
  WP-34s ISP (flashing cable) again ;( Bernhard 16 5,785 11-01-2013, 05:02 PM
Last Post: Bernhard
  Re: [WP34S] Flashing Issues Les Wright 22 5,829 10-30-2013, 02:16 PM
Last Post: Les Wright
  help flashing a hp30b to a wp34s john mantooth 3 1,639 09-25-2013, 08:58 AM
Last Post: Thomas Chrapkiewicz
  Flashing cable for HP 20 / 30B Stefan Koenig 3 1,940 09-19-2013, 05:53 AM
Last Post: Marcus von Cube, Germany
  USB flashing/Li-po boards patryk 6 2,393 09-08-2013, 12:31 PM
Last Post: patryk
  Help with flashing HP30s John Ioannidis 14 4,140 09-04-2013, 09:37 PM
Last Post: John Ioannidis
  Flashing at HHC2013 Kiyoshi Akima 1 1,123 08-30-2013, 09:12 AM
Last Post: Matt Kernal
  Self-made WP-34s flashing cable? Victor Koechli 6 2,893 08-15-2013, 10:11 AM
Last Post: Les Wright

Forum Jump: