Help with HP 41CX - 95% working


I just picked up a 1984 model 41CX and there are a few things that are not working. If anyone can help it would be great, everything is working properly except:

1. The USER key needs a firm press to work (using SF27 instead)
2. The ON key won't work at all (remove batteries and press any key gets it started) - I haven't tried using contact cleaner or this like just yet... (not sure but it may be stuck ON)
3. Running CATALOG 5 (lists all alarms that are set) freezes the display (with 'CAT 5' showing)but after I remove batteries and press any key to restart the calc works fine - well everyting except CAT 5.
4. Time and stopwatch functions seem to work fine, but alarms might be a problem as the display goes blank when I execute any xyzalm command. By removing batteries and pressing any key the calc restarts fine but loses the time so its hard to check xyzalm.

I have already repaired the slightly cracked posts and seem to have good contact between the keyboard-CPU and keyboard-display.

The reason I think the on/off key might be stuck ON is that my fully working 41C doesn't restart by pressing any key after putting the batteries in...



1. Does the user key seem to move normally compared to you C? Does it depress normally but just requires extra force to get it to register?
The user button uses the same kind of switch as any other key you should be able to feel the "click" when the dome under the key distorts, if it seems to operate normally, but you have to lean on it to get it to register that would suggest there is contamination under the dome.
2. Again does the action of the on switch feel ok? If it feels ok when the calculator is turned on what happens if you press shift then on? It should display the time.
3&4 These do not sound good. It seems that these functions are causing the calculator to go off into the weeds perhaps there is a faulty component on the CPU card. Access to a diagnostic ROM would be useful here.

I don't think that the problem is the on key being stuck on, I tried holding the on button while inserting batteries and I do not see the behavior you describe on one CX that has been sitting without batteries for a long time I got the memory lost message on the others, two CVs and a CX if I hold the on key while I insert batteries it will not power on when I press a key. The on button does have one unique connection to the CPU card, it is the only button on row 9. So perhaps you still do have a connection problem between the keyboard and CPU card. If your calculator has the elastomer or "zebra" connectors these are know to be problematic in 41s the interface that is two plastic tube with wire ring around them are much more reliable.

If you are really brave you could swap CPU cards with your C, the keyboard and display is identical.


thanks very much for the quick reply. My comments to yours below:
1. The USER and the ON keys feel very normal in operation and the click is distinct as with all keys.
2. When the calc is on and I press shift ON, I get the same response as just pressing ON - the display goes blank and the only way to restart is to remove batteries very briefly, reinsert and press any key. The calc then operates 'normally'again.
3 & 4. Diagnostic ROM - not sure what/where to get this kind of help?

Connectors shown in this photo:

Any furhter suggestions?


Well it does indeed look very nice inside, I can't really make out what the interconnect is from your picture, however the plastic frame around the interconnect looks like the one that was used with the elastomer interconnect, and as I said previous if it is the elastomer one they can be bad news in a 41. I know of a source for the better interface which is tiny wires wrapped around a hollow plastic rod, for a good picture of this interconnect go to If your CX does have the elastomer interconnect it is likely at least part of your problem.

For the diagnotic ROMs the images are available on a another site, however you need a ROM emulator of some sort to store them on, I built a ROM emulator just so I could use the diagnostic ROMs as well as HPIL related ROMs.


Unfortunately, as described, it has all the signs of a ROM failure. An HP service rom would be the fastest way to debug.

FWIW, only early CV's had the nasty pink internconnects. The CX pictured has the last version gold devices.


Upon much closer inspection, I would recommend you clean the flux from the display driver contacts. Use the solvent sparingly, otherwise it will get into the four switch domes at the top of the keyboard.

The reason: the bus is exposed there, any contamination can make rom and ram look defective.


I had a closer look and I see what you mean, there is a lot of flux around the solder on the keyboard circuit board where it connects to the display board:

I will try careful cleaning and let you know.


Possibly Related Threads…
Thread Author Replies Views Last Post
  HP Prime Save Power Turn Off Not Working Timothy Roche 12 4,167 10-27-2013, 01:41 PM
Last Post: Michael de Estrada
  Temporary User Mode Key Programs not working in RPN BruceTTT 7 2,720 10-14-2013, 01:46 PM
Last Post: BruceTTT
  HP-97 suddenly not working Brad Barton 10 2,801 02-25-2013, 08:15 PM
Last Post: Brad Barton
  [41CL] Problem with PowerCL ... not working Doug (NYC) 5 1,989 01-22-2013, 07:18 PM
Last Post: Doug (NYC)
  42S exit key not working dwsmith 4 1,668 11-05-2012, 10:59 AM
Last Post: dwsmith
  HP-46 not working Ignacio S├ínchez 1 1,018 10-24-2012, 11:17 AM
Last Post: Donald Williams
  [WP34s] last QtGui version not working fhub 8 2,499 08-31-2012, 05:08 PM
Last Post: fhub
  Modfile not working with Win 7 x64 Richard Wagoner 6 2,268 07-04-2012, 10:32 PM
Last Post: Diego Diaz.
  Working on HP's again Les Koller 49 12,999 06-20-2012, 01:29 AM
Last Post: Thomas Radtke
  held breath, found tapes & drive working Garth Wilson 9 3,137 06-12-2012, 12:52 AM
Last Post: Garth Wilson

Forum Jump: