HP41 Card Reader repairs



#5

I just finished replacing the "gummy" wheels on my two card readers with pairs of 'O' rings. The 'worm gear' on one of them seemed loose on its motor shaft, so I used a tiny amount of 'super glue' to fix it as recommended in one article. After much tearing out of what little hair I have left, I was able to re-assemble them both OK.

Both now work reasonably well. The one which I didn't need to glue works silently; it gives occasional checksum errors, but I can live with it. The other one is quite noisy, often shows MALFUNCTION, sometimes shows CHECKSUM error, and about one time in 5 passes it works OK.

Since doing the repairs, and a bit late in the day, I've learned through old postings on this forum:

1) There is a clutch mechanism between the motor shaft and the gear; so perhaps gluing the two together was not a good idea

2) The wheel shaft is eccentric and can be adjusted using the screwdriver slot for optimum pressure on the card.

3) 'O' rings might not be the best replacement solution because they apply uneven pressure.

So now I don't know what to do:

Should I pull them apart again and swap the 'O' rings for something else? If so, what?

Do I need to separate the glued shaft and worm gear, and try to implement a replacement clutch assembly? If so with what?

How important is it to have the drive wheel position adjusted correctly? Is there a recommended way to do it.

Grateful for any advice from the group. I'm not keen to pull them apart again, but neither do I want premature wear or damage to cards.

Regards,
Steve


#6

Quote:
1) There is a clutch mechanism between the motor shaft and the gear; so perhaps gluing the two together was not a good idea
Urban legend. HP called it a coupler, not a clutch. Attaching with glue is perfectly acceptable.

Quote:
2) The wheel shaft is eccentric and can be adjusted using the screwdriver slot for optimum pressure on the card.
HP service procedure is to power the motor from a 3 volt dc source (motor leads disconnected from electronics) and adjust the eccentric for 180 +/- 20 ma current while holding a card in place under the drive roller. What you'll find with most o-rings is the current will be on the high side (200-250ma) and the easiest procedure is to simply position the small molded indicator dot on the eccentric to be opposite the motor, the screwdriver slot perpendicular to the card path.

Quote:
3) 'O' rings might not be the best replacement solution because they apply uneven pressure.
Not true at all, they just might not last as long as a solid face roller. In practice, they are far better and easier for the one-off home repair as they provide a consistent OD, something that is most times difficult to obtain with silicone tubing. The typical usage failure with o-rings is the wrong size. Should be US size 005. When placed on the shaft the OD should be very close to 0.250 inches. Better to be a little undersized than over. I know one eBay seller had be providing rings that were too large, don't know if that is still the case. FWIW, seller Waterhosko's are correct.

#7

Randy,

Thanks for that. I think, then, that I'll simply strip the slightly noisy one and try adjusting the eccentric.

Thanks again.
Steve


#8

If you tear it back down, remove the gear/o-ring assembly and check the motor current with the drive screw only. It should be less than 40-50ma. Any more than that means the lead screw is not attached on center or is not fully seated. Either of these would likely cause noisy operation.

OTH, if the eccentric is set with the dot to the motor side, the motor current is sky-high and this would be the cause.

Squealing is also caused by bearing noise. The very end of the worm screw shaft where it enters the plastic frame has a thrust bearing inside the plastic. A micro-drop of plastic safe oil on the end bearing of the shaft cures most noisy readers.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Reasonable price for a 41C, Quad Mem, Time, Navigation and Card reader module? Eelco Rouw 10 973 12-12-2013, 01:52 AM
Last Post: Eelco Rouw
  hp-67 card reader problem. Marcel Samek 5 590 12-09-2013, 09:09 PM
Last Post: Paul Berger (Canada)
  HP 41CV Repairs William Mabotja 3 369 11-20-2013, 04:45 PM
Last Post: Mike Powell
  HP-97 card reader pinch roller axle davorin 2 360 09-15-2013, 08:47 AM
Last Post: aj04062
  HP-97 Card Reader davorin 3 371 09-13-2013, 04:21 PM
Last Post: Stephan Matthys
  HP-67 Card Reader Repair Question aj04062 1 305 08-08-2013, 11:15 AM
Last Post: Randy
  Hp-67 card reader: tantalum capacitor identification Ignacio Sánchez 8 728 06-02-2013, 07:26 PM
Last Post: aj04062
  Testing card reader motor for 65 Michae Altmann 2 354 03-17-2013, 09:24 PM
Last Post: Randy
  Repaired HP-97 card reader doesn't show any signs of life jbssm 6 554 02-17-2013, 03:15 AM
Last Post: Alberto Fenini
  HP 65 card reader problem H Fischer 3 360 11-24-2012, 12:11 PM
Last Post: H Fischer

Forum Jump: