[wp34S] PSTO Won't Write to 6 thru 9



#2

Hi guys,

In my 30b-based wp34s, I have been fiddling with flashing and internal storage, etc.

I am chagrined to note that I same to only get access to libraries 0 thru 5 with the PSTO command. On my calc, the function won't accept 6 thru 9 as a parameter for the function.

All is well with the emulator, and I can PSTO to all ten libraries, just like the manual says I should.

Do I possible have a bad calc with bummed flash memory? It would be a shame to miss out on those extra 2000 program steps.

I am still using 2.2

Les


#3

Some of the flash regions have been used to implement new functions such as matrix support.
This restriction does not apply to the emulator.

#4

The number of flash regions had to be reduced. The cost of the matrix functions primarily.

The emulator has no such restrictions since it isn't really limited by memory or disc space.


- Pauli


#5

Whew! My 30b was a new but open box TAS sale. The price was right, but I was worried I had a hardware issue.

This issue does apply to 2.2, right? So all is normal with my calc?

Thanks,

Les

P.S. Another little glitch in this is that an askew insertion damaged a pin in my cable! Just ordered a fresh one from Gene. Dang, those little pins are delicate and I thought I was taking care. Take caution, guys!


#6

Yes this applies to 2.2. Matrix functions are present -- they aren't small.

Thus far, all the 3.x functionality has been done in a flash neutral manner -- in fact we've (Marcus predominately) saved enough to regain one flash region in addition to providing the extra functionality.


- Pauli

#7

Took the opportunity to update not only the v3.0 manual but v2.2 as well. Your calculator is perfectly alright :-)


Possibly Related Threads...
Thread Author Replies Views Last Post
  [WP34S] WP34S firmware on the AT91SAM7L-STK dev kit? jerome ibanes 1 344 10-04-2012, 04:59 PM
Last Post: Paul Dale
  HP-97 Write Error Colin Verrilli 6 562 09-09-2012, 01:57 AM
Last Post: Luiz C. Vieira (Brazil)
  HP41 Card Reader won't read and write Bruce Larrabee 5 557 07-31-2012, 06:33 PM
Last Post: John Robinson
  HP48SX seems fully functional won't run SELF TESTS? Bruce Larrabee 5 553 07-16-2012, 11:04 PM
Last Post: Luiz C. Vieira (Brazil)
  HP-67 won't run on batteries David Ramsey 5 524 04-18-2012, 12:15 AM
Last Post: David Ramsey
  [WP34S] Mac OS Flashing Tool Won't Flash Les Wright 2 377 03-23-2012, 03:59 AM
Last Post: pascal_meheut
  HP won't fix PSE bug on 15CLE? MK-52 14 946 12-18-2011, 03:51 PM
Last Post: Eddie W. Shore
  [wp34s] Incomplete Gamma on the wp34s Les Wright 18 1,249 12-06-2011, 11:07 AM
Last Post: Namir
  [wp34s] Romberg Integration on the wp34s Les Wright 2 409 12-04-2011, 10:49 PM
Last Post: Les Wright
  12c won't turn on --- options? Gene Wright 8 614 10-28-2011, 10:45 PM
Last Post: gene wright

Forum Jump: