HP97 card reader followup



#16

Some progress with the card reader.

For the non-rolling nylor roller, I carefully cut away some material circumferentially from the thicker spinel using a razor blade and magnifier glasses, until it dropped in place without difficulty, and rolled freely.

For the disintegrated coupler, I used the insulation from an 18G wire, surrounded by silicone within the aluminum tube. With this, the motor would move the card through slowly, reaching 180 mA current without any resistance, but there was lots of slippage. I ended up gluing the couple/worm gear assembly to the motor shaft with a drop of super glue. Now there's no slippage, but the motor is taking over 300 mA and moving slowly, and the calculator is detecting the error and shutting down the motor.
Here are a couple of pictures, taken before re-assembling the reader:

It seems the motor control is working properly, but somehow there is too much resistance.

Does the roller look too thick? It is almost exactly flush with the metal disc base.

Thanks for any additonal suggestions.

Happy Thanksgiving!

Dave


#17

I'd try adjusting the eccentric shaft that supports the gear. If it is all the way "up", the resistance will be high. Backing this off (by rotating) will reduce the drag/friction.


#18

I've finally located my copy of the museum CD, and, as you mentioned, it suggests rotating the pin until the motor resistance is 180 +/-20 mA when trying to roll a card against resistance. However, I'm getting over 300 mA regardless of the position.

Can someone explain how this works? The manual refers to this as an eccentric cam, but it doesn't look very eccentric to me--it looks fairly symmetrical about the axis. I measure a diameter of 0.91", uniformly about the cam. Perhaps that's part of the problem. Is it supposed to be curved?

I took some pictures. Please forgive the fuzzy focus. Here is what it looks like:


If this is supposed to be able to be curved or ellipsoid, then that may explain the high resistance to the card. Can someone post (or email) a picture of the cam if it's supposed to look different?

Thanks!

Dave


#19

Look very closely at the end of the shaft where it is reduced to fit in the frame. That smaller very short section is slightly eccentric to the long shaft that supports the roller. The shaft of the pin itself is round. Problem is that if the diameter of the roller is too large, then the drag force will be too large regardless of how you adjust the cam.

Edited: 24 Nov 2011, 5:03 p.m.

#20

Quote:
Does the roller look too thick? It is almost exactly flush with the metal disc base.

The diameter of the metal disc base is 0.62mm. A roller with an outer diameter with no more than 0.65mm is ok.


#21

Would that be 6.2mm?


#22

Correct. Sorry my mistake.

#23

Getting closer. I hadn't realized the peg at the end is slighly eccentric. It is almost imperceptible, but I believe it is slightly eccentric. It is possible that I didn't push the cam in far enough to engage the eccentric peg at the end.

After pushing in the cam all the way to ensure engaging the motor, the motion of the card through the reader is slow and slightly jerky, but the card goes all the way through. The calc can at least attempt to write to the card, sending it through the reader, but when I attempt to read back (for example, writing a program to the card, then switching back to run mode), the card passes through, but generates an error.

When I say the card goes all the way through, I mean that a tiny tug is required to pull the card out at the end. However, my HP65 reader appears to work this way as well. The HP97 speed is about 1/2 to 2/3 that of the 65.

When I insert the card and hold it rather than let it go freely through, the motor current is about 350 mA. I suspect that this is because I superglued the motor shaft to the coupling, so that there is truly no slippage. Can anyone who has done this coupler/"clutch" repair comment on this?

Thanks,

Dave


#24

There is not supposed to be any slippage, period. It is not a clutch. Please stop this line of reasoning lest you incur the wrath of the great Randy.

Edited: 24 Nov 2011, 10:10 p.m. after one or more responses were posted


#25

Hi Michael,

I'm glad to hear that since, as I mentioned, I super-glued the shaft of the motor into the vinyl insulation sleeve. I will say that I was not comfortable with having the shaft slip in the sleeve, since it seemed a very unreliable setup. I only repeated it because I have seen it here, but the manual (which I have now that I found my CD copy) certainly doesn't mention a clutch. However, there is an article in the articles forum that may need to be corrected.

Then, would it be correct that the roller is supposed to slip over a restrained or jammed card, at the right cam setting? That would explain how adjusting the eccentric cam could affect the motor current when holding the card so it can't roll through.

If the current is too high, and the card is going through slowly and slightly jerkily, then I am guessing there's too much friction in the system, and too much torque on the motor. Although I had believed my tubing on the roller is not too thick, perhaps I need to find a smaller caliber solution.

Does that line of reasoning sound reasonable? Does anybody have suggestion of a specific size of silicone tubing or O-ring that is known to work reliably?

Thanks,

Dave

Edited: 24 Nov 2011, 9:11 p.m.


#26

Yes, a card jam should not cause the motor to stall, which could damage it. To that extent, the slipping roller could be considered a clutch of sorts. As to the O-rings, that is the method that I've always used, and have bought them from sources like this. I've found that the best way to secure them on the wheel is to use a bit of superglue. I'm not sure what size they are nor the durometer value. I believe they are Viton. There are some people on this forun who do know and might chime in.

#27

Quote:
Does the roller look too thick? It is almost exactly flush with the metal disc base.
Yes, it is too large and is the reason for the over-current. It should be *exactly* flush with the metal part of the wheel - which is 0.250 inches in diameter.

The correct o-ring size is 005. I have rebuilt many card readers that had high current and did not read reliably, the problem was incorrect o-rings. I know at one time, one of the eBay sellers was selling rings that were too large. Here is a link to my source:
http://www.mcmaster.com/#o-rings/=f35yqm Part number is 9452K13, cost is $1.93 for 100 pieces.

Edited: 25 Nov 2011, 9:25 a.m.


#28

What O-ring material do you recommend. I see from your source that they offer Viton with A75 durometer hardness. Also, the OD of the #005 size is 0.241", not 0.250" that you recommend. Does the O-ring expand to 0.250" when it's installed ?


#29

In this application, I don't think you'll find a difference between A70 and A75 hardness... and yes, they expand when stretched over the hub. IIRC, they end up a few thousandths over .250 inches - but certainly not as large in diameter like the tubing shown in the OP.

IMO, while tubing *appears* to provide more surface area and is likely to last longer, rings provide a far more consistent result than tubing. If you're lucky enough to find a piece of tubing that is of the correct size and is concentric enough to work, have at it.

#30

Thanks! I have followed the link and placed the order. I will report the result once I have placed these o-rings.

Best regards,

Dave

Edited: 25 Nov 2011, 2:08 p.m.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Reasonable price for a 41C, Quad Mem, Time, Navigation and Card reader module? Eelco Rouw 10 711 12-12-2013, 01:52 AM
Last Post: Eelco Rouw
  hp-67 card reader problem. Marcel Samek 5 433 12-09-2013, 09:09 PM
Last Post: Paul Berger (Canada)
  HP-97 card reader pinch roller axle davorin 2 272 09-15-2013, 08:47 AM
Last Post: aj04062
  HP-97 Card Reader davorin 3 271 09-13-2013, 04:21 PM
Last Post: Stephan Matthys
  HP-67 Card Reader Repair Question aj04062 1 220 08-08-2013, 11:15 AM
Last Post: Randy
  Hp-67 card reader: tantalum capacitor identification Ignacio Sánchez 8 526 06-02-2013, 07:26 PM
Last Post: aj04062
  Testing card reader motor for 65 Michae Altmann 2 256 03-17-2013, 09:24 PM
Last Post: Randy
  Repaired HP-97 card reader doesn't show any signs of life jbssm 6 388 02-17-2013, 03:15 AM
Last Post: Alberto Fenini
  Disaster: help for a couple of HP97 needed! Jose Gonzalez Divasson 10 484 01-21-2013, 04:45 PM
Last Post: aurelio
  HP 65 card reader problem H Fischer 3 258 11-24-2012, 12:11 PM
Last Post: H Fischer

Forum Jump: