WP34s -- not turning on after flash


I have flashed the 30b several times, but now it will not turn on after a flash. I got all the correct messages, set boot from flash, execute, cable reset, on button : blank screen.

I also went through the entire erase procedure from scratch and same thing happens.

Any suggestions?


did you try popping the batteries out and back in again?

Last time I tried to flash, I got the same thing. I remembered something Neil had told me that sometimes the calculator will appear to be dead but actually still be on at full power. So the recommendation was to pop the batteries out if I was going leave the calculator for a while.

Anyhow, I did this, and when I put the batteries back in it turned on properly!


Yeah, tried that.. will try again...


the corollary to that is that if you didn't pop the batteries out immediately they may be dead.


Maybe I've uploaded a binary that does not work so try the V21 install if in doubt.


Still no go. Everything appears normal in the flash process. It just won't turn on.


David, try MySamba.exe, please! Can yo reflash your calculator with the original 20b firmware?


Can you provide a link to the MySamba.exe program?

I don't have the original 30b firmware to try.





Problem resolved!

Thank you Marcus, Gene, Dominic, and Jeff!

The problem was that when I downloaded calc.bin I right clicked and "save link as" on the calc.bin file. The resulting file was only 8k in size. The correct file would be ~121k. This 8k file would give the appearance of flashing but obviously would not work.

The proper method of downloading from the SVN page is to double-click the calc.bin file then select the download link.

It is interesting that even flashing the correct file did not solve the problem. I had to flash the original 30b rom back into the unit and then reflash with the WP34s rom. The unit worked just fine after that.

Also the lead to use MySamba.exe was very helpful, it is much easier to use and very fast.

Wonderful support from all you guys. What a joy. Thank you!



oh yeah, I had forgotten that I had done that too once. The clue for me was that SAM-BA wasn't doing 14 or 15 segments, only 1.

Possibly Related Threads…
Thread Author Replies Views Last Post
  DIY HP 30b WP 34s serial flash/programming cable Richard Wahl 2 2,533 12-04-2013, 11:14 AM
Last Post: Barry Mead
  PRIME: re-format the flash drive to recover the operating system Harold A Climer 2 1,727 11-06-2013, 12:22 AM
Last Post: Michael de Estrada
  Bad Flash in HP Prime Han 11 3,256 09-27-2013, 12:38 PM
Last Post: Han
  Flash Flood Warning: 9/16/2013 (One Week from HHC13) Eddie W. Shore 8 2,874 09-17-2013, 09:20 PM
Last Post: Craig Ruff
  FLASH? command Andrew Nikitin 1 1,211 06-18-2013, 01:02 AM
Last Post: Walter B
  [EXCLUSIVE FLASH] Infos about new HP Prime ! Mic 16 4,072 04-02-2013, 11:06 AM
Last Post: Frank Boehm (Germany)
  No luck getting flash disk to work in 95lx Harald 7 2,946 03-18-2013, 08:11 AM
Last Post: Harald
  [41CL] Repairing an image in Flash Monte Dalrymple 0 899 01-24-2013, 07:01 PM
Last Post: Monte Dalrymple
  [WP34S] WP34S firmware on the AT91SAM7L-STK dev kit? jerome ibanes 1 1,214 10-04-2012, 04:59 PM
Last Post: Paul Dale
  DIYx flash bootloader Eric Smith 11 2,769 09-19-2012, 07:01 PM
Last Post: Eric Smith

Forum Jump: