HP-65 strange card writing error



#5

I have an HP-65 that I refurbished a few yars ago (new drive roller, clutch, cleaned head & leaf switches, etc. and well lubed).

It was working perfectly until today. I can read cards fine. I can write cards and then read them back in and get a steady "0.00".

However, when I switch to W/PRGM, in addition to the normal keycode display, I see minus signs at the left and right ends of the display. And the program does not run properly, the display just flickers dimly. This strange behavior only happens with cards that I have recently written to. Standard Pac cards, and cards I recorded a month ago read and run properly and don't display the minus signs.

AFAIK, the most likely culprit with write failures is the leaf switches. But I have not read any mention of the strange display. Could the switches be "marginal" - making intermittent contanct (somehow getting out of adjustment by just sitting on a shelf)? or maybe some electronics are finally dying (caps, coils, etc.)

Anyone seen this before?

-John (3665)


#6

Hi John,

Did you replaced the tantalium caps next to the head amplifier circuit and on the back of the motor ? A lot of strange cardreader errors are caused by a cap with a high ESR value. Also important is the condition of your battery pack because the head amplifier gets it supply directly form the battery, if the internal resistance of the pack is getting high you also get unpredictable results. A bad battery pack also causes the a short battery life.

-Rik


#7

Hi Rik,
Which are the values of these tantalum caps? Are the same for an HP-67? Thanks,
Albert


#8

Hi Albert,

According to the HPCC schematics from Tony Duell they are 22uF, there is also one on the motor for supression of the commutation spikes.
Keep in mind that Tony some times makes a typo so the value could also be 2.2uF, but you'll see the value when you open the calculator.

-Rik


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP50g: Writing a function that returns a function Chris de Castro 2 447 12-10-2013, 06:49 PM
Last Post: Han
  Strange HP 25 Problem (Repair) Onur Ilkorur 5 557 12-06-2013, 05:13 PM
Last Post: Onur Ilkorur
  [HP Prime] "Error while checking exact value with approximate value, returning both!" Chris Pem10 13 1,081 12-06-2013, 05:12 AM
Last Post: parisse
  Strange Battery Icon during updaate of Prime Firmware. Harold A Climer 7 784 12-05-2013, 04:40 PM
Last Post: Michael de Estrada
  Writing RPL programs on OS X Sean Freeman 18 1,200 11-30-2013, 03:59 PM
Last Post: Sean Freeman
  MS advert shows spreadsheet with obvious error BruceH 3 440 11-14-2013, 09:50 AM
Last Post: Bill (Smithville, NJ)
  HP PRIME : strange behavior when trying user key capability Damien 12 873 11-03-2013, 11:02 AM
Last Post: Joe Horn
  [HP-Prime] - Shortcuts for program writing Jean-Michel 4 430 11-01-2013, 07:55 AM
Last Post: Jean-Michel
  HP Prime: Rounding error in determinant Stephan Matthys 3 348 10-25-2013, 09:29 PM
Last Post: Walter B
  HP Prime Error: Summation Upper Bound > 1000 HP Pioneer 2 287 10-25-2013, 11:32 AM
Last Post: steindid

Forum Jump: