I keep getting a Fatal error with SAM-BA v.2.10


I keep getting a Communication Error regardless which USB port I put the cable with the adapter.

There is no place to find SAM-BA v.2.09 on AMTEL's website.

I also can't get MySamba to "find" a connection port.

Now I probably have a dead calculator with no hope of ever bringing it back.

Edited: 7 Oct 2011, 9:06 a.m.


I also can't get MySamba to "find" a connection port.

That's strange. Does the adapter register in Windows? Do you see it in device manager?


Not at first. Windows recommended me a web driver which I installed. It did not work. I'll try it from the CD and see what happens.

The USB to Serial Adapter I am using an Aluratek one (AUS100)

Update: The CD was absolutely no [insert bad words here] help! I doubt the CD even had the driver to begin with. Now I am trying the Aluratek website. If that doesn't work - it's going back to Staples for a refund (if I can get one).

Update #2: After reinstalling the Aluratek driver again, I restarted the computer. Then I get an "Installing device driver software" message, and taking a long time do so, I finally get a success (COM 4). Running SAM-BA, I select com4 and nothing happens. So I try running it again, and get only com3 (which I was unsuccessful before).

I plug the cord in another port - it is COM 5. So I run SAM-BA again and nothing happens.

I am running Vista and it supposed to work on Vista.

MySamba doesn't read the port at all.

I am so frustrated - it worked when someone else does it.
(The next computer I buy will be a Mac - I am getting sick of Windows)

Edited: 7 Oct 2011, 9:54 a.m. after one or more responses were posted


Are you running Windows 7? Before installing 2.10, did you tell it to run in Win XP SP2 compatibility mode?


I have Windows Vista (unfortunately). Now I am beginning to see why everyone hates it.


I am also getting an error in the Start up script when I unplug the cord.

I am reinstalling SAMBA - this is my last attempt.

Edited: 7 Oct 2011, 9:57 a.m.


I successfully did it with Windows Vista, see article 1060.

Note, use the SAMBA without the "_cdc" tag.


It still doesn't work! The SAM-BA 2.10 (non CDC) does not work. - at least not on my laptop. I still get the same communication error.

Next time there is a major update on the WP 34S, I just buy another one.

I now have to head to work, a very frustrated person.

Edited: 7 Oct 2011, 10:26 a.m.


... a very frustrated person.

Yes, I can imagine that. (My laptop screen doesn't work - after a metal object impacted it at speed. Fortunately it has an external screen connector)*.
Wish I could be of more help, but the replies here have already addressed those problems I could think of.

Edit: *this was not due to WP-34s, but unrelated Vista "anomalies".

Edited: 7 Oct 2011, 10:52 a.m.


Can you elaborate on that? I am not a Windows user.


Can you elaborate on that? I am not a Windows user.

In the "How to get started", it is step 4:

How to Get Started


The USB to Serial Adapter I am using an Aluratek one (AUS100)

i've downloaded the drivers from the Aluratek website and can confirm they are for a Prolific PL2303 chip, driver package v130.

it is likely that ALL the problems you are seeing are related to the drivers you have downloaded and the PL2303 chip. many of these chips are chinese forgeries (it happens to be a chip that is easy to duplicate), and the current bug-free prolific drivers will detect a fake and refuse to install - hence only outdated prolific drivers will work. also, the PL2303 itself (even genuine ones) requires external level shifters to drive RS232 correctly, which many adaptors lack.

bottom line - all hope was lost once you walked out the staples store. return the USB/serial adaptor and buy one that uses anything other than a prolific PL2303 chip.


I noticed the PL2303 chip on the two that I bought. I'll have to go on a mission to find such a cord (maybe Fry's? Best Buy?).

Thanks, Robert.

Marcus, one way or another I am going to get the calculator to work again - I can't wait to try out those matrix functions... even if I have to buy one from you.


Now I probably have a dead calculator with no hope of ever bringing it back.


I am sure that there is hope to bring it back. If worse comes to worse, I'll bet that lots of people would volunteer to re-flash it for you. I'd be happy to do so, but there is probably someone within reasonable driving distance who could do it for you. Of course, getting it to work yourself would be ideal. I have a Vista machine that I keep meaning to try it on. I bought an EasySYNC ES-U-1001-R10 USB to serial converter which is supposed to work and have drivers for Vista. I’ll let you know if I have success.

Did you remove the batteries from your 30b? If I recall correctly, it runs at high power and won't shut itself off once it is erased.


I tried on my 20b, in the worst case scenario that it didn't work. At least I have working WP 34 on the 30b.

I will see if I can find the cord you suggested, Jeff. Pleaser let us know what happens.

And the batteries were taken out after the failed attempts.

Thanks for your help, guys. I am sorry I can't report better news.

Edited: 7 Oct 2011, 10:32 a.m.


You should still use a DMM to check the battery voltage or swap the batteries with your 30b (after doing a ON+STO of course!)


You may have several layers of driver cruft from multiple installations. Try removing all the USB serial ports with device manager, rebooting and reinstalling. Vista has an XP mode too, if I remember correctly.

Having said all that, I think Marcus knows what he's talking about with respect to the chipset. In any case you should try to clean out the old ports before trying to install a new driver for the new cable.



I was able to successfully flash a 20b on my Vista PC. Here is how I did it:

1. bought an FTDI ES-U-1001-R10 USB to RS232 adapter. I bought it direct from FTDI, cost about $30 shipped. I did this several weeks ago.

2. I did not use the installation CD that came with the converter because it did not list Windows Vista (or XP) on the instruction card that came with it. It said "For other O.S. and later driver releases, go here": http://www.ftdichip.com/Drivers/VCP.htm, so I did. Then I clicked on the setup executable link over in the comments section for Windows operating systems, and let it install the drivers.

3. Then I plugged in the USB to Serial converter, and windows told me that it successfully installed the drivers for my device and told me it was COM10.

4. Went to sourceforge and downloaded the latest bin file and Marcus' new version of MySamBa

5. Connected the cable to my 20b, and did the sequence of button pushes* to get it ready for flashing.

6. Started MySamBa. Nothing in the COM port dropdown. Crap. Stopped MySamBa. Started again, same result.

7. Right-clicked on the MySamBa.exe file and chose properties, clicked on the "Compatibilities" tab, and checked the box to run it in compatibility mode for Windows XP (Service Pack 2).

8. Started MySamBa - COM10 now availalbe in the dop down. Navigated to the bin file, clicked download, and successfully donwloaded the rom to my 20b.

If I can do this, anybody can because by-and-large, computers hate me.

* - Not sure if this is the official sequence, but what always works for me is as follows-

- turn calculator on

- plug in cable

- press and hold ON key on the calculator

- press and hold the Erase button on the cable

- press and release the Reset button on the cable

- release the Erase button on the cable

- release the ON key

- press and release the ON key

- click on download in MySamBa



I got an ES-U-1001-R100 USB-to-Serial adapter from Amazon and it works for me under Windows 7 without any driver installation. SAM-BA 2.10 also installed without issue for me. Perhaps this worked so easily as it's an HP laptop :-).



I have two Easy Sync cables coming this week. Thank you so much for helping me get my 20b back to life on Sunday, Gerry!

On a side note, my laptop is in defragmenting mode - it's been a day and a half ever since Sunday at 11 PM.


I don't know what's wrong with me, but nothing works. I am following the steps and the suggestions but for some stupid reason I still can't get a stupid connection - not with Samba, MySamba, not with one connector, or another one I bought at the bookstore. I must have downloaded the stupid driver three or four times. I even put new batteries and not even the ON+STO combo can't bring it back to life.

I'll try it on another computer - maybe I'll have better luck.

Thanks guys for your advice. When HP fixes the PSE bug, I hope I can get HP to swap two machines for my old ones.

Edited: 7 Oct 2011, 10:24 p.m.


Based on all I have read here, I suspect both of your USB to serial converters. Your best bet may be to find a Windows XP machine with a real serial port if you can.

When (if?) HP fixes the PSE bug, go over to Gerry Schultz's to reflash your 15c LEs.


Maybe I'll try at work (if I can get away with it...). Maybe I'll luck out and find a store that actually sells a converter that works. Or have Gerry do it for me.


HP: You really need make it so that the average dumb-behinds like myself can just plug in the calculator with a regular USB port without any adapters to update the software - like the 50g.


Here's my recipe using SAM-BA.

By the way, I felt had to write this because the manual refers to another document for some important steps, then directs you back to itself for some others. I found actually trying to follow this with two PDFs open, one with very nice and helpful pictures that make the steps not fit on a single PDF page, was very difficult. There needs to be a canonical list of instructions in one place.

connect cable to PC and calculator
on the calculator/cable:
press and release ON/CE
Press and hold ERASE on the cable
press and release RESET on the cable
press and release ON/CE
release ERASE on the cable
press RESET on the cable
press ON/CE
start SAM-BA on the PC
in SAM-BA:
choose serial port and board at91sam7l128-ek
press connect
browse to the calculator image (calc.bin)
wait for the download to finish
say "no" to the lock regions dialog
in the scripts area, select boot from flash
press execute
back on the calc/cable
press RESET on the cable
press ON/CE machine should start
press [H] X.FCN to get the function menu
press the 3 (V) key to jump to the VERS command.
Press XEQ
Compare the version number to the expected one.
Marvel at the tiny "r" in Walter's name. :)

Hey Eddie, I flashed your 20b at the HHC Conference and can do it again if you like. I'm in West LA and my work email is gerald dot schultz at fox dot com. My home email is g (underscore character) schultz at ca dot rr dot com. We can set up a time this weekend to get together and I can try re-flashing it.




I think I am going to have to take you up on your offer. Thanks for flashing it for me at the conference.


I would recommend using the new MySamba. The old one wouldn't show any com ports of any variety in win7. It works great on xp, win7 with all 3 usb<->serial adapters I have.


Edited: 7 Oct 2011, 11:36 a.m.


The new one does not enumerate any of my com ports, whereas Win7 Device Manager does (COM5).


I fixed the com port display issue by using XP comp mode with the Oct 4th dated MySamba, however now I get a failed to connect error. I see the LED on the USB->Serial blink as it tries to connect to the 30b for about 2 seconds then, "failed to connect". Stumped. Thanks.

Edited: 8 Oct 2011, 12:53 a.m.


Are the batteries on your calculator OK? Is it turned on? Do a RESET on the cable then an ON (long enough) and then connect.


2.8V each. I tried the reset, then on sequence and there was a ray a hope, I didn't get the error, but then again nothing happened. I doubt it downloaded the code in a second.

Subsequent tries have resulted in the same connection error.

Possibly Related Threads…
Thread Author Replies Views Last Post
  MS advert shows spreadsheet with obvious error BruceH 3 2,156 11-14-2013, 09:50 AM
Last Post: Bill (Smithville, NJ)
  Shutdown with the Apps key and more than 10 variables in a program. Davi Ribeiro de Oliveira 10 3,782 11-05-2013, 01:26 PM
Last Post: Han
  HP Prime: Rounding error in determinant Stephan Matthys 3 1,627 10-25-2013, 09:29 PM
Last Post: Walter B
  Prime Error or Mine? toml_12953 12 3,583 10-22-2013, 10:35 AM
Last Post: toml_12953
  Explaination on How to Reset Caculator in Users guie: error Harold A Climer 5 2,537 10-15-2013, 02:11 AM
Last Post: cyrille de Brébisson
  Repair of HP-34C - Error 0 and Error 9 Jeff Kearns 3 1,674 10-11-2013, 12:29 PM
Last Post: Randy
  Updated PPC DVD Version 2.10: HP-41 Searchable Program Files and Scannable Barcode Jake Schwartz 3 1,858 09-27-2013, 09:51 PM
Last Post: Olivier (Wa)
  Do You Think a Listing Error Was Made? Jim Johnson 13 3,823 09-04-2013, 09:23 AM
Last Post: Eddie W. Shore
  Rounding of 10^x Olivier De Smet 8 2,532 08-28-2013, 06:33 AM
Last Post: Dieter
  HP Prime: Error reports : Here Patrice 111 22,912 07-24-2013, 05:52 PM
Last Post: Thomas Klemm

Forum Jump: