Re: 34s: TVM problem?



#5

I actually had a need to do TVM so I thought I would try out the wp34s library routine.

I believe it is broken by the fact that LBL 00 is used twice in segment 1, step 15 for TVM and 368 as part of the vector functions.

It doesn't seem to matter if I load that segment into RAM or try to run it from the XROM.

I can get it work if I delete step 368 after the PRCL 1


#6

Ma fault. You can rebuild the libraries yourself if you have the cable. I'll change the label in one of the functions or use Niel's assembler for this. Stay tuned.


#7

oh good, I'm not crazy :-)

I only just got my 20b - when Neil gets back to Ottawa I'm going to borrow his cable (unless he got me my own) to flash this puppy.

Is the cableless alternative to change the 2nd LBL00 and calls to it to something else and then save the RAM back to segment 1?


#8

You should be able to PRCL 1 to copy the flash segment to RAM, edit it there and PSTO to write it back to flash.

- Pauli


Possibly Related Threads...
Thread Author Replies Views Last Post
  WP 34s : An old problem coming back Miguel Toro 2 538 11-05-2013, 03:00 AM
Last Post: Marcus von Cube, Germany
  TVM again ;-) fhub 17 1,471 09-02-2013, 11:03 AM
Last Post: fhub
  TVM WP34s trouble Jim P 4 633 06-28-2013, 07:31 AM
Last Post: fhub
  WP 34S flashing problem Gerson W. Barbosa 15 1,172 03-02-2013, 10:18 AM
Last Post: Gerson W. Barbosa
  HP 34S complex # problem Richard Berler 2 383 02-17-2013, 11:01 PM
Last Post: Richard Berler
  TVM-Solver for the PC fhub 14 1,278 12-26-2012, 03:24 PM
Last Post: fhub
  [WP34s] New TVM-solver version fhub 43 3,524 12-26-2012, 06:12 AM
Last Post: fhub
  [WP34s et al.] Solving the TVM equation for the interest rate Dieter 24 1,850 12-01-2012, 05:53 AM
Last Post: Paul Dale
  12c TVM problems where N is less than 1? James 29 2,643 11-25-2012, 11:50 AM
Last Post: Werner
  WP-34S transfer problem Reth 9 808 06-20-2012, 09:25 PM
Last Post: Reth

Forum Jump: