34s builds 1249 and 1250 crash on real hardware


I know builds are often handoffs between you guys, but just an FYI.

Both the 1249 and 1250 builds "crash".

When I run a program, the screen blanks and sits there. When I press ON, it displays "Restored"


Thanks for the feedback. We'll look into it. Emulator build 1250 seems to work as usual :-)



Gene I was suspecting this. Testing will start tomorrow. Have you cleared the calculator or are you trying to run what has been in the calculator before? Does the crash depend on the program you are trying to run?


1) It cleared the calculator when I loaded the new firmware. Erased was displayed and memory was empty.

2) It does not matter what program is run. LBL A, +, GTO A does the same thing as a longer program.

3) When it displays "Erased" is the calculator really totally erased? Any other way to clear it completely in case some bit is floating somewhere it should not be?

and... no problem on the testing. That's what I was doing. Beta software testers have to be willing to run into problems. That's our job! :-)


Same thing here with 1249 (obtained via SVN client.

However, I forgot to Erase prior but had nothing saved in Flash.

However, new operation yields errors such as:

1 2* 2* 2* 2* 2* 2* 2* 2* 2 * gives 512 --> Correct

2 * gives 100 --> Not correct

Along with very slow keyboard response including prefix keys.

Will retry after full erase as I did not follow the procedure correctly.



Hmmm, I just tried these exact steps and running a short looping program and neither failed on 1249 for me. However, what you are seeing is quite a bit like what I saw immediately after upgrading (and also like something I saw last week running much older firmware).

I changed the batteries and the problems went away. It would be quite a surprise if this is the cause of three people experiencing failures within a day of each other but it might be worth a try. BATT indicated 2.9 with the old batteries which should be fine.

We'll still investigate since it seems unlikely that this is the root cause.

- Pauli


More info:


will work fine if you single-step through the program. Push R/S however and it goes off to la-la land.


BATT indicates 2.7 on my unit. Hmm...

Edited: 18 July 2011, 5:41 p.m.


So, moral of the story... 2.7 BATT went to la la land, 3.1 batt runs.


It looks like 40 MHz is too demanding. The next revision will run at about 15% less speed. I had increased the speed considerably, especially for "non crystallized" machines, in order to get good baud rate divisor values. This might have been too much for some devices.


Any way to set the speed value by the user?


You can set test mode (ON+1) which emulates a low battery situation. This will set the speed to one third of what you have now.


I seem to remember a discussion about what the proper voltage and someone (Marcus?) said he programmed the 34s to show a low battery warning at a level different than the 30b.

Perhaps that level needs to be looked at once again to determine when it actually should show the warning so these failures don't show up unexpectedly.


The maximum speed was simply set too high. I'd be glad if someone will test with the most recent build and some worn out batteries.

I'll check back here tomorrow...


Another question:

Does the emulator also emulate the speed of the real calculator, or does it always run with the maximum speed depending on the PC?

Edited: 18 July 2011, 6:38 p.m.


The emulator is just a native C program which does not have an idea of the speed of the ARM processor. So it runs as fast as it can.


The emulator is just a native C program ...

Ahhh, so it's rather a simulator than an emulator, correct?

(I thought it may work like some other emulators which emulate the CPU and then run the original ROM code).

And how do you then get the calculator ROM (calc.bin)?

Do you write it in original ARM code or is there just a cross-compiler (C to ARM) in the HP20b-SDK which creates this ROM?

Edited: 19 July 2011, 6:14 a.m.


I've two separate environments:

Microsoft Visual Studio for the emulator.

Eclipse with the Yagarto GCC cross compiler and some Unixish tools.

The command line version compiles nicely under Linux or Mac OS with the compilers provided there.

The project is just a collection of source files which may be compiled (with some conditional compilation inside) into the various incarnations of the software. It took some time to get all the right pieces together. ;-)

Possibly Related Threads…
Thread Author Replies Views Last Post
  Four-Level RPN and the Real World Matt Agajanian 14 6,165 12-13-2013, 03:57 PM
Last Post: Manolo Sobrino
  "HexZombie - a tool for real programmers" Thomas Chrapkiewicz 8 2,877 11-16-2013, 12:46 AM
Last Post: Kiyoshi Akima
  Another Prime crash Stefan Dröge (Germany) 2 1,308 11-06-2013, 01:48 PM
Last Post: Stefan Dröge (Germany)
  HP Prime Crash bluesun08 5 1,920 11-04-2013, 05:16 PM
Last Post: Michael de Estrada
  HPprime CRASH and mysterious clepsydra indicator fabrice48 3 1,773 10-30-2013, 03:17 PM
Last Post: cyrille de Brébisson
  HP PRIME - Crash with "REPLACE" cmd ? dg1969 0 951 10-21-2013, 03:25 PM
Last Post: dg1969
  Dedicated HP calculator programming-hardware-bug website? Geoff Quickfall 12 2,845 10-12-2013, 11:34 PM
Last Post: Les Koller
  Unexpected problem with the real Prime Javier Goizueta 4 1,956 10-08-2013, 01:00 PM
Last Post: Marcus von Cube, Germany
  HP Prime (DVT Prototype) Hardware Details Adrien Bertrand 7 2,826 08-10-2013, 12:04 PM
Last Post: Eric Smith
  WP-34S QT emulator bug: real menus for catalogs Marcel Samek 8 2,930 07-09-2013, 11:25 PM
Last Post: pascal_meheut

Forum Jump: