Stand-alone version of WP34s assembler available



Though the executable is big (5.6MB) and clunky slow (if has to decompress itself -- each time -- before it runs), it is available for any Windows environment without an installed Perl package. Other than that, it has none of the drawbacks of the TinyPerl build attempted a few weeks ago, and behaves identically to the main Perl script.

The Assembler documentation in SVN has been updated and includes some commentary about this addition as well. (A 'red-lined' difference of the document is also available at: WP34s_Assembler_Disassembler_diff_30Jun2011_to_9Jul2011.pdf)

The main Perl script is still, and will continue to be, the main development but the executable will be topped-up from time to time (its an ugly, multi-computer chore to create, ugh!!).

On another note, after a month wandering in the wilderness of Canada Post, my overlays have arrived (thanks Eric!) so I can finally retire my paper overlay. My photography doesn't hold a candle to others I have seen, but here is the comparison (I haven't flashed in a bit):

I too have had the mushy keys on <-, and to a lesser extent EEX and +/-. I am going to try a sharp razor blade to release the keys. You can just make out a bit of hacking I tried on the <- key with a less than sharp xacto blade.

Other than that minor issue, the new overlays are great.



... it is available ...

Now the only question is: WHERE? ;-)


On the SVN repository in the usual directories here




On the SVN repository in the usual directories here


That really strange: I'm always using the following link

but there's still SVN 1196 (even with refreshing the browser cash)!?


Edited: 9 July 2011, 2:38 p.m.


Franz, get yourself an SVN client like TortoiseSVN. The latest WP 34S release is 1197.


Well Marcus, I doubt this program would work on my old Win98 notebook I'm using here for internet! ;-)

And so far the link for the WP34S-SVN I've posted above has always worked fine - I don't know what's the matter today, maybe a problem on my ISP!?


Hello Neil,

Congratulations! Have you used pp or have you found something better?



Hi Hubert,

Yes, this was done using "pp". Once I got it all together it worked quite well. There were some problems with which Perl package was used and I'd have to go back and find out which one I eventually used.(I think I mentioned more details in an email to you last week.)

There is about 14MB (compressed to ~5MB) of unicode that I am still trying to figure out if I can remove. I have tried several tricks -- including just deleting the darn stuff -- but, as yet no luck. I am still looking for a solution that will make it smaller. Making it smaller will also make it faster since the majority of the time is taken decompressing the image.

The Assembler documentation gives a bit more detail.

BTW: It may *not* work with VERY old versions of Windows (ie: Windows 98). I have no way to test this but I do recall seeing something in some "pp" documentation that may indicate this.



BTW: It may *not* work with VERY old versions of Windows (ie: Windows 98).

Win98 is VERY old? Well, I'm much older myself ... :-)

But here on my Win98 notebook it seems to work fine so far!


Though the executable is big (5.6MB) and clunky slow (if has to decompress itself -- each time -- before it runs)

Hi again,

I've now looked into your EXE and I saw that the biggest part in it is for Unicode support (in the subfolder lib\unicore).

Maybe you could try to compile it without Unicode support?

I don't know if this is possible, but it would dramatically reduce the size of the EXE and also its decompression time, and Unicode is certainly not necessary for your assembler.


Possibly Related Threads…
Thread Author Replies Views Last Post
  New version of WP34s iOS emulator pascal_meheut 4 1,769 07-22-2013, 03:55 PM
Last Post: Matt Agajanian
  WP-34S assembler & constants Marcel Samek 8 2,363 06-27-2013, 12:27 PM
Last Post: Marcel Samek
  Patch for wp34s assembler Marcel Samek 0 841 06-26-2013, 05:35 PM
Last Post: Marcel Samek
  New version of the WP34s iOS emulator pascal_meheut 15 3,906 04-23-2013, 01:58 AM
Last Post: Walter B
  [WP34s] New TVM-solver version fhub 43 10,645 12-26-2012, 06:12 AM
Last Post: fhub
  [WP34S] WP34S firmware on the AT91SAM7L-STK dev kit? jerome ibanes 1 1,188 10-04-2012, 04:59 PM
Last Post: Paul Dale
  HP 71b Assembler Michael Fehlhammer 2 1,148 09-06-2012, 08:20 AM
Last Post: Michael Fehlhammer
  [WP34s] last QtGui version not working fhub 8 2,469 08-31-2012, 05:08 PM
Last Post: fhub
  [WP34s] console version fhub 4 1,759 05-16-2012, 05:38 PM
Last Post: Paul Dale
  [WP34s] Assembler question fhub 6 2,138 05-14-2012, 03:08 PM
Last Post: Marcus von Cube, Germany

Forum Jump: