Help needed with my 41CX


I haven't used my 41CX halfnut for a month or two and now it seems to have developed a rather strange fault. If I insert an IR printer module (82242A) or a terminated HP-IL module (82160A) (with printer enabled or disabled) in ports one or three I cannot get the calculator to turn on. I can insert the IR module and the HP-IL module in either of the other ports and there is no problem. Equally, I can insert any other module in my collection (eg Advantage, Extended I/O, Wand) in ports one or three without incident.

I have tried resetting the calculator (on-clx, on-clx-enter), replaced the batteries, replaced the battery holder, all to no effect. Oh, and to clarify, I never have more than one module inserted at the same time.

I am eager to get this problem fixed as I want to use these modules with a card reader installed. Any ideas appreciated.



Hi Steve,
Ports 1 and 3 work electrically in parallel. So I suspect that the I/O assembly doesn't make proper contact to the main board. I'd open the calc and clean the contacts between I/O assembly and board with isopropyl-alcohol. I once had the same problem when the calc wouldn't start but then it was only one port --> the port connectors were dirty. But in your case I think it's an internal contact problem. Good luck Daniel


While it's apart check edges of the port contacts where they wrap around the I/O block. Often times the flex circuit will tear and break one of the contacts taking out both ports.


Many thanks for your advice. I will try taking the calculator apart.

The two things I don't understand are:

1. If the problem is the port contacts or the I/O connector, how come this has occurred while the calculator has been left untouched on a shelf for two months?

2. Why do the other modules work fine in ports one and three? And why does the calculator work fine with no modules inserted? Is there something special about the IR and HP-IL modules? An address line not used in the other modules perhaps?

Since my original post I have got the calculator to work for a short time by pressing on-clx-enter then on-clx three times (yes, always exactly three times). The calculator works fine, and recognises the IR or IL module. Once I switch it off, however, it won't turn on again unless I repeat the procedure. Normally I do not get MEMORY LOST with this procedure (strangely), but sometimes I do and then the message cannot be cleared unless I remove the batteries!

Any ideas?



Just a couple of comments to clarify some things:

a) In a sense, all ports are in paralell: most lines like VCC, VBat, GND, Clock, Data, Instructions and Address (ISA), and Flag Input (FI) go to all ports. There are a couple of contacts on each port which define the port address (each contact may or may not be connected , allowing for the four combinations 00, 01, 10, 11).

b) The backplane or Input/Output assembly, which is a plastic piece wrapped with a flexible printed circuit going to the ports and also to the battery contacts is a usual suspect in HP41 problems. Both dirty contacts, corrossion or "simply" lack of the right pressure may affect the quality of contacts between this assembly and the main circuit board. There is a small piece of plastic foam below the contacts which are supposed to get pressed against the main board, the piece of foam tend to become dried and less elastic over time. Also any attempt to over-adjust the screws which close the case halves together, or a knock against the floor, etc. may break the plastic posts which holds the screws, making the pressure (and hence the contact) weaker.

The modules that are worrying you need a good deal of power to work, while ROM or RAM did not. Also they probably use the Flag Input (FI) line, since they are peripherals, I think (not 100% sure) that ROM-RAM don't use FI. So a good idea may be to check VCC and FI contacts first.

A careful disassembly and cleaning may be the first step, you also will obtain a good insight on how the HP 41 is built; without such knowledge is difficult even to explain possible causes.

Please look at previous and archived postings here at the MoHPC, and also in the Articles forum, I suggest you should give a good look at postings by Tony Duell, among others, to obtain extra information on what to do and how.

I hope this helps, and please disregard any idiomatic mistake...


My first thought is that the HPIL module, the IR printer module and the 82143 'dedicated' printer all use the DATA line on the bus. ROM modules do not. Have you tried an Extended Memory module in port 1 or 3? My guess is the calculator won't recognise it either.
Anyway, as the machine works fine with the HPIL module (etc) in port 2 or 4, it means the chips are working fine. It's most likely a bad connection between the main PCB and the I/O assemnly (that flexible PCB wrapped round a plastic block that forms the I/O port connectors and battery contacts). Take the machine apart and clean the contacts on this flexible PCB and the main PCB using propan-2-ol. Then put it all back together again.


The HP contact assembly is basically a single sided flexible printed circuit that is wrapped around a plastic header. The pressure of the case presses the contacts on it against the calculator circuit board.

Since the flex circuit is a single sided circuit board, the left and right pairs of module contacts are basically independt of each other. They are wired together in parallel by the etch pattern on the keyboard. A problem with one side or the other of the module ports is almost always caused by bad contacts to the keyboard or a break in the flex circuit on that side. If cleaning the contacts does not help then look for a broken trace on the flex circuit with an ohm meter. They can be impossible to see visually.

Possibly Related Threads...
Thread Author Replies Views Last Post
  [OT?]Orthography corrector needed. Diego Diaz 8 1,217 06-22-2013, 04:31 PM
Last Post: Andrew Nikitin
  HP-50g How to store many equations - help needed Timo Labrenz 5 987 03-03-2013, 12:22 PM
Last Post: Timo Labrenz
  Disaster: help for a couple of HP97 needed! Jose Gonzalez Divasson 10 1,311 01-21-2013, 04:45 PM
Last Post: aurelio
  HP41 emulator for HP48sx - keyboard overlay needed Doug (NYC) 3 784 12-31-2012, 03:11 PM
Last Post: Allen
  restoring HP29C - help needed Alberto Fenini 9 1,253 11-25-2012, 07:56 AM
Last Post: Alberto Fenini
  Advice needed John Abbott (S. Africa) 15 1,595 04-19-2012, 04:04 PM
Last Post: Luiz C. Vieira (Brazil)
  19BII replacement recommendations/decision making help needed Timo Labrenz 20 2,333 03-28-2012, 12:24 PM
Last Post: Timo Labrenz
  OT: Manual for Casio FX-3900P needed Matti Övermark 5 850 11-27-2011, 06:10 AM
Last Post: Matti Övermark
  Repair HP41CV. Help needed. Kees van der Sanden 4 698 10-11-2011, 07:44 AM
Last Post: Ronald P
  Battery Contact Needed Fouad M. Kaadou 1 437 10-07-2011, 02:28 PM
Last Post: Paul Berger (Canada)

Forum Jump: