WP34S 956 crashing in wine



#6

I updated to 956 this AM and tried to run it up under wine (wine-1.2.2 on ubuntu 10.04) with the following crash. Does anyone know what is going wrong? This has been working beautifully under wine thus far.

(I have removed some of the svn update output and most of the debugger dump for clarity.)

Thanks...

nhamilton@hp-ubuntu:~/Downloads/wp34s$ svn up https://wp34s.svn.sourceforge.net/svnroot/wp34s wp34s_svn
Skipped 'https://wp34s.svn.sourceforge.net/svnroot/wp34s'
...
U wp34s_svn/trunk/windows/wp34sgui/wp34sgui.vcxproj
U wp34s_svn/trunk/windows/wp34sgui/builddate.h
U wp34s_svn/trunk/windows/wp34sgui/wp34sgui.c
U wp34s_svn/trunk/windows/bin/emulator_d.pdb
U wp34s_svn/trunk/windows/bin/emulator_d.lib
U wp34s_svn/trunk/windows/bin/wp34s_compact.bmp
U wp34s_svn/trunk/windows/bin/emulator_d.dll
U wp34s_svn/trunk/windows/bin/wp34sgui.exe
U wp34s_svn/trunk/windows/bin/emulator_d.exp
U wp34s_svn/trunk/windows/bin/wp34s_medium.bmp
...
Updated to revision 956.
Summary of conflicts:
Skipped paths: 1
nhamilton@hp-ubuntu:~/Downloads/wp34s$ wine ./wp34s_svn/trunk/windows/bin/wp34sgui.exe &
[1] 1623
nhamilton@hp-ubuntu:~/Downloads/wp34s$ fixme:heap:HeapSetInformation (nil) 1 (nil) 0
wine: Unhandled page fault on read access to 0x0044c000 at address 0x414540 (thread 0009), starting debugger...
Unhandled exception: page fault on read access to 0x0044c000 in 32-bit code (0x00414540).
...

#7

What happens if you delete your old state file wp34s.dat?

P.S.: Your SVN command is way to complicated. Just go to the top level directory of the project (wp34s_svn in your case) and type "svn update". SVN knows from the hidden .svn directory what to do.

Edit: I think I know what happened: Your state file was too old and some garbage was interpreted as a length field. I've added a sanity check there but deleting the file will certainly help. It's invalid anyway. If you have a program in your file which you want to save, just forward it to me. I can extract the code for you.


Edited: 25 May 2011, 7:04 a.m. after one or more responses were posted


#8

As suggested, I deleted all the copies of wp34s.dat in the tree (there were several so I suspect that it saves this file out to whatever directory I launched from). Still no luck.

I poked around a few other revision to see what would happen. If I wind back to 954 (svn up -r 954), everything works fine. However, 955 crashes in the same manner as 956.

Thanks for the svn wisdom. I'll admit that I am much more familiar with cvs than svn. Your suggestion is certainly much shorter. I was just using what was documented on the sourceforge website (your know: if it ain't broke, ... you're not trying hard enough :-) ).

Thanks...


#9

Try 957 and report back.


#10

957 works like a charm!

Thanks!!!


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP Prime Connectivity software in Virtualbox/wine Chris Pem10 2 449 11-22-2013, 02:20 PM
Last Post: Chris Pem10
  old wine in new skins Mike (Stgt) 11 831 12-05-2012, 08:00 AM
Last Post: Mike (Stgt)
  [WP34S] WP34S firmware on the AT91SAM7L-STK dev kit? jerome ibanes 1 352 10-04-2012, 04:59 PM
Last Post: Paul Dale
  Successful running EmuXY under Wine 1.4 Christoph Giesselink 0 209 03-12-2012, 03:06 PM
Last Post: Christoph Giesselink
  [wp34s] Incomplete Gamma on the wp34s Les Wright 18 1,303 12-06-2011, 11:07 AM
Last Post: Namir
  [wp34s] Romberg Integration on the wp34s Les Wright 2 425 12-04-2011, 10:49 PM
Last Post: Les Wright
  WP34S Under WINE SteveH 12 942 11-19-2011, 04:00 PM
Last Post: Hubert Weikert
  HP97 crashing with trig and logs Mark Edmonds 13 895 08-04-2008, 12:15 PM
Last Post: Mark Edmonds
  Emu48 1.42 and WINE - It Works! Howard Owen 0 164 09-02-2006, 10:21 PM
Last Post: Howard Owen
  HP48GX crashing while crunching numbers Jeff 1 246 05-20-2005, 05:03 PM
Last Post: James M. Prange (Michigan)

Forum Jump: