WP34s 1.17 Build 874 possible SETTIM bug?



#11

Hi:
I noticed when using SETTIM that the input argument's seconds value seems to be ignored and replaced with some value between 10 and 14.

For example if I have 22.0400 on the stack, execute SETTIM then immediately press hTIME I get a value back of 22.0412 instead of an expected 22.0402 or something close to that.

Regards,
Bob


#12

Wow! A command all for me. :-)

Tim W


#13

Oh man, I hope that's not changing your TV channels or something :-)


#14

I will check it. What happens, if you set the clock to something like 1.2345 ?

Edit: The seconds written to the RTC were definitely bogus. I fixed it in SVN for V.1.8. V1.17 will not be fixed.


Edited: 18 May 2011, 3:37 a.m.


#15

Just installed 1.18 - problem solved.

Thank you!

Bob

Edited: 18 May 2011, 10:04 p.m.

#16

Aren't you glad there's no KILLTIM command? ;-)

Regards,


John


#17

I can always add one :-)

- Pauli


#18

Come on, that was a peaceful project so far :-)

Walter

#19

:-(


#20

Other possibilities: PEEKTIM, POKETIM, PUTTIM, POPTIM, PUSHTIM, DIVIDETIM, ROTATETIM, FLOATTIM, MASKTIM, ABORTTIM...

Let's hope your wife doesn't execute REMOVETIM, SWAPTIM or REPLACETIM.


John


Possibly Related Threads...
Thread Author Replies Views Last Post
  wp34s binomial bug Andrew Nikitin 4 342 09-22-2013, 05:20 PM
Last Post: Paul Dale
  Expon bug in wp34s Andrew Nikitin 7 505 07-14-2013, 03:23 AM
Last Post: Marcus von Cube, Germany
  another wp34s bug Andrew Nikitin 8 547 06-26-2013, 01:01 AM
Last Post: Paul Dale
  WP 34S New Build with older GCC Marcus von Cube, Germany 4 343 06-22-2013, 05:12 PM
Last Post: Marcus von Cube, Germany
  weird statistics bug in wp34s Andrew Nikitin 5 490 06-20-2013, 01:54 PM
Last Post: Namir
  Update of Emu42 to v1.17 Christoph Giesselink 1 194 05-15-2013, 09:30 AM
Last Post: CompSystems
  HP-15C Simulator / Release 3.2.00, Build 5319 Torsten 10 714 05-11-2013, 05:19 PM
Last Post: Thomas Klemm
  NCTM, Denver April 17-20 Tim Wessman 1 194 03-16-2013, 06:41 AM
Last Post: bluesun08
  [WP34S] A funny bug in Pi (prod) Eduardo Duenez 3 383 01-28-2013, 03:41 AM
Last Post: Walter B
  [WP34s] Bug or feature? Dieter 25 1,226 01-03-2013, 06:20 PM
Last Post: Paul Dale

Forum Jump: