HP20b inert - how to get it working again?


Hello, all - I received the cable from Gene (thanks!) and, prior to trying the '34 code, decided to back up the flash to my PC. It connected fine but only read a file of all 1s. Oh well.

Meanwhile, now my 20b doesn't do anything. Fresh batteries still leave a blank display. Hooking up the cable isn't sufficient - running SAM-BA v2.10 refuses to connect with it.

So time to dig into piles of documentation. Meanwhile, any suggestions on (1) how to talk to it again and (2) how to get it running?

Many thanks to all!

Jim Horn, Cell 1-707-327-6253



Did you try just pretending it is working and connect the cable, follow the normal button pushing sequence, start the software, etc.? I got my 20b into a blank, non-responsive state at one point and was able to revive it thusly.


Just in case you don't have the flashing documentation, Tim's step-by-step is linked in this thread.

I think Jeff's idea is excellent: just pretend it's working and follow those steps.

Good luck!


Edited: 9 May 2011, 11:42 p.m.


The ERASE button on the cable does what it says: It erases the flash. This clears the bit controlling whether the built-in SAM-BA boot loader is started, a prerequisite for reflashing the device. With only the boot loader active, you can only use the flashing software to resurrect the calculator.

There is no way of extracting the original firmware because the only means of getting into SAM-BA mode is clearing the flash. You can get the original firmware from Tim.


You can get the original firmware from Tim.

It's here. At least, I found a working 2009 image there. Don't know if that's the current version.


A 20b image comes with the SDK. 30b images exclusively from Tim or Cyrille.


Thank you, all! I followed the original instructions using the flash image in the 20b Development Kit and have my calculator working again with Version 14.014. Now that I know I can get it back as a '20b again, I'll dive into the wp34s - can't wait!


Once you've repainted the keys, you'll need another 20b. ;-)

For serious use, the 30b is recommended. My development system is a butchered 20b but I've just ordered another 30b for a permanent brain transplant and some plastic surgery.

I'm thinking of "Letraset" transferable letters for the white key legends. Will that work?


I am new to the forum and have looked to see how I might acquire a serial cable to program my 20B. I keep seeing "Thanks Gene!" but not much else to point me the way. Can anyone give me a direction or help me with a link that might land me one of these coveted items?

Best regards...


Use the mail system of this forum to ask Tim Wessman. He is sending the cables to people seeking to ruin their precious HP gear. ;-)


Thanks for the quick response. Maybe I am loosing it but I can't seem to find any mail system attached to the forum. Can you give a broad hint where to look? (Sorry for the stupid question!!)



Just click on the name of the addressee (printed blue on my screen) - i.e. Tim's name in an arbitrary posting of him.



He is sending the cables to people seeking to ruin their precious HP gear. ;-)

Right now I am stuck with an inert 20b myself... I've tried three computers so far, two OS's (Vista and Seven), SAMBA v2.9 and v.10 but it won't connect. Ok, the manual says "Serial port must not be USB-serial converter." but one of the computers does have a real RS-232 port. The CR-2032 batteries have been replaced with fresh ones (but their voltages have now dropped from 3.15V down to 2.8V).
Any idea? Thanks!

P.S.: I don't care about restoring the original firmware.


Right now I am stuck with an inert 20b myself...


The CR-2032 batteries have been replaced with fresh ones (but their voltages have now dropped from 3.15V down to 2.8V).
Any idea? Thanks!

Gerson, that's bad news. :-(
The current draw of SAM-BA is considerable as it does not make any power saving attempts. As soon as you turn on your calculator, it starts eating batteries. Remove them if you do not get the firmware loaded successfully.

I normally do the following: I start SAM-BA on the PC (using an FTDI equipped serial cable, in fact it's my Olimex JTAG adapter right now, but not its JTAG connector but its serial port). Wait until the connect prompt appears. You need to select the correct board type (at91sam7l128-ek) and the correct serial port.

Before I press Enter, I push the reset button on the cable, release it, and hold down ON for half a second or so. I then press enter on the PC to connect.

You can see some diagnostic output from SAM-BA if you start it from a Windows command prompt and redirect the output to a file. I'm using sam-ba.exe V 2.10. The command line is

sam-ba.exe >log.txt

Hi Gerson:

Unfortunately Vista & Win7 are a no-go with SAM-BA 2.10 and the serial connection on the HP 20/30. You'll need to find a machine with XP to reflash the calculator.

In this thread Katie reported success with Sam-BA 2.6 + a patch under Win 7, so if you can't use XP, you might try that.

I've not had any problems using a USB-serial cable, your mileage will vary depending on the chip set. If you can start with a hardware RS-232 port that may eliminate one variable if you need to troubleshoot

Good luck!


Edited: 17 May 2011, 6:01 p.m.


Bob and Marcus,

Thanks for your responses. I tried MySamba on Windows 7 (compatibility mode set to WinXP) and real RS-232 port, but it was unable to connect. Perhaps because the batteries are low (2.75 V). I'll try again later with fresh batteries.



I don't think the batteries are the problem even if the cable itself draws some power, so its best to leave it disconnected when not in used.

Two points:

1/ Use the SAM-BA.EXE executable, not the alternate version!

2/ Redirect its output to a file and post the results here. You need to go to the command line to do this.


Compatibility mode won't do it, I'm afraid. V2.10 really, really wants XP to operate.

If you have Win7 Pro or Ultimate you can try the XP virtual machine. I've had that sort out driver issues, but don't have it any more so I can't try it with SAM-BA.



Hi Neil,

Since you're new here, please note Tim is of HP :-) if you didn't find out yet.



And, actually, Tim has outsourced the mailing of cables to me so he can concentrate on bringing out the HP 29CX.


HP 29CX.

Why did the do nothing programmable expandable calculator spring to mind here???

- Pauli


/humor on

Actually, the handheld 29CX has not only the printer of the 19C, but also the card reader of the 67 ;-)

/humor off



Hey Jake, you are actually talking about SD cards, aren't you? ;-)


No, wifi to the "cloud"

Possibly Related Threads…
Thread Author Replies Views Last Post
  HP Prime Save Power Turn Off Not Working Timothy Roche 12 4,167 10-27-2013, 01:41 PM
Last Post: Michael de Estrada
  Temporary User Mode Key Programs not working in RPN BruceTTT 7 2,720 10-14-2013, 01:46 PM
Last Post: BruceTTT
  HP-97 suddenly not working Brad Barton 10 2,801 02-25-2013, 08:15 PM
Last Post: Brad Barton
  [41CL] Problem with PowerCL ... not working Doug (NYC) 5 1,989 01-22-2013, 07:18 PM
Last Post: Doug (NYC)
  42S exit key not working dwsmith 4 1,668 11-05-2012, 10:59 AM
Last Post: dwsmith
  HP-46 not working Ignacio S├ínchez 1 1,018 10-24-2012, 11:17 AM
Last Post: Donald Williams
  [WP34s] last QtGui version not working fhub 8 2,499 08-31-2012, 05:08 PM
Last Post: fhub
  Modfile not working with Win 7 x64 Richard Wagoner 6 2,268 07-04-2012, 10:32 PM
Last Post: Diego Diaz.
  Working on HP's again Les Koller 49 12,999 06-20-2012, 01:29 AM
Last Post: Thomas Radtke
  WP34S donor case from HP20B? Andrew Davie 6 2,012 06-20-2012, 01:26 AM
Last Post: Walter B

Forum Jump: