29C needs help!



#7

Hi all,

A few days ago I acquired a HP-29C in nice condition for a good price. Aaah... red LEDs. So small and handy - it's a real cutie, isn't it? :-) The battery compartement has been modified so that the unit now runs on regular AA-size NiMH batteries, providing about five times the original operation time and allowing the use of a decent processor-controlled external charger. So far, so good.

First tests showed that the 29C runs significantly faster than my good old (even slightly newer) 34C. So I tried the 8-queens-benchmark on http://www.hpmuseum.org/cgi-sys/cgiwrap/hpmuseum/articles.cgi?read=700 to find out more.

Since the 29C is not listed there I used the sample program for the 11C/34C, only slightly modified for the 29C since it uses register 0 for indirect addressing. The result was quite surprising: While the 34C is listed with 73 minutes, the 29C did the job in just 42! Even better, a simple factorial program (i.e. essentially a simple loop) runs quite exactly twice as fast as on the 34C. I had expected an execution speed close to that of the HP-67, or maybe something comparable to the 34C/15C.

Today there was another surprise. The 29C was running a program when, after about half an hour, I suddenly noticed the display showed nothing but twelve zeros: "000000000000" and no reaction on any key press. :-(

Now, there are two questions:

  • The calculator worked perfectly for a few days. What might have happened here? What can I do now?

  • I wonder if the 29C really is so much faster than the 34C or even the 67. Maybe other 19C or 29C-users may try the 8-queens-benchmark program and state their results. Has my unit possibly been modified? In this case, may this have caused the mentioned problem?

Dieter


#8

I am not a hardware expert, but I have been burned many times by running HP-25 calculators using AA Alkaline batteries. My humble guess is that the batteries you are using messed up the chips and friend a circuit or two .. or three ... or more. That's why the only HP25 and HP-29C I touch nowadays are emulators.

Maybe hardware savvy folks can offer a better diagnostic.

Namir


#9

Namir, thanks for your response, but of course I didn't use Alkaline batteries but rechargeable NiMHs, having exactly the same voltage as as the original NiCds.

However, I wonder if disposable Alkaline batteries really may harm a 25(C) or 29C. Their voltage (1.5 V when new, then continuously dropping) is just about 10% higher than the 1.4 V of a freshly charged NiCd. Which then quickly drops to almost constant 1.3...1.2 Volts in use.

Dieter


#10

The alkaline batteries have fried more than one HP-25 which were functional when I received them. So I have some statistical data to back my suspicion.


#11

I use Energizer lithium cells in all my woodstocks and never had a problem. Their initial voltage is around 1.7 per cell, much higher than fully charged nicads. Running up to 3.5 volts or so has never been an issue for me.

The thing to watch out for is the 9 volts or so that you get from running these calculators off the AC adapter with no nicads inside (or at least no nicads making contact with the battery terminals).

-Katie


#12

Like Katie, I have fortunately never had a problem with the lithium batteries. I suspect that, if the calculator is "fried", it was already on the verge of failing.

#13

Hi Dieter,
Be sure to check all contacts in the battery loop...scrub them so they shine. As you have
put in NiMH cells, I'll bet you've done away with the soldered strap which originally connected the two cells, and are relying on the tensioning spring for the cell to cell connection...just be sure this area is clean.

My 29C has occasionally exhibited whacky behavior, and this has always been the culprit.
(Incidentally, I bought my 29C brand new in 1978, and it's been with me ever since!)

#14

I wrote:

Quote:
The 29C was running a program when, after about half an hour, I suddenly noticed the display showed nothing but twelve zeros: "000000000000" and no reaction on any key press. :-(

In the meantime I searched the forum and found exactly the same problem in
this thread from 2001. Just like here, the 29C crashed after about half an hour while running a program, locking up with twelve zeroes in the display.

Since neither I nor the previous owner had the original Wookstock AC-adapter (the batteries were charged in an external charger) the problem cannot have occured due to overvoltage or another cause related to the charger.

May I ask the experts if this and the information in the earlier thread sheds some light on both Mark's and my problem?

Dieter


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP-29c keyboard dead 2nd row problem Xavier A. (Brazil) 6 774 07-17-2012, 07:09 AM
Last Post: Xavier A. (Brazil)
  HP-29C Counterparts Matt Agajanian 2 411 05-12-2012, 06:44 PM
Last Post: Matt Agajanian
  My 29C's even more bizarre behaviour Matt Agajanian 5 693 04-25-2012, 05:46 PM
Last Post: Matt Agajanian
  29C/25C question. Matt Agajanian 7 771 04-03-2012, 12:03 AM
Last Post: Matt Agajanian
  My very schizophrenic 29C Matt Agajanian 9 932 04-02-2012, 05:12 PM
Last Post: Matt Agajanian
  Help!! My 29C may need a doctor. Matt Agajanian 5 674 03-31-2012, 04:23 AM
Last Post: Ignazio Cara (Italy)
  Legible version of 29C Curve Fitting program Matt Agajanian 6 766 03-21-2012, 07:46 PM
Last Post: Matt Agajanian
  Sleek approach to Register Exchange on HP-29C Matt Agajanian 8 856 03-16-2012, 01:04 PM
Last Post: Marcus von Cube, Germany
  Is there a self-test program for the HP 25 or 29c ? Michael de Estrada 1 347 04-10-2011, 03:09 PM
Last Post: Xavier A. (Brazil)
  HP-29C Behavior that is odd! Jeff Davis 1 342 02-07-2010, 11:43 AM
Last Post: Michael de Estrada

Forum Jump: