HP-41CV Display



#2

I just got a CV that seems to be acting funny.

When I first put the batteries in, it didn't seem to come on unless I would reset [on] <=.

Then after repeatedly pressing on it now seems to be alive.

What would cause the display to light up 1/2 a second after pressing on? Is this normal? The CX I have doesn't seem to have this lag.

Also, as I ever so slightly press the on-user-prgm-alpha buttons, the LCD will fade in and out.


#3

Hi there,

I'll assume this is a Coconut, as the symptoms are quite likely to come from a bad CPU to keyboard connection: contact strip failure or broken post are common sources for this sort of (somehow) weird behaviors.

Hope this helps.

Diego.

Edited: 2 Mar 2011, 2:41 a.m.


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP 41CV Repairs William Mabotja 3 557 11-20-2013, 04:45 PM
Last Post: Mike Powell
  "Packing" syndrome of my HP-41CV PGILLET 12 1,241 11-03-2013, 02:46 PM
Last Post: Hans Holzach
  HP-41CV - A Walk Down Memory Lane Tom Lewis 9 923 03-18-2013, 11:14 PM
Last Post: BShoring
  HP-41CV power problem Don Davis 2 449 10-11-2012, 09:13 PM
Last Post: Don Davis
  Can the display for a HP32Sii be replaced with the display from another model? Bruce Larrabee 8 982 10-10-2012, 10:05 PM
Last Post: Luiz C. Vieira (Brazil)
  HP-41CV layout vs Voyager's, 35s Ben Huntsman 17 1,442 09-17-2012, 05:30 PM
Last Post: Luiz C. Vieira (Brazil)
  HP-41CV System II aj04062 1 389 06-22-2012, 08:49 PM
Last Post: Allen
  HP-41CV "tall keys" version Ignacio Sánchez 16 1,381 06-11-2012, 04:59 AM
Last Post: Diego Díaz
  HP 41CV defective aurelio 7 724 05-16-2012, 03:54 AM
Last Post: Frank Boehm (Germany)
  HP-41CV dilemma Matt Agajanian 41 2,934 03-13-2012, 10:56 PM
Last Post: Luiz C. Vieira (Brazil)

Forum Jump: