HP 97 Card not fully ejected


After refurbishing the "clutch" and traction wheel it works well except the card is not fully ejected after reading. Does this problem mean that I have a speed issue?

By doing continuity tests while pushing the card slowly into the reader (with power off) I can verify that the motor switch, head switch, and write-protect switches work. I have yet to go through the process of changing R1.




I just tried to see the length of the recorded strips on the back of a card using iron filings, the product used in school science labs. The particles are too large to work well, but I can see what I think is the recorded length. If so, they look too short. Maybe all the data gets read and the motor shuts off before the card is ejected?

BTW, since there are no values given for Lmin and Lmax in the SM I am assuming that the printed image of the back of the stip is to scale and one is supposed to just lay the card beside it. Is that right?



it works well except the card is not fully ejected after reading
Define "fully". If it can be pulled out with your fingers, it worked.

Maybe all the data gets read and the motor shuts off before the card is ejected?
No, it doesn't work that way. Everything is controlled by the leaf switches.

I have yet to go through the process of changing R1.
Don't go there, shouldn't be needed. Unless of course you changed the motor.

The most important missing data: Does it read the card correctly and the motor stops with the end of the card out the back of the case? That's a correct read cycle. What does your 97 do?

Edited: 1 Oct 2010, 9:17 p.m.


Thanks, Randy.

It does read the simple area of a circle program correctly, but does have to be tugged out. Others have told me the tug is abnormal. Also, the I wrote the program to this card after the repairs to the reader, so I wonder about the validity of the test. Another member of the forum is kindly sending me a card created with his reader which doesn't have the "tug it out" symptom.



"Tug" it out? That's normal. It should be require very little force to remove. Are you expecting the card to be fully ejected out of the reader and calculator body?


I don't expect it to be completely ejected out of the reader, but the trailing end should no longer be under the traction wheel. It's not.


This shows the record tracks on a Data 2 card created with my reader. Much too short compared to the SM diagram.

Click here for photo



Hey Ed,

I presume the video of my card reader convinced you that it wasn't working correctly.


Edited: 3 Oct 2010, 10:55 p.m.


No, but from what you have shown I can't tell if you have to tug it out. By tug I mean to pull hard, with easily felt resistance. I believe the resistance I feel is due to the trailing edge of the card being still in the grips of the traction and pinch wheels.

Actaually, the problem was called to my attention when I posted a video of me doing the same thing, but pulling the card out after the read. Here it is again:

Video of my reader from last April.

I had posted it to get comments on the noise level I had at the time. Ignazio responded as follows:

Hello Ed, I've saw your short movie. It's my opinion that your reader is too much noisy, and that you must pull the card when it's out of the reader. You have used o-rings too much wide! BTW, have you checked the test-point on the card-reader PCA with a continuity tester? There are three test-point marked M (motor switch), F (Write protect swith) and H (head switch) on the upper left side of the PCA, that you must check with the ground signal (to the left of the three test-point) to test the switches are working properly. Let me know.

Now that I've repaired the clutch and switched to the fuel tubing traction wheel repair the noise probelm is gone, but the incomplete ejection is still with me.

Thanks for you interest. It helps to get feedback!


Edited: 4 Oct 2010, 2:55 p.m.


Hi Ed,
It's my opinion that you have too much pressure of the drive roller on the magnetic card's surface, due a not correct position of the eccentric cam. This issue could be the reason of your difficult to pull the card from the rear of the calculator after a r/w session.
Try to rotate this cam until the force needed to insert the card into the reader is not so high.
Let me know if my opinion is helpfull.

Regards and ... never give up



Good to hear from you Ignazio!

I have been thinkg that too, and have been trying to adjust it. I am measuring current per the Service Manual but cannot find any position of the eccentric shaft that gets it down to 180mA. About 300 is as low as I can get it. The manual also indicates the eccentric shaft may have to be replaced, but that might be hard to source!

Today I noticed that the wheel I made from fuel tubing is slipping on the shaft. I'll try a drop of superglue.

Give up? Me?

Thanks for your intertest.



...I am measuring current per the Service Manual but cannot find any position of the eccentric shaft that gets it down to 180mA. About 300 is as low as I can get it...

Bad eccentric? Not likely.

Remove the eccentric and the gear and run @ 3 vdc. If the motor current is greater than 25 ma, the motor is binding due to an off center coupler and is the cause of the higher than normal current. If motor current is okay, it could be:

  1. Tubing is too large in OD
  2. Gear and/or eccentric have goo on/in them from the old wheel


Thanks, Randy.

The adjustments I've done seem to have speeded up the motor a bit since the track length is a little longer now and it doesn't take quite as much of a pull. But I will take it apart again and do the test you suggest.

I have to rule out the goo possibility as I have cleaned everything carefully. The OD is possibly the problem. I first tried O-rings purchased on eBay but they were of larger OD than the fuel tubing I now have installed. Might have to once again review the Archives on this issue.



I have to rule out the goo possibility as I have cleaned everything carefully.

Well, it looks like I was too sure of my goo removal talents. I found a tiny lump in one of the the cavities where the pinch wheel axle rides.

The OD is possibly the problem.

Using a precision caliper, I have measured the OD of my fuel hose traction wheel while installed on the gear. It measures 0.244". That makes it almost exactly the diameter the shoulder on the gear that is fits up against. IOW, if the tubing OD was any smaller it would be below the shoulder.

So, my current theory is the tiny bit of goo was keeping the pinch roller from turning. That would make the motor work alot harder, possibly causing my symptoms.

More on this after I do the no-load current test and put it back together. I'll also put a little superglue on the gear shaft before slipping the new traction wheel on.



Got the Data 2 card. Thanks!

It reads great on my machine, even though the data track lengths are different from the card written by reader (in it's current state of adjustment). See how they compare below:

Comparing track lengths.

Yours is shown at the top. Comparing it to the diagram in Sec 4-35 of the SM, it looks like yours is about LMin, whereas mine is significantly shorter. Yet, mine now seems to read fine too, after fussing with adjustment of the eccentric shaft. Mine takes a little more of a tug to get out after the read, but not as bad as it was.

So for those who have wondered, cards written on readers of widely differing adjustments seem to be read OK on both.



Interesting Ed,

Mine takes a very minimal tugging to pull out.

I've rebuilt this card reader using some urethane orings. They are of a lower durometer than the std Buna (black) orings you get. I figured urethane is known for its high friction coefficient, so I'd give it a try. One thing I had to do though is super glue them to the shaft as they would slip on the gear. It did take some tinkering on the eceentric cam to get it running well.

I bought 100 of these crazy things for $5. If anyone wants to try a few, let me know.


As I mentioned, I saw slippage with the fuel tubing also. I had been doing the SM procedure of holding the card to get the extreme current reading and shortly afterwards just let it pass on through. It pulled through nicely for a bit then slowed down, then stopped. Since I have the calculator apart I was able to flip the reader over and see what was happening... worm gear sailing merrily along, gear turning, "traction wheel" still! Wouldn't have believed it possible.

Yes, I'd like a few (4 would do) of the urethane O-rings.


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP-97 card reader pinch roller axle davorin 2 810 09-15-2013, 08:47 AM
Last Post: aj04062
  HP-97 Card Reader davorin 3 860 09-13-2013, 04:21 PM
Last Post: Stephan Matthys
  Repaired HP-97 card reader doesn't show any signs of life jbssm 6 1,221 02-17-2013, 03:15 AM
Last Post: Alberto Fenini
  HP41 Card Reader not Pulling Card Colin Verrilli 14 1,865 07-29-2012, 05:53 PM
Last Post: Randy
  HP48SX seems fully functional won't run SELF TESTS? Bruce Larrabee 5 1,060 07-16-2012, 11:04 PM
Last Post: Luiz C. Vieira (Brazil)
  HP-97 Card Reader Repair Adventure LHH 1 515 06-08-2012, 10:48 PM
Last Post: David Ramsey
  Hp 97 Card Reader issues Fouad M. Kaadou 2 569 11-26-2011, 04:28 AM
Last Post: Fouad M. Kaadou
  HP 97 card reader Davd F 13 1,596 11-21-2011, 08:26 PM
Last Post: Davd F
  HP 67, 97, 97+ emulator Olivier De Smet 8 1,248 11-11-2011, 09:57 AM
Last Post: Israel Otero
  Fully testing HP 41 Le Babou 7 1,030 10-23-2011, 08:59 AM
Last Post: Allen

Forum Jump: