Repaired 41C



#7

I repaired my 41C's flex circuit which was damaged by corrosion. In testing, I found something odd. With no other modules in place, the Math Pac worked in port 1 but not in port 2. The display would come on but then no response to any key, including power. The repair is on the port 1/3 side of the flex circuit, not the port 2/4 side.

However, with a 4X RAM in port 1, the Math Pac works in port 2. I read that the ROM has to come after the RAM, but why would the ROM not work without the RAM?

(Edited: they're ports, not slots. D'oh!)

Edited: 13 Mar 2010, 11:08 p.m. after one or more responses were posted


#8

I believe you are simply not allowed to leave slot 1 empty. Although the instructions indicate that you can leave 'gaps' e.g. memory module in port 1 and application module in port 3 or 4 with port 2 empty etc., you may have to use port 1 first in either case.


#9

The only requirement is to fill lower ports with RAM modules (if present). How could you use Card reader (and associated ROM) without additional RAM modules otherwise?

Since you mention corrosion check that you got rid of all of it

Greetings,
Massimo

Edited: 13 Mar 2010, 9:01 a.m.


#10

The only corrosion I found on the PCB was a bit on the gold contacts to the flex circuit, easily cleaned off. The flex circuit itself was badly corroded. The negative battery terminal was destroyed so I cleaned it and covered it with a metal strip that reaches up to the PCB contact. It is a bit thick so I covered the adjacent contacts with aluminum foil strips to ensure contact.

It seems to work except for the oddity noted above, but perhaps that is normal?


#11

May I suggest that you try to contact Diego Diaz (http://www.clonix41.org/Maintenance/IO_Block/IO_Block.htm) for a replacement, if available?

;)

Greetings,

Massimo

Edited: 14 Mar 2010, 7:40 a.m.


#12

That new flex circuit looks very nice but I recently put in new batteries (Radio Shack, 2 for $0.99) and now the Math Pac works in port 2 with or without RAM in port 1. Yay! The old batteries measured about 1.25 V each unloaded and there was no Lo Batt indicator, but they were 15 years old. They had been stored outside the calculator, after the corrosion damage had occurred with the previous set.

Edited: 15 Mar 2010, 6:20 p.m.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Repaired HP-97 card reader doesn't show any signs of life jbssm 6 914 02-17-2013, 03:15 AM
Last Post: Alberto Fenini
  HP-41C partially repaired, help with "ROM", alpha glitches MattMalone 2 427 09-26-2012, 02:26 AM
Last Post: Diego Diaz
  Hp 97 needs to be repaired (Ciao Ignazio) aurelio 6 673 10-09-2011, 08:13 PM
Last Post: Michael de Estrada
  Repaired HP41CV hangs on error. Dan Koller 2 401 07-26-2009, 05:38 PM
Last Post: Geoff Quickfall
  Charging time for repaired HP 82120 Matthias Wehrli 0 232 03-03-2007, 05:31 PM
Last Post: Matthias Wehrli
  HP-67 Gummy Roller Successfully Repaired Grant Henson 6 702 12-19-2006, 07:10 PM
Last Post: Grant Henson
  is this normal in a repaired 41CX? Gonzalo Fernandez (Spain) 3 458 03-06-2006, 11:31 AM
Last Post: Klaus
  HG48GX cable plug : where can I get it repaired ? Antoine M. Couëtte 12 1,112 10-25-2005, 08:07 AM
Last Post: Tony Duell
  Repaired 41C has short time-out Michael Burk 3 407 06-14-2005, 09:30 PM
Last Post: Randy
  I repaired my 15C back plate bill platt 1 302 09-17-2003, 02:18 PM
Last Post: Veli-Pekka Nousiainen

Forum Jump: