HP-41 turn-on behavior



#15

Hi all,

my first post here, though I have been visiting the museum for years. I recently got a non-working 41 and, after dealing with the broken posts and zebra contacts issues, the calc is working like new. Anyhow now and then, after sitting unused for a while, the first press of the 'on' button will not wake up the machine. On a second attempt it will usually come up alive, and from then on every subsequent on/off cycle will perform flawlessly, even with very light pressure.

Any hint?
Thanks,
Paolo


#16

Ciao, Paolo;

can you identify which model you have? A CV or a CX, coconut or halfnut?

Thanks.

Luiz (Brazil)


#17

Hi Luiz,

sorry for not clarifying.
It is a fullnut 41CV.

Paolo


#18

Paolo;

the main reason I asked about the internal structure is that the fullnut (or coconut) may suffer from bad contact. The keyboard and LCD assembly are connected to the mainboard through a series of contacts provided by a zebra connector (I know of two different types) or a conductive polymer. In any case, if one of (or a group of) the contacts fail, the calculator does not turn on. In some cases, [MEMORY LOST] may occur.

If, at the first press of the [ON] key the 'supposed' faulty contact is established, then in the second press the calculator will turn on and will react to the [ON]-key pressing for as long as it happens briefly. If it rests for a while, chances are that the contact fails again.

These are just considerations based on the fact that the calculator is a fullnut and it has been serviced. I'd search for cracks in post or, mostly, in the receded area around the hole for the top, longer screws. This area cracks easily, and chances are that they really break if the screw is forced too much. I 'sense' the pressure over the case with my fingers, but it is a bit hard to explain. I'll add some pictures later and try to use words and images, maybe I'll succeed.

Not too much of help, but it seems to me it is not hard to repair.

Success!

Luiz (Brazil)


#19

Hi Luis,

and thanks a lot for your interest (and thanks to Bruce, too.)
The zebra contact issue was solved in a 'definitive' way, that is with wires soldered between the keyboard and the mainboard, and that was done by a pro. I know this could be questionable by 'collector' standards :), but I feel the calc is way better than new right now, at least from that point of view. Bad contact could still be there in the part under the display, though. Anyway, there is no sign of malfunction even by (lightly) twisting the calc or pressing in different areas.
Bruce was asking about programs etc., but no, often the symptom has arised after a 'on+backarrow' procedure.
The one thing I didn't try yet is leaving the batteries out for enough time as to provoke a 'memory lost', a real cold restart. In what would this differ from an 'on+backarrow' sequence?

Again, thank you very much,
Paolo


#20

Ciao, Paolo;

the 'system' memory loss depends on existing system regular operation. In some circumstances, [ON]/[backspace] is disregarded and the calculator does not clear its own memory.

I prefer the 'hardware' memory loss, because it gives you the closest factory condition. In terms of final memory contents (RAM), once you see [MEMORY LOST] I cannot think of any differences between both, though.

When needed, I open the calculator and short the terminals of the two 'big' electrolytic capacitors in the mainboard. I cannot tell you which one first, but I choose the bigger one first (IIRC, this is the one with the power line). A few days ago I found myself in one particular case: a halfnut simply locked itself inside its own and lost the keys... The display froze with [0.0000] with no visible cause and stayed like like this, no reaction.I removed the batteries for a while, put them back, turned the calculator back ON and nothing changed. I tried the [ON]/[backspace] and nothing. No response at all.

It worried me a lot because it was a halfnut, and they are not serviceable the way the coconuts are. Then I opened opened the calculator and shorted the only two electrolytic capacitors it has. Working fine after about a week or so.

I also have one HP41Cx (halfnut) that has a troubled [4] key. It fails to work when pressed by the first times, but once it starts working flawlessly it stays like this until the calculator rests for a while. Like if there is some kind of dirty stuff that moves away when pushed (a gel?) but gets back when left untouched. Does it exist or it is just my pride trying to solve a mystery? :^(

Hope this helps a little bit...

Luiz (Brazil)


#21

Ciao Luiz,

seems like your '4' key has something resembling my 'on' key...
Anyhow, I just took the batteries out of the 41. I'll wait till reinserting them produces a 'Memory lost' and let you know what happens after that.

Thanks,
Paolo


#22

Paolo;

wait for a few days, maybe a week, OK? The power consumption for the HP41 is so small that it takes a while till the capacitors go bellow the minimum operating voltage. That´s why I go straight discharging the capacitors...

Cheers.

Luiz (Brazil)

#23

ciao Paolo,Hi everybody,
what kind of wire did you use ?
I'm thinking about fixing mine in the same way.
Thx for help, Alberto


#24

Please, what I want to know where can I find a Card Reader for my HP 41CX. If you know, please tell me where can I buy one of it.-
Another thing, what I need is how can I convert my programs in a languge like Visual Basic 6.0a of Microsoft or how may I pass to a PC these programs I have done yeras ago.-

Thank you for all.


#25

Aldo,

The best source I know of most reliable card readers (HP-82104A) for HP-41C/CV/CX is from a guy called Richard Anthony, in the US. He repaired/serviced all my card readers, and they work brilliantly. He's on eBay with the id of 'plasmoid'. He doesn't always have a card reader on sale, but drop him a line with what you want (from an active eBay item), and he will most likely be able to procure it. Considering the quality, his prices are very reasonable.

Regards,

Philippe


#26

Thanks a lot for your consideration and deferent answer. The best for you.-

#27

Any programs in the calculator? Any timers active?

I used to prank my friends by putting in an "OFF" program and have it run after midnight. Drove them crazy the next morning. ;)

Doesn't sound like your situation, but I thought I'd offer.

thanks,
bruce


#28

Well, I left the batteries out for about 12 hours and got my 'memory lost'. After that the probblem is still there. I discovered that the amount of time needed to get the 'false start' is completely random. Sometimes it will sit for hours and restart promptly (even with *very* light pressure of the 'on' key), sometimes, thirty seconds after an on/off cycle it will need two 'on' key presses. It is definitely a very insignificant 'problem', but I still wonder what may cause it.

Thanks,
Paolo


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP-41(CL): The easiest way to transfer FOCAL programs from a Linux PC to the HP-41 Geir Isene 13 2,250 12-05-2013, 02:40 AM
Last Post: Hans Brueggemann
  HP PRIME : strange behavior when trying user key capability Damien 12 1,603 11-03-2013, 11:02 AM
Last Post: Joe Horn
  HP Prime Save Power Turn Off Not Working Timothy Roche 12 1,561 10-27-2013, 01:41 PM
Last Post: Michael de Estrada
  HP Prime: Slow turn off Paul D. Fox 1 539 10-09-2013, 08:39 PM
Last Post: Tim Wessman
  Prime formatting behavior Camille 0 360 09-28-2013, 05:37 PM
Last Post: Camille
  wp-34s (Inconsistent Behavior) Barry Mead 2 545 07-23-2013, 02:54 AM
Last Post: Marcus von Cube, Germany
  HP-41C Tall Keys Strange ON Behavior aj04062 3 693 12-02-2012, 06:49 AM
Last Post: aj04062
  Weird behavior from lithium AAs Dave Britten 4 628 11-14-2012, 06:22 PM
Last Post: Lars Bergström
  HP15C strange complex number behavior Mike W 5 826 09-11-2012, 04:36 PM
Last Post: Mike W
  Curious SINPLOT behavior on HP71B Christoph Giesselink 4 700 07-12-2012, 03:12 PM
Last Post: J-F Garnier

Forum Jump: