HP41 ROM images related: I didn´t see that comming...



#2

Hi, all;

I was checking the ROM images that are stored in my computer when I also decided to check the ROM versions of three different 82143A printers' interfaces. One of the printers is complete, the other two may be combined to assemble one working unit (there is only one mechanics).

I loaded the three images, one at a time, in three MLDL2000 SRAM addresses: 08, 09 and 0A. Then I listed the ROM images and saw that they were of the same 1E version. But then I decided to upload each one of them to the computer, and after opening the three images I found this:

ROM Filename    : D:\HP41-related\HP41_ROM_images\printer_1E_0.rom
------------------hex---dec----------------
XROM : $01D 029
# Functions : $019 025
ROM Name : -PRINTER-
Pause Entry : $28B
Program Entry : $000
Sleep Entry : $000
OFF Entry : $000
Service Entry : $26B
ON Entry : $23B
MemLost Entry : $233
ROM Revision : PR-@@
Checksum : $36E CHECKSUM NOT GOOD, should be $3BA
NOPs Counted : 77

ROM Filename : D:\HP41-related\HP41_ROM_images\printer_1E_1.rom
------------------hex---dec----------------
XROM : $01D 029
# Functions : $019 025
ROM Name : -PRINTER-
Pause Entry : $28B
Program Entry : $000
Sleep Entry : $000
OFF Entry : $000
Service Entry : $26B
ON Entry : $23B
MemLost Entry : $233
ROM Revision : P@-@@
Checksum : $36E CHECKSUM NOT GOOD, should be $067
NOPs Counted : 93

ROM Filename : D:\HP41-related\HP41_ROM_images\printer_1E_2.rom
------------------hex---dec----------------
XROM : $01D 029
# Functions : $019 025
ROM Name : -PRINTER-
Pause Entry : $28B
Program Entry : $000
Sleep Entry : $000
OFF Entry : $000
Service Entry : $26B
ON Entry : $23B
MemLost Entry : $233
ROM Revision : PR-1E
Checksum : $36E CHECKSUM NOT GOOD, should be $06A
NOPs Counted : 251

Three different NOP counts, three different checksum (the three of them not good), three different ROM versions, and they are reported Printer 1E.

Now I'm stuck! I'm willing to check all ROM images that share the same ROM version # because now I see that they may be different inside... Any other related event?

It seems that the rabbit took a deeper warren...

Cheers.

Luiz (Brazil)


#3

It appears that whatever process you used to transfer the ROMs from the printer modules to the MLDL is not reading them correctly. The '@' signs in the module name/version are indicative of reading zeros instead of valid data, which is consistent with the varying NOP count. I suspect that if you read the same module multiple times, you will not get consistent data.


#4

Hi, Eric;

good point, indeed. I am using an HP41 halfnut with both an MLDL2000 (configured with HEPAX in page #5) and one printer module connected to it. I'll repeat the process and copy the same printer ROM to other different SRAM blocks and see what happens.

Cheers.

Luiz (Brazil)

#5

Up and downloading may not always be reliable, be sure to check the process with Verifym (or use autoverify), or use the data only when opening the ROM file from disk.
If this happens more often, you should reduce the communication speed in the Preferences dialog, or tweak the other communications parameters.

Meindert


#6

Hi, Meindert;

thanks again for your (always necessary and welcome) advise.

I transferred all HP41 related data I have about the HP41 (>4GB) to a laptop (Acer, could not afford an HP) and then I started it all over: I set comm speed to 181.82kbps (32), JTAG speed to 146.3kbps (40, half of the default speed), USB Timeout to 1000 msecs, FLASH prgm and Sector erase timeout to 2000 msecs. Then I uploaded the 1.51 firmware version to the MLDL2018A again and erased all its memory. Now I am (slowwwwly) uploading all ROM images again. Well, now I think I am eliminating some, if not all, future issues.

In time: I used HEXEDIT to inspect the interrupt locations and ROM versions of the three printer ROM I mentioned in the beginning of this thread, from within the interfaces themselves, i.e., their original ROM data, not their images, and found out they have identical values stored on them. The discrepancies I found were not from the ROM modules. Lotta work to do, then...

Best regards.

Luiz (Brazil)


Edited: 22 Nov 2009, 8:07 p.m.


#7

Do not make the settings too slow, especially be careful with the JTAG speed, as some of the programmed delays depend on it.
I usually run eveything on the highets speed, but if your USB port is a bit slow, or if you hav emany other active devices on a USB hub, sometimes data is missed.

For up and downloading: there is a backup function in M2kM. A saved backup can be edited like any MOD file, and then restored, so you do not have to handle each ROM image individually.

Meindert

#8

Luiz,
Could you send me your modifications to preliminary 43A study? I like to share advancements in thinking. Maybe you can add some notes to the prelim study? I haven't had much time lately to study 43A as they all got melted but i do love this device. Do you remember when the big thing was to grind down the return cam so that we could get full graphic image dump on 2" wide paper? Good machine that can do startling images on thermal paper.
Oops, i just drove up the price of old 43A printers.
Doug


#9

HI, Doug;

thanks for your reply.

(un)fortunately the differences in the ROM images happened to be caused by a comms glitch, and after the problem was solved all three ROM images downloaded perfectly identical to each other.

And yes, I remember the 'Hanukkahs' (at least I remember people using this names) shown in some club publications. One of them called my attention: it was a boat in the sunrise, in one of the HP Key Notes.

As I mentioned, I have a fully working and two-to-build-one 82143A´s. They have some differences in their PCB layout, will take pictures and, as I have them taken, I'll share them at photobucket. In the meantime, if you want to have a look at some of the other pics, be my guest:

Gentle beasts they are, these HP82143A...

Cheers.

Luiz (Brazil)

Edited: 7 Dec 2009, 11:39 a.m.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Sending little images to the Prime (...and Program name bug?) Erwin Ried 19 2,736 12-10-2013, 05:35 PM
Last Post: Erwin Ried
  HP-Prime CAS nice images CompSystems 9 1,110 08-28-2013, 12:00 PM
Last Post: Juergen Keller
  HP 41 Mcode related Questions Michael Fehlhammer 4 781 05-10-2013, 07:09 PM
Last Post: Michael Fehlhammer
  HP85 Programmable ROM cardtridge 82929A-service ROM not working- inaki 2 732 04-25-2013, 08:08 AM
Last Post: inaki
  [41CL]Updating ROM images with a Clonix Dan Grelinger 14 1,622 02-13-2013, 10:41 AM
Last Post: Ángel Martin
  Newest 41CL ROM Images Dan Grelinger 2 482 01-16-2013, 01:25 PM
Last Post: Monte Dalrymple
  shelf life time of a ROM, EEPROM, EPROM vs Mask Rom Guido (Canada) 6 1,065 01-11-2013, 04:09 PM
Last Post: Thomas Falk
  What didn't you do last year ? Michael de Estrada 16 1,576 01-09-2013, 01:45 PM
Last Post: Marcus von Cube, Germany
  DEL. SERV 1 (USPS) module: I didn't see that coming... Luiz C. Vieira (Brazil) 4 700 11-09-2012, 01:29 AM
Last Post: Ángel Martin
  Big ROM - 41 System DEMO ROM Ángel Martin 5 972 10-16-2012, 05:28 AM
Last Post: Ángel Martin

Forum Jump: