Pil Box ... works like a charm !



#2

Had my Pil box for about three weeks now. Initially I had some problems with my (real) 71b locking up and lots of HPIL broken loop errors.

It was a problem with my Framework installation. I repaired it with the microsoft software and Voila ! It works like a charm.

Brilliant I'm chuffed to bits as we say over here.

Thanks to Jean-Francois for his efforts. It's worth every penny.

If this sounds like an advert I'll point out that I have no connection with Jean-Francois apart from buying a box from him LOL

Now HUNGRY for LIF images

Sean


#3

My PILBox with HP-71b chokes. What kind of framework update did you do? I guess you're talking about .Net. I'll test with a different PC later.


#4

What does PRINT VER$ return? PIL-Box 1.2 or 1.3?

Thanks.


#5

Framework 2.0 Will check version of PIL box tomorrow (it's at work)

Marcus how does it 'choke' ? What are the symptoms ?

Sean

Edited: 13 Oct 2009, 1:53 p.m.


#6

I get "HPIL ERR: Message Error" and scrambled output in the display window.

My HPIL-1A seems to be the culprit, at least that's what JF told me. I might have to reflash my PIC to get it working.


#7

VER$ does not return the PIL Box version. I asssume its the latest firmware though as the box ifs from JF's latest batch.

My HPIL is ver 1A

My problem was also either broken loop errors or HPIL message errors.

I could see output in the scope window but nothing in the display area.

Sean


#8

Seems to be the same case as mine. JFG is working on the problem. I've a prommer so I can update the FW in my PILBox from images recieved by mail. Hopefully this will result in a new FW that works with 1A.

#9

Hi Sean,

At least, the PILBox (firmware 1.3) works correctly with your 1A module. I have no problem as well with my 1A module.

It seems there are some differences between the 1A modules, unless Marcus's problem is due to something else. But for the moment, I still suspect the 1A module because the symptoms are very similar to what I (and others) observed with 1A modules and PILBox firmware 1.2.

J-F


#10

JF, we can swap our 1A modules for further testing.

#11

As I mentioned earlier in HP-IL 2009 thread there are problems with PILBox firmware 1.3 and HP-71B with HPIL version 1B.

#12

Quote:
At least, the PILBox (firmware 1.3) works correctly with your 1A module. I have no problem as well with my 1A module.

I no longer have a problem with my 1A. I just reprogrammed the PIC today with 1.3 and tested with ILPer (Windows in a VM session), Linux and OS/X (hpil_test) without issue.

#13

My problem still persists, even with 1.3. It's probably my specific interface.

JFG has asked me to perform at test with another device in the loop. The only device I could provide was an old PC with Christoph's card and EMU41: It made the connection to ILPer work, but I have to recheck with a reversed setup (changing the position of the PC in the loop.)

Edit: I've just checked it: With the PC in the loop, PILBox works, without I get errors, no matter where in the loop the PC is.


Edited: 17 Oct 2009, 6:03 p.m.


#14

JFG has sent me a new incarnation of the firmware. This works better but mass storage access still produces errors. I'm positive that he will sort this out... :)


#15

JFG has created a fix for my HP-71b 1A HP-IL problem. The controller is simply too fast: It starts sending the next frame while it is still receiving the last package rearriving around the loop. This seems to have confused PILBox. Another device in the loop slows down communications enough to make PILBox happy.

The recent fix (1.3.3) introduces a special, jumper selectable, "no other device in the loop" mode that seems to take care of my 71b's behavior but might interfere with other devices in the loop. Since I don't have any other device, I'm happy with the solution.


#16

Hi Marcus,

Is this a firmware fix ? My PIL box has started to work intermitently with my 1A HPIL. It's really weired sometimes it will work for an hour and then on re-connecting fail for the rest of the day. I'm afraid I spoke too soon ! Maybe it's a temperature effect (clock drift ?) with the marginal timings.


Sean


#17

Sean, do you have any other HP-IL devices that you can put in the loop? If that fixes the problem, the new FW will help you. JFG can certainly send you the HEX file but you need a PIC programmer to install it on the chip.


#18

Hi Marcus

Yes I'll try to put my printer or 9114A in line tomorrow. I have a programmer so I may ask JFG for the new code.

Best Regards

Sean

Edited: 28 Oct 2009, 4:21 p.m.


#19

I tried the HP9114 in line and it still didn't work.

JFG has kindly sent me an upgraded firmware version to try.

Will keep you posted. It's a bit difficult at the moment as I'm trying to move my laboratory Where did I put that programmer LOL ?

PS never try to lift a Cascade Mirotech 12K prober with less than 4 VERY strong guys !!!


Edited: 4 Nov 2009, 1:57 p.m.


Possibly Related Threads...
Thread Author Replies Views Last Post
  How to copy files from 9114B to hard drive via PIL-box? Joe Horn 23 2,920 12-14-2013, 11:57 PM
Last Post: Geoff Quickfall
  HP Prime works from the traditionally TI community... debrouxl 1 372 12-06-2013, 09:00 PM
Last Post: Erwin Ried
  PIL-box w/o IL cable = paper weight Joe Horn 15 1,382 11-26-2013, 01:05 AM
Last Post: Les Wright
  Box left at HHC Tim Wessman 1 358 09-26-2013, 11:05 PM
Last Post: Wlodek Mier-Jedrzejowicz
  Looking for scans of a HP-19c Box ledudu 5 481 01-20-2013, 06:13 AM
Last Post: Lode
  HP48GX everything works perfectly except the 'ON' key? Bruce Larrabee 5 528 10-22-2012, 05:41 AM
Last Post: Bruce Larrabee
  Make PIL-Box ILPer program run on OS X Juergen Keller 6 605 09-07-2012, 04:38 PM
Last Post: Hans Holzach
  Using PIL-BOX & ILPer to Transfer Programmes from PC to HP41CX? Michael Lopez 5 494 06-25-2012, 09:31 AM
Last Post: Michael Lopez
  HP-IL: Using 82162A Printer and PIL-Box in Same Loop Les Wright 12 865 05-17-2012, 11:58 PM
Last Post: Les Wright
  Program works in emulators but not on HP-15c hardware Marcel Samek 32 1,994 05-11-2012, 08:46 PM
Last Post: Jeff O.

Forum Jump: