HP41C issue: beeps, but the display does not work



#2

Hi, everybody

My newly acquired HP41C arrived with the following problem: after putting a battery pack in and pressing ON, the display does not display anything, or something gibberish. Sometimes all the segments of the left half of display are seen, sometimes all the segments on the right, sometimes upper half, sometimes none, etc. After pressing any key, the display goes out, however a beeping sound (not a normal beep) is heard every three or four seconds.

The battery contacts are in perfect condition: clean, with no corrosion. All the screw posts seem to be intact (lower posts are reinforced by hexagonal nuts).

It also seems that all the keys have a perfect tactile feedback. The gibberish display can be cleared by any key, meaning that every key gives a contact.

What should I do next?

Another question: can I replace the HP41C PCB with the one from the HP41CV? I have an HP41CV with a PCB which works correctly, but the machine has another issues.

Thank you.


#3

HI, Nenad; greetings from this side of the ocean!

Your assumptions are correct: the mainboard of the 'coconut' series (I used to call the 'fullnut' as a counterpart for the 'halfnut', but it seems to me it is not the correct term, though) are interchangeable, and the display should work correctly. The behaviour you describe should be related to a bad contact between the main PCB and the rest of the calculator, and this should be because the small, double zebra contact (either with thin golden-plated strips or multi-contact conductive polymer) has not been pressed enough. If you have any modules connected to the calculator, you could also have other problems. Just as a brief test, press the calculator half cases against each other between the tow rubber feet in the botton, and see if it works. The zebra contacts are exactly there.

If you need more guidance or pictures, let us know.

Success!

Luiz (Brazil)


Edited: 7 Oct 2009, 8:21 a.m.


#4

Your procedure did something very bad to my new/old HP41C. After disassembling the machine, cleaning the zebra strips, retightening the PCB nuts, putting the screws, as well as the battery pack back, the display showed something as:

MEMORY LOST

My machine lost its memory! I thought the memory was somewhere on the PCB. Nevertheless, I looked under the desk and there was no visible HP41C memory. Then the most interesting part comes: after I pressed <alpha> and a few keys afterwards, the LCD display says:

THANKS LUIZ

Finally, I decided not to exchange the HP41C PCB with the one of the HP41CV. Knowing that the HP41CV PCB is OK, this was a new information to me that this is also the case with the HP41C PCB.

Oh, that HP41CV. When I summarize what I have already done to it, it will certainly deserve my post under the topic "condemned to HP hell".


#5

nt

#6

Hi, Nenad;

you have no idea how I missed these moments we experience here... Needless to say I feel back home! Thank you for letting me know about this, I appreciate. Oh, and have you found the memory your calculator lost, just throw it away and allow the little one a fresh new start from now on. Not all memories are good, mostly in 'her' case, with that weird behavior (do you actually think 'she' would like to remember the days 'she' was only able to beep in the blind? I don't think so...).

I am preparing a post (not a big one, just filled with info) in order to update the guys here about some new stuff. Gimme a couple of days...

Best regards.

Luiz (Brazil)

Edited: 7 Oct 2009, 5:21 p.m.


#7

"She" is reserved for my HP67! She was a real beauty back in 1980 when I finally got her attention (and still she is). She was always there with me, ready to help me through my university days, reports, exams, etc. with her bright red LED display and magnetic cards. I would have never completed studying of mechanical engineering without her smart support. Yes, I know that I should have talked to her, brought her flowers, written her poems, try to attract her in other ways, but unfortunately I did not have enough time later on as a young engineer-I had a lot of work to do, and (my confession) treated and exploited her as a working horse.

This is just to explain why I cannot use "she" to address my HP41C-it is only a common calculator.

;-)


#8

I need help...

While reading your text I began listening to Charles Aznavour and seeing a little movie with a calculator, a guy, flowers and happy people... All of this in my head! Doc Meyers, were are you? I need to set an appointment...

Oh, boy...

Edited: 9 Oct 2009, 3:25 p.m.


#9

Well... I used my TI-59 with printer in college to generate love poems for my random girlfriend... I mean, random poems.

Does that count?

Why not "she"? A few of us here, that will remain un-named (Luiz, you know who we are), call our calculators our "babies".

Just terms of endearment. I don't think that's too odd.

I finally pieced together a working 29C. A working circuit with a working keyboard. She's beautiful. She needs an HP-10 calculator to share a shelf with, now. Her Woodstock siblings and 19C big brother are getting old... they need a new companion...


#10

Hi, Doc; good old days, ahn?

You see, while reading Nenad´s post I actually 'traveled' that way, like a prelude for a TV commercial! That was wierd...

Anyway, I´m also guilty as charged... I still look at any of the Voyagers and think: 'What a beautiful design...'. Same with the HP71B (remember it? Still here, of course, and working fine...). I just did not know how bad that could be prior to consider that a way to get us rid of the 'HPless Hell of Sinners'.

'Nough said, though! The new guys may be wondering if this is the kind of stuff I actually used to post about in the past... I should have waited a bit more, right?

Quote:
(...)to generate love poems for my random girlfriend... I mean, random poems.
Hope your wife does not read the Forum...

Cheers!

Luiz (Brazil)

#11

Hi, Nenad;

just to add that the golden plated zebra stripe is very fragile, and gentleness is demanded when cleaning it. I have what remains from a zebra stripe that simply dismantled in various parts, the zebra contacts themselves broke in a few small tubes. I was lucky enough to have a spare (polymer type) to replace it.

Cheers.

Luiz (Brazil)

Edited: 7 Oct 2009, 5:27 p.m.


#12

Luiz,

What do you recommend to use to clean the gold zebra strip?

Thanks,

Steve Leibson


#13

Hi, Steve;

I have already used isopropyl alcohol. From our good friend Wikipedia, we have:

Quote:
Isopropyl alcohol is cheaply available. Like acetone, it dissolves a wide range of nonpolar compounds. It is also relatively non-toxic and dries (evaporates) quickly. Thus it is used widely as a solvent and as a cleaning fluid, especially for dissolving lipophilic contaminants such as oil.
Because the conductors are golden plated, they will actually not oxidize, just get dirty or simply isolated because of lack of pressure. But I consider that the main problem actually is how to clean without dismantling the piece. I use regular, commercially available cotton swab moysted with isopropyl alcohol and carefully move it over the surface of the contacts the way I suggest in the drawing below (sorry if it is not better, I drew it right now...)

The image (hopefully) shows the polymer tube where the contacts are build. I use the swab like this to avoid the contacts to detach from the surface of its isolating base.

Hope this helps.

Success!

Luiz (Brazil)

Edited: 9 Oct 2009, 12:12 a.m.


#14

Thank you for that very complete explanation and the excellent illustration, Luiz. I really appreciate the help.

Steve


Possibly Related Threads...
Thread Author Replies Views Last Post
  Solver issue with HP 17BII - different from 19BII Jeff Kearns 13 458 11-28-2013, 02:36 AM
Last Post: Don Shepherd
  emu48 - copy stack doesn't work (as expected) Thomas Radtke 2 246 11-11-2013, 02:19 PM
Last Post: Thomas Radtke
  Another minor Prime hexagesimal issue Jonathan Cameron 1 154 11-08-2013, 02:37 PM
Last Post: Michael de Estrada
  Another Prime mystery - templates don't work anymore Michael de Estrada 2 197 11-02-2013, 11:34 AM
Last Post: Michael de Estrada
  HP Prime Solver Variables Issue Anibal Morones Ruelas 8 447 10-19-2013, 09:45 AM
Last Post: Harold A Climer
  Does the HP Prime software only work with Win 7/ 8 ? Michael de Estrada 3 246 10-12-2013, 02:52 PM
Last Post: John Ioannidis
  Voyager keyboard issue John Richards 2 188 09-27-2013, 07:43 PM
Last Post: John Richards
  Back to School/Work/Other Calculator Poll Eddie W. Shore 63 2,701 09-12-2013, 06:03 AM
Last Post: bhtooefr
  WP-34S: Little issue with program step indicator Miguel Toro 6 304 09-06-2013, 12:45 PM
Last Post: Miguel Toro
  HELP! WP-34S (Flashing Issue) Barry Mead 2 183 07-15-2013, 04:25 AM
Last Post: Marcus von Cube, Germany

Forum Jump: