Connecting HP 48GX with PC via!!!


I need some help with this first time connection...

I am trying to download the XModem (Manual-XRECV) following the steps: ' alpha X , left shift I/O , NXT , XRECV .... After some 20 seconds the calc displays: "XRECV Error: Transfer Failed"... And that's the end of the loop... I cannot connect the calc with the PC....

I am using a serial-USB adapter because my laptop does not have a serial port.. could be this a problem?

Any idea or hint? Thank you!!!


Hola, Juan; que tal?

If you are using an HP48GX, the only port available with its hardware is RS-232 compatible (PC_compatible serial) and, if I am not wrong, it is possible to use a serial-USB converter (that should not be the problem). But I am not 100% sure about this...

If you have the chance, try using another computer with a RS-232C compatible serial port just to make sure your HP48GX connects correctly.

(after editing) I forgot to ask: the keystroke sequence you mention, is it correct? I cannot check now, but it seems to me it has more keystrokes than usual (maybe it is because I´ve been using the HP50G more, lately)


Luiz (Brazil)

Edited: 5 Oct 2009, 12:52 p.m.


Hola Juan,

Something doesn't seem right here. If your HP 48GX recognizes the XRECV command, then you already have the XMODEM library installed on your calc, and shouldn't need to download it again. I too had problems with communication between my HP 48SX with XMODEM on it and my PC using Conn4x and a USB to RS232 converter. I did try some other communication programs with no luck. I assume that you made sure the communication protocols were matched between the PC and calc (baud rate, parity etc.). I have an old DOS PC with a RS232 port and use Kermit to communicate with the calc.

Sorry I couldn't be more helpful.



thank you Luiz and Michael... I cheked everything (that I know) and is still not connecting....


Hola, Juan;

I looked again at the keystroke sequence and, if I am not wrong:

- you define a variable named 'X' to hold data to be transferred from the computer to your HP48GX ([ALPHA] X); did you try [ALPHA][']X instead?

- then you open I/O ([left-shift] I/O);

- then you 'tell' the calculator to receive data ([XRECV]); it will be stored in variable named 'X', defined in first step, right?

- 20 seconds later you get transfer error message.

What message you have from the PC? What happens in the Conn4x window? The error message appears only in the calculator?

Just to let us track a little bit down.

Saludos, Luiz (Brazil)

Edited: 5 Oct 2009, 5:32 p.m.


That's correct Luiz, step by step.. I got no message in the pc, only in the calculator...It looks like they are not seeing each other...and no connection is stablished...
Reading other mails and possible causes (thank you guys very much!!!!) I am still not clear about the problem... I have XP with SP2, this should not be a problem...


Hola, Juan;

Just another question: when you execute XRECV in the calculator, the computer should also 'be told' to send data. What operation are you performing in the Conn4x after (or before) executing XRECV in the calculator?


Luiz (Brazil)


Sorry Luiz, I've just seen your question... Yes I tried to connect first and then send a small file but the pc did not show any signal with any message. I will try this weekend with the HP explorer and the HP comm sugested up here. Thanks and… um ótimo final de semana para você...


I guess you've recently upgraded Windows XP to SP3? After that serial to USB adapters no longer work even if you re-install windows and don't upgrade to SP3.


Well, I guess it's time to throw my USB > RS232 converter in the trash. :<) I'm glad I still have my old DOS PCs. :>)


Well that's where mine are heading...

I've got one old machine too, kept it just in case.


Edited: 5 Oct 2009, 10:25 p.m.


I am using a Keyspan USB/Serial with XP/SP3 without issue. Perhaps if you uninstall and reinstall your drivers. One thing that I did do was to remove all the extra COM entries. I had 8 or so for many devices that I do not use like bluetooth. After I did that I was able to use two different USB/serial adapters as COM3 and COM4 without issue.


I use a desktop, WinXP SP3. I could NEVER connect to it from my 48G or 48G+ using Conn4x.

I installed an older connectivity program, HP48Explorer. That seems to work just about all the time. I use a serial/USB converter, too.

I'm not sure what exactly is wrong with Conn4x as far as the 48G series machines, and what is exactly right with HP48Explorer, but the latter works.


I'm sure it's not Conn4x - before installing SP3 I connected my Leica instruments to USB ports through serial-USB adapter on 3 different computers. Once they got upgraded (automatically) to SP3 no one can't connect.


Thanks Ed, I will try this HP48Explorer you mentioned....



Did you try it?


In my experience, Conn4x is extremely fussy when it comes to USB/serial adapters. I've never been able to get it to work that way, except for a very old build that's lacking quite a few features (ASCII transfer mode, for one).

Try sending a file to the 48 using HyperTerminal and XModem. Any file will do. I've never had issues getting that to work.


I just tried this without issue. Step-by-step:

  1. Acquire Windows XP SP3 machine.
  2. Acquire USB to Serial cable.
  3. Plug USB to Serial cable into PC. Install driver if necessary (I had to).
  4. Note the COM number, I was using COM3:
  5. Install CONN4X.
  6. Launch CONN4X.
  7. Set "Connect Using" to your COM port (mine was COM3:)
  8. Important. Set "Speed" to 9600 (it defaults to 115200).
  9. On your 48GX Right Shift 1 (I/O), select Transfer..., make sure BAUD is 9600, PORT is Wire, ignore the rest, NXT, then F (OK).
  10. From CONN4X select File/Download HP48 Server
  11. Follow the instructions (I used 'XX' instead of 'X' because 'X' was already in use).
  12. Watch it download and be amazed. :-)

My guess is that you did not do steps 7 and 8. If I omit them then I can reproduce your problem.

Edited: 9 Oct 2009, 4:45 p.m.


Thanks Egan for the detailed step by step explanation. I went thru it fut faild in the last minute, i think.
There was a signal sying 0/3400 bytes transfered....wait... and then another one saying: connection error - please check your connections....
Meaning who knows what....


Try a different USB/Serial and check your HP48 cable and connections.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Connecting 50g to Win7-PC Victor Koechli 6 2,118 07-02-2013, 09:51 AM
Last Post: Software49g
  Connecting a 9825A to the outside world David Ramsey 3 1,722 06-12-2013, 04:13 AM
Last Post: Tony Duell
  Installing Conn4x on Windows 8 Jerry Raia 2 1,160 01-04-2013, 10:28 AM
Last Post: Jerry Raia
  Connecting the HP-41 to the HP-71... Why? How? Geir Isene 8 2,577 09-06-2011, 10:52 AM
Last Post: Raymund Heuvel
  HP Getting out of the PC market? Richard Garner 32 7,097 08-19-2011, 03:49 PM
Last Post: Massimo Gnerucci (Italy)
  Windows 7 and HP 48GX Nico Tak 12 3,429 03-01-2011, 04:02 AM
Last Post: Marcus von Cube, Germany
  HP 48GX Squeaky Anthony (USA) 3 1,529 02-09-2011, 01:15 PM
Last Post: Anthony (USA)
  HP-33C dead after connecting Charger witout batteries Ernst Fueloep 6 1,845 11-08-2010, 10:36 AM
Last Post: Ernst Fueloep
  HP 41 to PC possible? SpeedyVV 4 1,561 08-26-2010, 11:52 PM
Last Post: DavidShenk
  Connecting HP-110 to a 9122D floppy drive John AS (UK) 4 1,651 10-20-2009, 03:49 AM
Last Post: John AS (UK)

Forum Jump: