Repaired HP41CV hangs on error.


Hi folks,

I've recently rebuilt the posts on my old HP 41CV calculator. I gave each of the contacts on all the boards a good cleaning with an alcohol swap and blew dry with air and re-assembled the calculator.

The calculator now appears to work fine (whereas it wouldn't even turn on before) but there is a problem. Upon any error, e.g. divide by 0 or Log(0), the display goes blank and the calculator appears to hang up. CLX or <- do not restore the display. The ON button does not respond. Sometimes holding the CLX key while toggling the ON button results in a CLX command and the calculator continues to function normally until the next error. The calculator is clearly on because I do not get a MEMORY LOST message in this scenario.

...and on further investigation, in PGRM mode, hitting the SST key results in the SHFT flag in the display being show, and the calculator also hangs up. So there are other problems.

Does anyone have any suggestions on how to procede to fix this?

Thanks much, and I love this museum!! If all else fails, I will revert to the HP25C emulator on the links page. Very nice!



It does sound like a bad ROM. But, crud can cause similar behavior so I would recommend you clean the processor board with isopropyl on both sides and let it dry well. If there is any flux on the solder side, get it completely cleaned off.

That might cure it but if not, again, it is most likely a bad ROM.


Hi there,

firstly, Randy is the guru here so I bow to his diagnosis but before you lose all hope read on!

I have just restored two HP 41CX halfnuts and a 41CV fullnut. These too required repaired screw posts:

(battery post repair

All three also needed bottom shell washer reconstruction:

washer posting

Now to the crux of this posting. The two CX's failed to respond after a thorough cleaning, repairing and reassembly. If I was lucky I got nothing but strange characters, other times no display at all.

I tried the memory lost salute, removing the batteries and shorting the far left battery contact with the far right, master clear with batteries removed and all the other methods to reset that are available. I ultimately left the calculators with batteries removed for 4 days as I happened to leave for a trip.

When I came back, I installed the batteries (new) and tried both calculators starting with the memory lost keys (ON and back arrow). I got the memory lost display which I cleared with the back arrow key and they both WORKED and have ever since! I remembered that this was one of the ways to reset the HP 41 series in the event of a severe Synthetic programming mistake.

So try removing the batteries and leaving the unit for a couple of days.

Cheers, Geoff

Edited: 26 July 2009, 6:06 p.m.

Possibly Related Threads...
Thread Author Replies Views Last Post
  MS advert shows spreadsheet with obvious error BruceH 3 1,303 11-14-2013, 09:50 AM
Last Post: Bill (Smithville, NJ)
  hp41cv memory modules tim peterson 10 2,137 11-07-2013, 11:09 PM
Last Post: Garth Wilson
  HP41CV Mike Powell 12 2,064 10-30-2013, 08:17 AM
Last Post: Mike Powell
  HP Prime: Rounding error in determinant Stephan Matthys 3 965 10-25-2013, 09:29 PM
Last Post: Walter B
  HP41CV Bry Sun 11 2,124 10-22-2013, 12:52 PM
Last Post: Geoff Quickfall
  Prime Error or Mine? toml_12953 12 2,151 10-22-2013, 10:35 AM
Last Post: toml_12953
  Explaination on How to Reset Caculator in Users guie: error Harold A Climer 5 1,415 10-15-2013, 02:11 AM
Last Post: cyrille de Brébisson
  Repair of HP-34C - Error 0 and Error 9 Jeff Kearns 3 1,020 10-11-2013, 12:29 PM
Last Post: Randy
  Do You Think a Listing Error Was Made? Jim Johnson 13 2,307 09-04-2013, 09:23 AM
Last Post: Eddie W. Shore
  HP Prime: Error reports : Here Patrice 111 10,766 07-24-2013, 05:52 PM
Last Post: Thomas Klemm

Forum Jump: