HP-97 card reader woes



#7

Hi folks,

after successfully reviving the card reader in an HP-65, I tried the same on an HP-97, but no luck.

I replaced the gooped up pinch roller with silicone tubing and glued the clutch. While I can consistenly read the preprogrammed cards, there's no way in hell I can write and subsequently read a blank card, no matter how I adjust the roller's eccentric shaft. Writing usually occurs without an error, but when a read error occurs, the card reader suddenly speeds up just as the card exits, as if it was trying to read beyond the end of the card.

I then resorted to fiddle with the leaf switch adjustment screws as a last ditch attempt, but no luck there either.

The motor warbles audibly and sounds like it fluctuates in speed. I've tried 3 different pieces of tubing for the roller, with the same results. I suspect the clutch itself is eccentric. Running the motor by itself from a bench supply also produces noticeable flutter.

Any hints before I give up?

Regards,

--Roland


#8

Roland,

Having refurbished a HP-67 card reader myself, including the clutch, there are several things that come to mind:

1) Make sure all electrical wire connections are good (motor to PCB, AC adapter connector pins to motor and keyboard PCB). These are press-fit connections which use the tinned wire as the male pin, and sometimes are a loose fit. Also, make sure these connections don't come apart and the wires are not pinched when you re-assemble the case.

2) Make sure you have not bent any of the spring connector pins on the keyboard PCB or motor control PCB.

3) Make sure the motor shaft is fully inserted through the clutch into the center hole in the worm gear shaft, that the tip of the worm gear shaft is inserted into the hole in the frame and that the rebuilt clutch is not rubbing on the frame. If you have not already rebuilt the clutch, then you probably need to.

4) Lubricate the motor bearings. It is possible to inject some sewing machine motor oil past the shaft seal by orienting the motor upright with the shaft on top, and manually rotating the shaft. Afterwards clean off any excess on the outside and shaft.

5) When you re-assemble the card reader, make sure the little white plastic roller is properly inserted in its slot. Also, I assume you have cleaned the card pathway on the read head side and that your cards themselves are clean.

Finally, a word of encouragement. I'm a total amateur in these matters, and if I can figure it out then I'm sure you can too. Just put it down for a few moments, have a beer, take a deep breath, then come back when your heart rate has returned to normal. You will eventually fix it, of this I am sure.

Bon chance,
Michael

#9

Hi Roland,

from your description I suppose that you got two problems left over.

First I'm not sure whether your card reader is writing at all. Getting no error message after writing doesn't mean that the card was written at all. The reader does not verify while writing. If you also own a HP-41 with card reader, you can try to read the card written by your 97. If the 97 is writing, the 41 will read it (but your 65 won't). If not so, check all of the connections between r/w head and 97 pcb, check the wires for correct order and shorts or intermittent contact. If you have access to an oscilloscope, check the write signals to the head. Use a resistance meter and check the r/w head for broken windings.

I guess your second problem is indeed the kind of tubing you are using. Tygon tubing (outer diameter 6.4mm, inner diameter 3.2mm) has always worked for me, have a look at German ebay shop "gromotec.de", article number 350165752412 (no, that's not my shop :-)) !).

If the clutch is not properly centered you would have to fix this first, otherwise the worm gear will rapidly wear.

It's also not a bad idea to lubricate the motor bearings and worm gear but don't flood the pinch roller and card guide. Some axial clearance of the motor shaft is ok, but excessive radial clearance would indicate worn bearings and can cause the described flutter too.

Never give up, good luck.

Rainer


#10

Thanks for the hints, fellas.

I disassembled another (earlier) HP-97 here and applied the same procedure to the card reader's clutch and pinch roller. The motor screeches like a dentist's drill! Amazingly, it reads and writes flawlessly, despite the racket it makes. I was hesitant about lubricating the motor shaft, but I guess it's absolutely necessary here.

The other card reader still gives me agro. It definitely sounds slower and strained compared to the other one (when it doesn't screech). I'll try a bit of lube on that motor too.

Other than that I've done pretty much all you mentioned except dragging out the o-scope to check the r/w signals. Might be a bit tough without the service manual.

Thanks for the hint with the Tygon tubing, Rainer. Right now I have to make up for the .4 mm difference with a layer of vinyl tape under the silicone tubing. Works, but certainly not as elegant as getting the proper diameter.

Oh, and I'll have that beer *after* I get it working. ;^)

Regards,

--Roland


#11

Well, lubricating the motor shaft achieved nothing. I even swapped the pinch roller and axle with those from the "good" reader. No luck. I'm starting to wonder if it writes at all. Guess it's time for the scope. Should I measure directly at the head or the chip (and which pins)?

Anyone know how to adjust those leaf switches? How do I detect if they're misadjusted?

Boy, have I wasted a lot of time on this is a DOG of a card reader. I guess there's a reason this particular HP-97 is in such great cosmetic shape... ;^)

--Roland


#12

A scope will tell you nothing.

If you receive the "Error" message when writing, the switches are most likely out of adjustment. You said earlier you "fiddled" with the leaf switches. Do you know how to set them correctly? I ask because it is a black-and-white procedure, no "fiddling" involved.

If you do not have a copy of the 97 service manual from the MoHPc dvd set, it is time to invest in one. The service procedure is well documented and leaves nothing to chance or guesswork.

Yes, some readers take more effort than others but I suspect it is your lack of documentation that is root cause of your frustration.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Reasonable price for a 41C, Quad Mem, Time, Navigation and Card reader module? Eelco Rouw 10 710 12-12-2013, 01:52 AM
Last Post: Eelco Rouw
  hp-67 card reader problem. Marcel Samek 5 433 12-09-2013, 09:09 PM
Last Post: Paul Berger (Canada)
  HP-97 card reader pinch roller axle davorin 2 272 09-15-2013, 08:47 AM
Last Post: aj04062
  HP-97 Card Reader davorin 3 271 09-13-2013, 04:21 PM
Last Post: Stephan Matthys
  HP-67 Card Reader Repair Question aj04062 1 220 08-08-2013, 11:15 AM
Last Post: Randy
  Hp-67 card reader: tantalum capacitor identification Ignacio Sánchez 8 526 06-02-2013, 07:26 PM
Last Post: aj04062
  WP34s Programming woes Frederick Wahl 8 391 04-05-2013, 03:12 AM
Last Post: Frederick Wahl
  Testing card reader motor for 65 Michae Altmann 2 255 03-17-2013, 09:24 PM
Last Post: Randy
  Repaired HP-97 card reader doesn't show any signs of life jbssm 6 388 02-17-2013, 03:15 AM
Last Post: Alberto Fenini
  HP 65 card reader problem H Fischer 3 258 11-24-2012, 12:11 PM
Last Post: H Fischer

Forum Jump: