3421A voltmeter drifts up when open circuit



#5

Do other 3421A users see this behavior? (Or users of other high impedance voltmeters?)

If the unit is set to DC volts, autorange with the input open circuit, and the controller asks for readings over and over, the unit returns readings that slowly increase from 0 to .3V, then it switches to the 3V range where the readings continue to increase until the unit switches to the 30V range. At this point, because of the lower input resistance (10 Mohm), the voltage drops to near zero and so the unit switches back to the .3V range and starts over. It does this even with no mux installed and the internal harness unplugged. When I connect a 100Mohm resistor (the largest I have - I don't even know how close it is because I can't measure it!) to the front panel jacks, the unit reads zero all the time. BTW, if the unit is set to .3V or 3V (not autorange), the reading rises to overrange and stays there.

My theory is that this is caused by leakage from the coils of the relays that route the signals on the main board. The coils are all connected to +5V and the other ends are switched to ground to actuate them (they are the same latching relays that used are on the mux board). The specified input resistance of the voltmeter is 10 Gohm (10^10 ohms!) on the two low ranges and I imagine the input capacitance is being charged from +5V through the leakage resistance of the relays. I think this is the kind of leakage that is supposed to be avoided by the "guarding" techniques recommended in app notes for high input impedance amplifier ICs. The relays probably don't have any provision for guarding (would require an extra pin to be connected to the guarding potential).

If I ever get very brave I might try to isolate the relays from +5V to test my theory (since they are latching relays they don't need power to stay in their current state).


#6

Yup.

I built a FET input multimeter using a very nice multimeter movement I salvaged from a home built VTVM. The problem was I used a phenolic PCB which was partially porus and as it absorbet moisture a stray voltage leaked into the the gates of the FETs. As I dried out the board the meter stabilised.

This was about twenty years ago when fibreglass was not as prolific as it is today. I replaced the PCB with a fibreglass board and no more problems.

It could be dust, a porous PCB, damaged transistors (I am not familiar whith this model - is it VT or FET?). There is probably some leaky voltage (current) somewhere.


#7

The active input circuitry is a hybrid, probably CMOS, but before it gets there the signal passes through some DIP relays that select the voltage range. This is a low cost (for HP) instrument from around 1982 that has the distinction of using HPIL to connect to a controller. It measures DC volts, AC volts, resistance (2 wire or 4 wire), frequency (to a very limited extent), and has firmware to read T-type thermocouples directly. It can hold option boards which provide a relay multiplexer or digital I/O. It has no display of its own. HP also made a multimeter with front panel controls and display (3468A/B) with similar measurement capability (plus internal current measuring shunts) and HPIL.


#8

I have seen similar behavior on my HP 3468A Multimeter.
It seems to use the same A/D converter as the 3421A.
Should be no problem because You will never get anything
to measure with a resistance near the input resistance of
the 3421A.

#9

I've never taken enough readings to look for a trend, but my 3421 certainly drifts (or picks up noise, as I said I've not taken enough readings to say which) when the input is open-circuit. Most very high impedance voltmeters do.
As soon as you connect a source with a sensible restance to the input, then the readings become stable. And since I only ever use it for measuring such sources, it doesn't worry me.

#10

Thanks for the feedback. It makes me more confident in the instrument, which is the best meter I have. Since it generally agrees with my other meters, I'm considering it to be "in calibration", I even managed to replace the lithium backup battery without losing the calibration by hooking up a bench supply during the operation.


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP-65 short circuit Ignacio Sánchez 2 385 10-22-2013, 08:27 AM
Last Post: Ignacio Sánchez Reig
  How to open 82162A Thermal Printer Chassis? Ron Fredericks 1 326 07-17-2013, 03:58 AM
Last Post: Tony Duell
  any open source HP 10BII emulators? John 15 1,222 06-12-2013, 09:58 AM
Last Post: Kimberly Thompson
  Need manual for HP 44464a (a 3421a I/O board Alan Sciacca 1 234 03-12-2013, 03:31 AM
Last Post: Diego Diaz
  Programming cable for hp-30b -> wp-34s Open letter to Gene Nigel Rowe 37 2,180 08-02-2012, 12:30 AM
Last Post: Guy Dufour
  HP-71B and the HP-3421A Vassilis Prevelakis 5 415 02-29-2012, 09:30 PM
Last Post: Vassilis Prevelakis
  Circuit for HP3421A Data aquisition Barrie Carruthers 4 389 01-06-2012, 07:14 AM
Last Post: RamLab
  HP48 open/repair guides back online Han 2 330 11-04-2011, 11:15 PM
Last Post: hpnut
  An "Open" letter to "DIY" and "Repurposed" calculator projects Ethan Conner 40 2,197 10-21-2011, 04:41 PM
Last Post: Ethan Conner
  A simple (and useless) digital circuit for the fans of the HP-15C (and two other HP calculators) Gerson W. Barbosa 7 541 10-17-2011, 07:23 PM
Last Post: bill platt

Forum Jump: