HP82161A Digital Cassette Drive


Years ago I packed this unit away during a move. It surfaced a couple of weeks ago. After inserting a new battery and attaching it to the HPIL loop with my HP-71B, it worked perfectly (reading and writing files) for about five minutes. Now however, it seems to work the drive motors, passes information through the HPIL to other devices, but doesn't seem to read or write to the tape. The tape mechanically actuates like it is writing or reading a file but then I get an error message "Device not found."

Does anyone out there have any ideas about what's wrong and how to fix it or get it fixed?


It sounds like the tape head got dirty. When tapes get old, they start to deposit significant amounts of their oxide onto the tape head. Soon it is thick enough to prevent reading and writing. Take a look at the tape head, and carefully clean it with a sponge (or cotton, if that's all you have) swap moistened in denatured alcohol.


Thanks for the suggestion; but I had already cleaned the head before I asked for help. The head was clean and shiny before I swabbed it with alcohol. In fact, the drive looks factory fresh.

I'm thinking the problem is within the read/write electronics. UGH!!


One thing that is a bit confusing is the HP-71 error, "Device not Found". That would seem to be an HP-IL error, not an operation error of the device. When I have a problem with a tape (would appear to be the same as a read/write electronics problem), my HP-41 report "Medium Err". I don't have an HP-71, so I don't know what it would report. "Device Not Found" seems like a timeout error.

Can you do a successful 'Find ID' command, using the HP-IL ID of the cassette drive?

Is the HP-IL timeout adjustable on the HP-71? Just guessing, but perhaps as you wrote files to the device, the access time got longer and the HP-71 HP-IL interface is timing out.



Hi Dan,

Been away a few days...
Yes, the error is now related to the medium rather than device not found. I don't know why it changed. The only thing I did was re-clean the heads (which looked very shiny and clean already.) But I took your suggestion and claeaned them again.

Again, I put in a fresh tape and it went through the motions of formatting. Tape ran through twice -- once for each head I suppose. then when I tried to write to the tape I got the "medium improper" message -- I forget the exact wording.

I suspect a read/write circuitry problem because when I first used the device, after of years of storage, it seemed to catalog the tape properly and I transferrred one program from tape to HP-71. Then it quit transferring data, seemed to work mechanically, and then I got those two error messages with subsequent attempts to read and write. Since I cleaned the heads the second time I seem to only get the "improper medium" message.


Edited: 1 Aug 2008, 9:19 a.m.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Need service information for HP 82161A Cassette Drive Peter N1 2 1,383 07-14-2013, 04:11 AM
Last Post: Tony Duell
  9114A Drive aj04062 4 2,247 11-17-2012, 07:48 PM
Last Post: Raymond Del Tondo
  200LX -- can't seem to access A: drive Glenn Becker 6 2,455 04-09-2012, 12:23 PM
Last Post: Glenn Becker
  OT: Sharp PC-1600 Cassette Files Bill (Smithville, NJ) 0 914 03-18-2012, 05:58 PM
Last Post: Bill (Smithville, NJ)
  [OT] Pens for SHARP CE-150 printer/cassette interface Miguel Toro 4 1,774 01-09-2012, 09:45 AM
Last Post: Klaus
  Digital watch wars Howard Owen 0 885 01-05-2012, 07:20 AM
Last Post: Howard Owen
  Interesting find: HP 9875A dual cassette drive David Ramsey 16 3,925 11-03-2011, 06:59 PM
Last Post: Eric Smith
  A simple (and useless) digital circuit for the fans of the HP-15C (and two other HP calculators) Gerson W. Barbosa 7 1,927 10-17-2011, 07:23 PM
Last Post: bill platt
  HP-9114A Drive aj04062 9 2,891 05-09-2011, 03:30 PM
Last Post: Eric Smith
  HP 9865a cassette tape drive Keith Lueck 2 1,091 11-01-2010, 11:20 AM
Last Post: Keith Lueck

Forum Jump: