HP-41CX & Barcode Wand Problem


I've just purchased a barcode wand for my newly acquired HP-41CX.

If I insert it into port 2 or 4 it works perfectly. However if I insert it into port 1 or 3 the LED fails to light.

If I run a Catalog 2 with the wand inserted into any port it does list "Wand 1F" which makes me think that it can detect it and that the functions are loaded.

Is there any reason why the LED won't work in ports 1 & 3?

Ideally I'd like it in port 3 so that I can have the card-reader installed at the same time.

Thanks for any insights.



It seems to be some sort of contact problem,

just carefully clean the contact foil which makes up the ports;-)

Also check if the case halves of the HP-41 housing are held together tightly.

Is there any corrosion insde the battery compartment or on the port contact foil?




Hi Raymond,

Thanks for your suggestions.

I have carefully wiped the contacts in the ports of the 41cx with a cotton-bud dipped in methylated spirits and this removed a tiny amount of dirt.

However, the problem still remains. All fine in ports 2 & 4 and nothing in ports 1 & 3. Sometimes when I move the wand back to port 3 and press the scan button, I very briefly see a flicker of light in the tip, but it immediately stops and doesn't return.

The battery contacts are clean as a whistle.

Having just received the wand, I'm stuck as to whether the problem is with the wand or the 41cx. I paid a lot for the 41cx, but it does seem to be in excellent condition.

Any further thoughts gratefully received!



As a WAG, it sounds to me that there are worn power port contacts in ports 1 and 3, since the Wand LED needs more juice to work than a normal module. This would allow a Cat 2 to work since only the Wand's built-in ROM is responding. My first suggestion is to clean the gold contacts on the wand itself. If no change, then do you have another 41C to test the wand in ports 1 and 3 just in case there is some addressing issue. Finally, do you have some other device, like the Infrared Printer module and try it in port 1 or 3 to see if it can print from those ports. If you don't have something like that to test those ports, then pull the batteries and try to inspect the contacts directly using a small, plastic dental inspection mirror and see if any contacts look worn and have gold missing on a contact.

I sent in my original 41C and CV in for repair last year and was told that the port connectors were worn. It just so happened that on the unmentionable site there were some 41C mid-plane sections being auctioned. I bought two and had both mid-planes replaced. My old mid-planes still work and might be in better shape than yours. If it becomes necessary, I will donate an old mid-plane to help get your 41CX up and running. I can also pass on the guy who worked on my 41s as did a great job.



I have two 41cxs. One half (sn 2534S), one full (sn 2506S). The fullnut has the same problem you describe. Any other module works but the wand in ports 1 and 3. As for the halfnut, it works in all ports. I tried new batteries in the fullnut. No luck. I took the fullnut apart, the ports look clean inside and out.



The Wand transducer does not takes its power from the V+ line but directly from the BAT line. While the ROM uses V+ line, that's why you can still see its ROM in CAT 2.

Certainly it looks like the contact from the keyboard PCB to the I/O block is not reliable enough at the ports 1 and 3 side.

You'll need to take your calc apart to determine if this is a question of dirtiness/corrosion, cracked post, loosen screws (the upper left seen from the bottom is the most likely as the BAT contact is the outermost one)

Hope this helps.

Best regards.



A battery post problem could possibly be checked by placing the -41 on a table (with the bar code ROM installed in port 1 or 3), and while on, placing pressure on the raised ridge of the front case between the normal keys and the toggle keys (on/user Prgm/alpha) at the top. If the LED will turn on when applying this pressure, a battery post problem is suspected.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Updated PPC DVD Version 2.10: HP-41 Searchable Program Files and Scannable Barcode Jake Schwartz 3 1,883 09-27-2013, 09:51 PM
Last Post: Olivier (Wa)
  HP 41: new barcode creation tool MichaelG 50 11,940 07-17-2013, 02:09 AM
Last Post: Ángel Martin
  HP41 Barcode ideas MichaelG 6 2,287 07-15-2013, 08:59 AM
Last Post: Olivier De Smet
  What About An iOS/Android HP-41 Barcode Reader App? Jake Schwartz 0 1,050 07-10-2013, 10:39 AM
Last Post: Jake Schwartz
  HP 71b ZENWAND Barcode Reader - Manual Michael Fehlhammer 2 1,225 11-02-2012, 03:34 AM
Last Post: Klaus
  HP-41C clear cased barcode reader Keith Midson 7 2,679 05-21-2012, 08:10 AM
Last Post: aurelio
  Errors reading with a HP 82153A Barcode Optical Wand aurelio 22 5,886 04-04-2012, 05:19 PM
Last Post: Les Wright
  HP-41 Wand: scanning from monitor? MichaelG 10 2,955 02-16-2012, 09:42 AM
Last Post: Vassilis Prevelakis
  HP41 Barcode generation Raymond Wiker 18 4,379 10-29-2011, 02:14 PM
Last Post: Raymond Wiker
  HP-41C SKWIDBC Barcode Generation ROM aj04062 27 6,051 09-07-2011, 09:58 AM
Last Post: M. Joury

Forum Jump: