Strange HP 41C Card reader



#4

Hi all,

I tried to fix the HP 41C card reader, but now, the card passes fine but it only reads and writes correctly sometimes, the other times it either says "Malfunction" or "Incorrect Checksum (or something like that)".

Any ideas of what is wrong?

Thanks in advance,
Jorge


#5

"Malfunction" and or "Checksum Error" is just a sign that you most likely did something wrong...

O-rings or tubing?

Oversized o-rings will cause all manner of problems. They must be size 005, not 006. There's a guy on eBay selling o-rings that are the wrong size. I've repaired several of his "refurbished" readers that had intermittent problems. No wonder.

Did you set the force correctly with the eccentric cam?

A slipping clutch will cause that problem. Did you load the motor to check it?

Malfunction is usually a card position switch problem, Checksum Error is usually a card transport or bad card problem. Both are a sure sign of the card not passing through correctly.


Edited: 27 Jan 2008, 5:06 p.m.


#6

Hi Randy.

I used O-rings I bought from an Italian seller in eBay, I used them to repair an HP-97 and it works fine now.

I don't understand what you mean by:
"Did you set the force correctly with the eccentric cam?

A slipping clutch will cause that problem. Did you load the motor to check it?"


#7

The plastic pin that holds the drive wheel in place is an eccentric, it is used to adjust the drive force against the card.

The procedure outlined below is fully documented in the 97 service manual:

Disconnect the leads of the motor from the board and power from an external 3 volt dc supply.

Insert a card into the slot but do not allow it to be pulled through.

Holding the card, adjust the eccentric for 180ma +/- 20 ma motor current.

If you cannot adjust to that current, you either have or will have a drive problem.

The wrong size rings is a very common problem, especially outside the USA since the proper ring, size 005, is non-metric.


#8

Hi,

"Holding the card, adjust the eccentric for 180ma +/- 20 ma motor current.

If you cannot adjust to that current, you either have or will have a drive problem."

Ok, I did it, although my measuring methods are not very accurate, I used a simple multimeter, the range of values I could get went from about 80mA to 98mA ... very different from the 180mA suggested.
I measured the Amperage directly in the motor connectors.

What can I do about this?

Thank you for all the help so far :)


#9

Possibility 1: The o-rings are undersized.

Possibility 2: The motor to lead screw connection has failed and it is slipping. It is called a clutch but it use it does not and should not slip, it is a similar material to the wheel and does decompose with time. Squeezing the outside metal ring only makes matters worse. The best solution is to remove and clean everything, place a very small amount of superglue on the end of the motor shaft and reassemble. If the material has crumbled and failed, the vinyl insulation from an appropriate sized piece of wire can be made to work.


#10

Hi Randy,

I was indeed the o-rings fault.

I used this aviation tube a Portuguese seller gave to me when I bought one of his 41CV and with it the card reader works correctly :)

Thank you for all your help.

Edited: 29 Jan 2008, 7:43 a.m.

#11

After all not everything is correct.

Although the card reader reads fine, whenever I try to write a card is says "Low battery".
But I'm sure the batteries are good, cause I just tested with new batteries.
Can this also be a problem of the motor?


#12

Test in another 41 and see if you can localize the problem.

You most likely have corrosion somewhere that is interfering with a contact. Start with the battery springs, then the battery/port block.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Reasonable price for a 41C, Quad Mem, Time, Navigation and Card reader module? Eelco Rouw 10 591 12-12-2013, 01:52 AM
Last Post: Eelco Rouw
  hp-67 card reader problem. Marcel Samek 5 353 12-09-2013, 09:09 PM
Last Post: Paul Berger (Canada)
  Strange HP 25 Problem (Repair) Onur Ilkorur 5 310 12-06-2013, 05:13 PM
Last Post: Onur Ilkorur
  Strange Battery Icon during updaate of Prime Firmware. Harold A Climer 7 433 12-05-2013, 04:40 PM
Last Post: Michael de Estrada
  HP PRIME : strange behavior when trying user key capability Damien 12 572 11-03-2013, 11:02 AM
Last Post: Joe Horn
  HP Prime function APP - Strange limitation ! :o( dg1969 2 223 10-04-2013, 12:10 PM
Last Post: dg1969
  HP-97 card reader pinch roller axle davorin 2 237 09-15-2013, 08:47 AM
Last Post: aj04062
  HP-97 Card Reader davorin 3 228 09-13-2013, 04:21 PM
Last Post: Stephan Matthys
  HP41CX: Strange serial #... Stephan Matthys 1 150 09-13-2013, 01:38 PM
Last Post: Stephan Matthys
  HP-67 Card Reader Repair Question aj04062 1 184 08-08-2013, 11:15 AM
Last Post: Randy

Forum Jump: