HP50g Statistics Application



#7

I am new standard user for HP50g calculators. I am as familiar with programming on this calculator. I got the calculator via the company, so I choose the most expensive calculator. I mostly use it for it's statistics applications. Everything worked well until a week ago when I decided to use it for some financial calculations. Since then, I am unable to launch the Statistics application. Instead I get an error message that say BAD ARGUMENT TYPE! This happens immediately i try to launch the application.

I have tried resetting the CAS, MODE, FLAGS, to their default values and nothing works.

Someone please help. If you hang out in owings mills, MD i'll buy you a beer. I am in bind, so any and all help is appreciated. Keep in mind I an not a seasoned user


#8

I never used a 50g. Only 48gx. Have you tried to purge the Sigma DAT variable (the one containing your statistic data). Maybe it got corrupted somehow. But it should not result in a error message right from the start before processing the data. Strange.


#9

Thank you for the response. No, I have not tried this. How exactly do I purge this Sigma DAT variable. There are very few resources on HP calc. troubleshooting, and none I could find about error messages. Please let me know. Thank you.


#10

Hi Sam.

If you press the [VAR] key, then you'll enter the VARiable browser. If necessary, press [NXT] to browse thorugh the variables stored in the HOME directory till you see tha SigmaDAT one (please note that here "Sigma" just stands for the Greek capital letter Sigma - so you're gonna see on the display a Greek capital sigma letter plus the "DAT" suffix).


Then you will want to press:


[LEFT SHIFT][+] @puts a pair of curly brackets on the command line

the [F1]...[F6] key corresponding to the SigmaDAT variable

[ENTER] @to terminate command line input

[TOOL] @to bring back the "basic functions"

[F5] @the "PURGE" key


and you're done!

By the way, if the above does not brings you out of trouble, you may want to consider the following:


1) try to issue the CASCFG command (you may pick it from the [CAT] list you get by pressing [RIGHT SHIFT][]SYMB] - it will "re-configure" the CAS settings

2) try to do a warm reset by pressing: [ON]+[F3] - this will "re-boot" the 50G

3) try to do a full reset by pressing: [ON]+[F1]+[F3] -
WARNING! This will reset the 50g to a nearly "out-of-the-box" state !!

Hope this helps.

Best regards.

Giancarlo

Edited: 7 Dec 2007, 2:34 a.m.


#11

First step worked like a charm. Perfect! Thank you, Thank you. I live in Maryland and you are possibly in Italy. BUT I still owe you a beer. This really saved the day.


#12

Glad it helped :-)

Yes, I live in Italy, but if I'll be passing in Maryland, I'll be happy to taste a beer! (by the way - how about MD's beer?).

Take care.

Giancarlo


Possibly Related Threads...
Thread Author Replies Views Last Post
  hp50g screen weird line Sok-khieng Chum Hun 2 616 09-10-2013, 08:11 AM
Last Post: Sok-khieng Chum Hun
  Documentation about Hp50g / 49g+ / 48gII and wikis Pier Aiello 9 1,266 09-10-2013, 04:22 AM
Last Post: Software49g
  "A Penny for your thoughts" on the HP50g Tom Grydeland 3 730 08-01-2013, 03:57 AM
Last Post: Les Koller
  Is there a HP50g emulator for Linux? Matti Övermark 2 635 07-03-2013, 07:40 AM
Last Post: Matti Övermark
  weird statistics bug in wp34s Andrew Nikitin 5 938 06-20-2013, 01:54 PM
Last Post: Namir
  HP50G advanced applications for mathematics CompSystems 0 506 06-17-2013, 08:38 AM
Last Post: CompSystems
  HP50g rebind stat key Chris Smith 1 536 05-26-2013, 06:21 PM
Last Post: Software49g
  How I use my HP50G at work. David Bengtson 7 1,007 05-06-2013, 02:57 PM
Last Post: Ingo
  HP 10s+ Easter Egg (Statistics) Eddie W. Shore 1 436 04-11-2013, 04:25 PM
Last Post: Andrew Feist
  HP50g emulator Richard Berler 1 488 03-24-2013, 02:43 PM
Last Post: aurelio

Forum Jump: