HP35s missing keystrokes?


Forgive me if this has been covered, but I looked briefly and didn't see anything about it.

I've had my 35s for about 3 months and like it quite a bit. However, I am pretty sure it's missing a few keystrokes. I tend to miss more calcs with it than my 48G. It was widespread enough to cause me to experiment a little.

Here's a great example. I started with 9.7847 on the stack and then tried to calc the simple product: .626(5)(2)/4.45 I ended up with some goofy answers like 30.626 or 6.882 a couple of times.

I actually resorted to video recording the display and keystrokes and ran through the calc about 10 times, going at a natural, but very fast speed. I could very clearly see and hear the click when the 2 was pressed, but it didn't register a couple of times. Of course, the product was multiplied by 9.7847, causing an error.

I'm pretty sure it is actually missing keystrokes, although I can't just sit there and strike 2 over and over and cause an error. Has anybody else dealt with this yet?


I see a similar issue with my 35S on the "enter" key and the number 4. It depends on if I press firmly or not on the Enter key. A firm press results in no problems, a light touch (even if I heard the key click) can sometimes mean a missed key. Same goes for the 4 key.


Hi, Brad --

The HP-35s I purchased in August doesn't seem to miss keystrokes (at least noticeably), but the one I received in September requires a firm press on "0".

-- KS


Hello. My 35s also misses keystrokes. I noticed this when adding numbers at a fast speed (my usual speed when working ;)). In my view the software misses the keys. Conclusion, no more 35s for me. I stick with my 32sii, a calculator that I can trust!


Interesting. One very weird thing is that I can't make the calculator miss a key just by sitting there and pressing it. I also can't make it miss a key by holding down one and pressing another. It even works when I do something like press 1, press and hold Enter, press 2 then +. It seems extremely robust.

Still, I'm almost completely sure it's not registering a keystroke just every now and then, but it's always during real calculations--which seems to strongly suggest user error. It always seems to happen during easy calcs, like a product of 3-4 numbers, which also implies that I'm making mistakes.


I've noticed it on mine as well. As a test I've cleared the stack, typed in a number, then pressed the enter key firmly but quickly 3 times. On rare occasions it will miss one of the enters. I'm personally convinced it is a software/firmware issue since I know I'm making 3 firm distinct key-presses.


I've found the same problem, sometimes with the zero key, sometimes with the decimal point key. I too suspect it's a firmware bug wherein it fails to register extremely short keypresses.

I wonder if hot-rodding the 35s might fix this problem.



Firmware? Perhaps, but since we're seeing different keys it sounds more like a marginal mechanical design/manufacturing issue to me (namely the keyboard) or a combo of electronics and keyboard.


I wonder if hot-rodding the 35s might fix this problem.

How would one go about doing this?


There was a post the other day about speeding it up by up to 50% by changing the value of R1 on the main board.


Is it missing keystrokes... or is it stopping itself mid-crunch when the next button is pressed? I cleared the stack and tried the following several times:

10 enter 3 * 6 /

Using a rapid keystroke, it consistently returns a value of 0.0000. If I slow it down, I get the correct answer of 5.0000. I took it a step further by performing the same calc with 1, 2, 3, etc. in all the stack registers. This is what I got:

stack filled with 1's => 0.0333 (or 1/30), stack filled with 2's => 0.0667 (or 2/30), stack filled with 3's => 0.1000 (or 3/30) ... etc

Too bad HP doesn't simply have an email contact for product gripes. I was just starting to like this calc...


Duh... I'm an idiot. it IS missing a keystroke. The "6" key in this case:

stack filled with 1's => 10 enter 3 * [1] / = 0.0333 (or 1/30)

stack filled with 2's => 10 enter 3 * [2] / = 0.0667 (or 2/30)

stack filled with 3's => 10 enter 3 * [3] / = 0.1000 (or 3/30)

[stack value used when the "6" key was missed]

Sorry for the incorrect post.

Edited: 15 Dec 2007, 8:37 a.m.


Stan, that's interesting. I can crank that equation as fast as possible and it doesn't seem to miss. I *think* mine's missing the decimal most often. These intermittent, inconsistent problems are the worst!

I've been concentrating on punching it fast but smoothly and my problems seem to be going away. It might be that I'm punching it barely slowly enough to eliminate them.


Mine misses the ENTER key occasionally and the "4" key more often. Speed is one thing that affects it (sometimes), but how hard I press seems to be a bigger issue. Harder presses result in rarely a missed keystroke.

The problem seems random as to which key is being missed since we're seeing different keys but a similar condition as to what makes it a missed keystroke. That implies (to me at least) it's more a mechanical design/manufacturing problem and not so much an electronic problem.

I still like the calc, just disappointed with the missed keystrokes. I'd prefer the 33s keyboard just since I knew it never missed my keystrokes.

Edited: 17 Dec 2007, 10:30 a.m.


I guess that's just some dirt from production inside the domes. You could try Randys procedure to clean it in an ultrasonic bath with A.dest.

At a second (electronics or programming) level, the 35s actually misses keys when pressed very fast. IIRC, the binary operators are concerned while numeric keys doesn't have the problem to this degree.


I'm seeing the Stan's problem exhibited with the 2, 3, 5, and 6 keys. I can get the missed keystroke to happen consistently and I can slow down entry to a point where it will not happen. I think this explains the couple of missed keystrokes I have experienced with the HP 35s.


Could it be that the 35s just doesn't scan the keyboard fast enough? This would let you press and release a key in between scans, in which case it wouldn't register.


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP35s Program Four Slings Lift Calculation Jean-Marc Biram (Australia) 2 1,266 12-16-2013, 07:21 PM
Last Post: Jean-Marc Biram (Australia)
  HP35s Calculator Max Rope Tension Program Jean-Marc Biram (Australia) 10 2,576 12-12-2013, 12:03 AM
Last Post: Jean-Marc Biram (Australia)
  [HP-Prime] - Missing confirmation before deletion Jean-Michel 11 2,358 11-14-2013, 05:47 AM
Last Post: Thomas Radtke
  HP 15C missing logo ! FORTIN Pascal 16 2,643 10-02-2013, 08:40 PM
Last Post: FORTIN Pascal
  Missing LCD segments (48 SX) Matti Övermark 2 830 09-18-2013, 03:50 PM
Last Post: Matti Övermark
  Missing functions on the HP Prime!!!??? :-( Namir 6 1,387 08-22-2013, 08:40 AM
Last Post: Gilles Carpentier
  HP-12C: Missing Segments Stefan Ramonat 2 912 06-28-2013, 10:59 AM
Last Post: Stefan Ramonat
  Missing HP Prime introduction Johnny Bjoern Rasmussen 2 891 04-24-2013, 05:18 AM
Last Post: Johnny Bjoern Rasmussen
  Trouble entering a HP35s program line Arno 2 896 04-05-2013, 06:28 PM
Last Post: Arno
  HP35s scientific calculator GREG W THOMAS 4 1,154 03-22-2013, 06:49 AM
Last Post: Thomas Radtke

Forum Jump: