50g won't turn on (or, no screen output) !


Hi folks,

I'm a first timer here. However, I own an HP-41CV since 1981! I still love & use it! (After repairing the Rechargeable Battery Pack and the Card Reader).

Lately, I got this HP 50g, with a problem. It won't turn on(?). I tried ON+BACKSPACE, ON+C, ON+A+F (beeped), RESET, hit it on the table gently; nothing appeared on the screen. Took out 4xAAA & CR2032 batteries for 2 hours. As soon as I re-inserted them back in, I heard a beep, and this time the machine would not turn OFF! Moreover, when I pressed the ON key for a while, I heard 5 quick beeps and a short pause, repeating until I released my finger. I waited a while, and I think it turned itself OFF. Now, I can turn it ON and OFF(=RED+ON), but still nothing on the screen. When ON, I just hear a single beep when I press the BACKSPACE (its tone changes after I hit an ARROW key and then the BACKSPACE). No key beeps when OFF. It seems like the system is coming up, but it is not outputting anything on the screen.

What could be wrong? Is this rather a hardware problem? If so, any ideas what I can do to fix it? What element(s) inside could have gone bad to prevent the screen from coming on (lighting up)? Obviously, ON+"+" (contrast) does not work either.

Any comments would be appreciated.

Thank you,


have you installed any libraries?


At youtube you will find a video on how to disassemble the 49G+. It's Portugese but easy to understand. As the HP 50G and the 49G+ are almost identical from the outside and software-wise, they are maybe also identical concerning their inards.

I used the above video to repair the keys (what the video is intended for) but it might serve you as well. You will see that there are 6 (?, I think) small cables connecting the bottom part with the batteries and the PCB. During my repairs I intentionally soldered off the two beeper connections. But one other cable on the other side of the PCB came off just by itself (without me puling or something) and caused the LCD to not turn on again. Maybe this can happen also on any other occasion without having opened the calculator. So maybe you want to have a look inside...

I assume you replaced the batteries with *new* ones - not only other ones?!? Do you have an SD in the slot? Maybe take it out...


Isn't it still under warranty?


Let me answer your questions and also give you my latest findings.

- I don't know if any libraries were installed, because I got this from somebody else. With that in mind, I tried ON+A+F, ON+BS, ON+C.

- It is out of warranty, I already checked the HP site.

- I remember seeing a 50g being disassebled in YouTube. However I didn't know about the 49g+. I watched it and got the idea. It was useful, thanks.

As a result, I decided to take mine apart. It was not hard. After removing the back cover, and then the protective aluminum(?) shield, I noticed that the connection tape to the LCD was partly detached on the left side. This connection (like a RAM chip connector, but much tinier) is like a tape over the terminals on the LCD board. If you peel it off completely, it is almost impossible to tape it back. So, I put a piece of clear tape over it, trying to hold it down on to the connections. I then put the batteries back, but no luck.. Still the same thing, no screen output, just key beeps.

Now, my question is this: Does anybody know where the voltage is applied to lit up the screen? Which leg of the LCD connector? How many Volts(6V)? And, which leg is the ground(-V)? It shouldn't be hard to discover it, but I want to make sure.



As a result, I decided to take mine apart.

That was a mistake in many ways...

To answer your question about the LCD, they don't have a single voltage supply, it's a bit more involved than that.

Peeling the ribbon off the display broke connections that were thermally bonded, not a good approach to troubleshooting.

Chances are it wasn't going to be repairable no matter what you did. They're were not designed and assembled with serviceability in mind.


I had similar problem with my HP49g+, but I knew how I got it - I had installed a HP48 library. Try the fix I got from Joe Horn first:


Just in case it isn't obvious, please be aware that it takes a fast
hand to do this correctly. You have to press and hold down the
backspace key IMMEDIATELY, the very moment that the warmstart begins.
This is much more difficult to do on a 49g+ than it is on a 49G.

If you can force a warmstart by pressing ON+C, then do it this way:
Press ON and hold it down, then press and release the C key (while
still holding down the ON key), then SIMULTANEOUSLY release the ON key
and press & hold the backspace key. Sounds complicated but it ain't.

If "Try To Revover Memory?" is displayed, then take a deep breath,
then press and release NO and IMMEDIATELY press & hold the backspace
key. This one's the most difficult; there can be no more than ONE
PRECISE INSTANT between pressing the NO key and pressing the backspace
key. A fraction of an instant is even better but is not required.

If the crash is so bad that none of the above work, then perform a
paperclip reset with the backspace key held down, which will force the
reset to pause midway with the screen turned on but blank. To resume
the reset and bypass your libraries, momentarily release the backspace
key and immediately press & hold it again. "Momentarily" means "of
duration greater than zero time and less than or equal to one precise

If the paperclip reset doesn't work, you can fake it into thinking
that you're going to update the ROM without actually doing so. Here's
how to do that: Press and hold BOTH the + key and the - key while
performing a paperclip reset. You will see the screen turn on but
remain blank. Release the + and - keys. You will see the ROM Update
menu (1:Update Code, 2: Self Test, 3:Secret Menu [hidden]). Press 3
to show the Secret Menu (actually it's the same one ordinarily
obtained by pressing ON+F). Now take a deep breath, press and release
ON and IMMEDIATELY press and hold the backspace key. This will force
the reset to pause midway with the screen turned on but blank. To
resume the reset and bypass your libraries, momentarily release the
backspace key and immediately press & hold it again.

ALL of these techniques will result in "DROP Error: Too Few Arguments"
or "Memory Clear" being displayed, and no libraries shown when you
press the LIB key. If libraries appear when you press LIB, you were
not fast enough; repeat the procedure more briskly.

Hope this helps!


* end of quote *

Note that taking out all batteries has no effect on port 2

cheers, reth



You are right, these machines are not designed to permit easy repairs. One thing I found is that, this one was already opened, and, the aluminum shield was removed. When I removed it again, I found the thermal bond of connectors half way peeled off, towards the tips; but not fully detached. The full length was somewhat still holding tight. I then put a clear tape along the whole length to prevent full detachment, hoping that it would create a better connection. If I were to open it again, I'd cut the shield along the connector, instead of detaching it completely, and leave the upper part glued on the board. This connector is the weakest part of the design. I don't understand why they did not fortify it with the strong red glue that they used around the CPU & the crystal.
The connectors are so tiny that there is no way to solder them one by one. This is a micro (if not nano) technology.


Thank you for the precious info. I printed it, just in case. I tried in vain everything written again and again. Just beeps, no screen output. It seems like the whole thing is working, except the screen output! What a shame.. I think the previous owner used a 48 lib, and having no idea that it was a recoverable error, s/he opened it up.

At this point, I'll keep it for parts, or until complete exploration & remedy ideas of this new design come up. If I ever succeed, I'll post it.

And, yes, I'll get another one this week. I'm planning to write some programs using C language. The 48/49 Advanced User's Manual did not have a word about it. I've seen some links, but would anyone recommend a good source?

In the meanwhile, I'll keep writing programs on my 41-CV too.

Thank you all for your precious input & time.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Prime screen scratches - Use a screen protector Eelco Rouw 11 2,212 11-19-2013, 10:16 PM
Last Post: Eddie W. Shore
  HP Prime Save Power Turn Off Not Working Timothy Roche 12 2,746 10-27-2013, 01:41 PM
Last Post: Michael de Estrada
  Stylus for Prime screen steindid 6 1,577 10-22-2013, 02:06 AM
Last Post: Alberto Candel
  HP Prime: Slow turn off Paul D. Fox 1 870 10-09-2013, 08:39 PM
Last Post: Tim Wessman
  Sending from graph to home or CAS screen Richard Berler 6 1,610 10-06-2013, 03:29 PM
Last Post: Tim Wessman
  HP48GX screen replacement Francisco Quiles 9 2,428 10-03-2013, 09:17 PM
Last Post: Francisco Quiles
  hp50g screen weird line Sok-khieng Chum Hun 2 1,042 09-10-2013, 08:11 AM
Last Post: Sok-khieng Chum Hun
  New screen on pictures of new Sharp EL-9950 Mic 4 1,432 06-10-2013, 10:40 AM
Last Post: Mic
  HP Prime should have higher resolution screen LHH 5 1,483 04-25-2013, 10:00 AM
Last Post: bhtooefr
  Creeping black pattern on HP-11C screen Larry Gagnon 6 1,414 04-12-2013, 10:09 AM
Last Post: Peter Murphy (Livermore)

Forum Jump: