HP82161 - really strange problem...



#8

Hello,

couple of weeks ago, I mentioned my problem with the HP82161 tape drive which was not able to format the cassette.
Two days ago, I received one formatted tape with couple of files on it.
I tested the drive and the drive is able to read files without any problem. I also can write my own files on this formated tape without a problem. But still, the tape unit is unable to format a brand new tape.

Anyone have the idea what can be wrong ? Anyone saw this problem in the past ?

Thx for any help

Pavel Korensky

P.S. I received the preformated tape from one kind guy from Switzerland. Also, I received many ideas from Tony Duell.
But yesterday, the harddisk in my machine crashed and I lost all my e-mail addresses. I would like to ask the above mentioned gentlemens (and also Luiz Vieira and all others who was in e-mail contact with me) for a short e-mail. I need to recover my e-mail directory. Thx a lot.


#9

This is a strange problem. I can think of a couple of unlikely causes and one that might be quite likely here.
The unlikely ones first : The particular part of the internal program on the 82161's micrcontroller thant handles formatting has failed, but the rest of the code is OK. Pretty unlikely. Or that the motor speed is wrong, so it can still read/write a preformatted tape, but if you try to format a tape, it manages to write a block off the end of the tape or something. Again very unlikely.
The most likely cause, I think, is that the track select circuitry has failed, and that the drive is always selecting track 0. That way it'll be able to read a tape with a few files on it (everything is on track 0 -- directory and the files), and it can write some more files to track 0
But when you try to format a tape, it writes the blocks for track 0, then overwrites them with the ones for track 1 (since the drive only ever selects track 0 due to the fault), and then can't find the track 0 blocks to write the directory to, as they've been overwritten.
Debugging that could be interesting because there are 2 custom chips (CPU and read/write chip) involved, and not a lot else.

#10

pavel,

my cassette drives did show up with symptoms similar to those that you are describing. in all cases they were hooked up to an overclocked hp-41. obviously, the 41 waits only a specific amount of time (which is coded in the IL-module, i suppose) for the tape drive to respond. so, after the drive has finished formatting, and is on it's 'way home', time will run out on the 41 before the drive arrives at the beginning of the tape. if your hp-41 is not overclocked, then maybe, the drive motors are running slightly slower than normal. this can be due to increased bearing friction, or, a defunkt cell in the accu- pack.

hope, this helps

cheers, hans


#11

Hi Pavel,
in my job I had worked a lot with EXABYTE and DAT tape drives and tapes. Sometimes I got tapes from colleagues with a, as they called it, mystic behaviour. What we found is that all these tapes were in transport cases (of our company) together with and very close to extremely strong magnets. So the tapes were 'formatted' in a special kind. We demagnetized the tapes with a commercial tape demag and they worked well. My hint: Try to get a demagnetizer for audia tape heads and demag your 'brand new tape'. Sounds strange, I know. But: IT'S NOT A JOKE! Hope I could help.
Regards,
Andreas


#12

Hello,

thank you for the ideas. It seems that there is really something wrong with the drive unit, because I wrote couple of files on the preformatted tape which I got and some of the files are corrupted and the directory is also a bit corrupted (one short program file suddenly looks 16392 registers long and all files are listed twice after DIR command).
It seems that there is really something wrong inside the drive. I will make a complete diagostic and we will see.
I only hope that the custom chips inside are OK.


#13

Hang on, there's a 1K*4 bit RAM in there (the 18 pin chip on the main PCB). Now, I don't like 'lucky dip' diagnostics, but I've had more problems with such
RAMs (including on HP equipment) than with anything else. Worth investigating anyway...


#14

Have you (very carefully) tried cleaning the tape heads?
I've used q-tips with the purest isopropyl alcohol you can find, and it seems to work well.

When cleaning heads in this manner, you should try to clean them across the head (up and down, rather than left and right in our case). I forget what the exact reasoning is, but I was taught to do this by someone who used to build custom tape transports. He said that cleaning in the other direction could actually damage the tape head.

Hope this helps.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Strange HP 25 Problem (Repair) Onur Ilkorur 5 1,287 12-06-2013, 05:13 PM
Last Post: Onur Ilkorur
  Strange Battery Icon during updaate of Prime Firmware. Harold A Climer 7 1,584 12-05-2013, 04:40 PM
Last Post: Michael de Estrada
  HP PRIME : strange behavior when trying user key capability Damien 12 1,798 11-03-2013, 11:02 AM
Last Post: Joe Horn
  HP Prime function APP - Strange limitation ! :o( dg1969 2 737 10-04-2013, 12:10 PM
Last Post: dg1969
  HP41CX: Strange serial #... Stephan Matthys 1 587 09-13-2013, 01:38 PM
Last Post: Stephan Matthys
  [WP34s] strange behaviour at number entry Dieter 12 1,803 06-06-2013, 05:36 PM
Last Post: Harald
  Strange battery leak Cristian Arezzini 0 472 06-03-2013, 09:49 AM
Last Post: Cristian Arezzini
  Strange video Peter Niessen 9 1,470 04-07-2013, 08:33 AM
Last Post: Csaba Tizedes (Hungary)
  HP-41C Tall Keys Strange ON Behavior aj04062 3 795 12-02-2012, 06:49 AM
Last Post: aj04062
  HP15C strange complex number behavior Mike W 5 909 09-11-2012, 04:36 PM
Last Post: Mike W

Forum Jump: