Equation Library in 49G+/50G versus 48G


Hi all,

I am relatively new to the RPL family of calculators, having used the 41C, 15C and 32sii primarily. I recently acquired a pristine 48G for a mere pittance and have been fooling around with the Equation Library. So far, every example that I have worked through from the AUR went flawlessly (with some exceptions like Bernoulli's Equation: Pressure at Depth where Po registers in kPa instead of atmospheres as in the example, consequently giving the wrong answer). The same cannot be said for my 49G+ with the v92 ROM and EqLib L226 and L227 files. On several occasions, certain variables do not have units associated with them and the solver will not work properly. One example would be the 'A' Total Surface Area variable in the Solid Geometry/Cone equations set. This is only an example and has happened elsewhere too. I have purged all variables every time the problem happens and tried reinstalling the library files but to no avail. Has anyone else noticed this or am I missing something fundamental here? Thanks in advance.




I have both a 48GX and and a 50G with the equation libraries, and they work identically for me. You might check the following issues:

(1) When you start the equation library, there should be three softkeys at the bottom left, marked SI, ENGL, and UNITS. The UNITS key toggles units on or off. When it's on, there's a little square on the right side of the key, so that it reads UNIT[] instead of UNITS. You can also toggle between SI and ENGL units, and the square shows which one is selected, although it doesn't meke any difference unless UNITS is turned on.

If you've been toggling the UNITS button, it could explain why your units sometimes disappear. If you've been toggling the SI and ENGL buttons, it could also explain why Po registers as kPa in "Pressure at Depth", because the default unit in ENGL is psi. You can see the default units for "Pressure at Depth" by pressing VARS NXT.

(2) If you've been using a particular set of equations, then switch UNITS on or off, or switch between SI and ENGL, then you have to purge the variables in the current directory for the changes to take effect. If that's not working, you might also check for any similarly-named variables in any higher directories.

For example, supppose you are using the Equation Library in a subdirectory named SUBD1 in the HOME directory. You purge all of the variables in the HOME/SUBD1 subdirectory, including variable A. But if there is also another variable A in the HOME directory, then you may still have a problem.

Possibly Related Threads…
Thread Author Replies Views Last Post
  48G vs 49G+ User RPL Speed Comparison John Colvin 7 2,607 11-16-2013, 10:07 PM
Last Post: Han
  Library#4 Modules mass-update and New Overlays Ángel Martin 0 1,248 11-09-2013, 05:55 AM
Last Post: 'Angel Martin
  [HP Prime] Constants Library Values Timothy Roche 24 7,372 11-02-2013, 04:17 PM
Last Post: Les Koller
  [HP-Prime CAS] Vector Calculus Library CompSystems 7 2,759 10-31-2013, 12:48 PM
Last Post: Han
  Equation Library/App for the Prime Harold A Climer 3 1,733 10-30-2013, 10:14 AM
Last Post: CompSystems
  Equation Library on the PRIME Harold A Climer 0 1,059 10-26-2013, 10:01 AM
Last Post: Harold A Climer
  Meltiple Equation Solver PRIME Vs. HP 50G Harold A Climer 5 1,836 10-07-2013, 05:11 PM
Last Post: CR Haeger
  CASplus Library for HP-Prime CompSystems 1 1,215 10-05-2013, 12:44 AM
Last Post: CompSystems
  The Rich HP Calculator Library Eddie W. Shore 0 881 09-27-2013, 10:19 PM
Last Post: Eddie W. Shore
  EOT--TI N-Spire Equation Limit Matt Agajanian 2 1,311 09-22-2013, 12:37 PM
Last Post: Matt Agajanian

Forum Jump: