Problem with 48G+



#2

The icon that appears when transferring data has appeared on the display, and I'm not transferring data. It's not blinking or going off, no matter what. But it doesn't seem to affect the calculator in any way except for it's apparent permanent presence. Could someone shed some light? I did transfer some data after and it accepted the dat, but the icon didn't 'blink' once.


#3

Forgive me, but just to be sure, are you certain it's not the low battery indicator? The 48G+ screen isn't all that big and these annunciators all look somewhat similar and seem to appear in similar locations.

#4

Ordinarily, the I/O annunciator is on only when the calculator is actually sending or receiving data. One bit in System RAM normally controls whether any particular annunciator is on or off. I'd expect that transferring some data should force it to the correct state, but perhaps the calculator is still trying to send something. Even so, I'd expect any transfer to eventually (within a minute) time-out.

An exception to the time-out would be using a "Serial I/O" command after executing 0 STIME. Maybe try forcing the time-out to its default value of 10 seconds by executing 10 STIME.

I'd try the CLOSEIO command, although I'd expect that turning the calculator off and then back on should've aborted any transfer and closed the I/O port.

You could try forcing a warmstart by holding down ON, pressing and releasing C, and then releasing ON.

If all else fails, you could try archiving everything to a PC (don't forget to also transfer anything that you want to save from port 0) and then forcing a TTRM (Try To Recover Memory?) by holding down ON, then A, and then F, and releasing them in reverse order. I'd first try answering YES and let it try to recover memory, and if that doesn't help, then NO to let it erase everything and restore everything in RAM to its default state. After clearing memory, you can use the RESTORE command with your archive file to get things back to normal.

But what I really expect is that your 48G+ has a hardware failure, and if none of the above helps, then it's probably best to just live with it.

Note that if for some reason the I/O port is staying open, then you can expect a higher than normal drain on the battery.

Regards,
James


#5

Ed, it's not the battery indicator. I saw this problem once before. A friend had a 48G and the same thing occurred. Nothing we tried got rid of the icon. It did last a long while [years], until the calc. finally died. It's not blinking so I don't think it's trying to transfer data.

#6

I have the same problem with my brand new HP 50g.

After only one week of intense use, the I/O indicator switched on. Shortly after that, the "Low Bat" message appeared on the screen.

While reading the user guide, I saw no mention that this indicator does serve as a low battery indicator.

Each time I connect the USB cable, the indicator switches off. I've read somewhere that the calculator uses energy coming from the USB cable when possible. So, maybe the I/O indicator does serve as a low battery indicator finally.

I did not yet try to change the battery.

Best regards

Patrick


Possibly Related Threads...
Thread Author Replies Views Last Post
  48G problem kc 3 298 06-15-2012, 08:33 AM
Last Post: KC
  Memory problem on 48G+ Iqbal 1 209 08-06-2009, 04:35 PM
Last Post: Raymond Del Tondo
  HP 48GX and 48SX and 48G and 48S and 48G+ Mad Dog ebaycalcnut 2 285 04-17-2007, 08:55 PM
Last Post: James M. Prange (Michigan)
  48G compiled local variable problem hal 3 321 09-05-2006, 12:54 AM
Last Post: Hal
  48gx = 48g +96k ? = 48g+ +32k? Eric Lundgren 2 283 02-21-2005, 03:44 AM
Last Post: James M. Prange (Michigan)
  Weird HP-48G problem Nelson M. Sicuro (Brazil) 10 577 11-17-2003, 04:57 PM
Last Post: Nelson M. Sicuro (Brazil)
  97 Card Reader Problem (NOT gummy problem) Peter Khor 5 423 10-04-2000, 11:03 AM
Last Post: ErikWahlin
  Problem with 48G+ Gobin 1 191 07-09-2000, 10:59 AM
Last Post: Tom Lianza

Forum Jump: