bad HP41CX?



#2

I have an HP41CX halfnut that when I put a magnetic card in a card reader, the motor of the card reader doesn´t turn on. Doing CAT 2 shows card reader present, so at least some power is available in slot 4 of the HP41CX. I have put a math module in slot 4 and shows all functions, the module works well. I have checked the card reader in an HP41CV and works perfectly. Maybe this problem should be a bad capacitor of the HP41CX?

thanks


#3

Hello, Gonzalo --

One basic thing to check is voltage on each "N" cell (or simply use the battery set from your 41CV. Running the motor to read or write a card requires a certain amount of power that is drawn from the HP-41, and that capability is probably the first to be lost when the battery becomes discharged. (Clock functions are next to go...)

-- KS


#4

Hello:

I have tested it with a new set of batteries. It seems it doesn´t arrive enough power in the slot 4 toward the card reader

gonzalo

#5

I think there's a hot shoe (unswitched) that's unique to port 4 to run the card reader. It may be bad in your machine.
Best regards, Hal


#6

Which piece is unique to port 4 of the 41CX? I have the schematic of the 41CX and don´t see any difference between port 4 and ports 1-3.


#7

Port 4 has the lines B3 and B4 connected together, it is the only port with that configuration. It is shown on the schematics and is obvious if you examine the port I/O block. I would remove the I/O block and look for battery corrosion, the most likely cause of your problem.

Edited: 10 Dec 2006, 10:51 a.m.


#8

If you clean the contacts of port 4 with isopropilic alcohol you will probably fix it.

Good luck

Jon


Possibly Related Threads...
Thread Author Replies Views Last Post
  Bad Flash in HP Prime Han 11 220 09-27-2013, 12:38 PM
Last Post: Han
  HP41CX: Strange serial #... Stephan Matthys 1 67 09-13-2013, 01:38 PM
Last Post: Stephan Matthys
  Cheap hp32sii in bad condition on sale on Taobao Waon Shinyoe (China) 1 62 03-01-2013, 08:35 PM
Last Post: Raymond Del Tondo
  Using PIL-BOX & ILPer to Transfer Programmes from PC to HP41CX? Michael Lopez 5 121 06-25-2012, 09:31 AM
Last Post: Michael Lopez
  HP-35S..Not so bad Matt Agajanian 19 312 04-23-2012, 02:00 AM
Last Post: Valentino Ducati
  Bad News for 33S: a bug shared with 35s bill platt 20 286 03-25-2012, 03:57 AM
Last Post: Paul Dale
  I no longer feel bad... David Ramsey 12 202 03-12-2012, 07:42 PM
Last Post: db (martinez, ca.)
  HP-41C bad display - where to start from ? Alberto Fenini 8 153 02-12-2012, 02:01 PM
Last Post: aurelio
  Science Project with HP41CX and Arduino? Fouad M. Kaadou 9 188 01-04-2012, 04:04 AM
Last Post: yves
  Return of the 15C with Bad Zebra? aj04062 3 84 12-23-2011, 01:52 PM
Last Post: uhmgawa

Forum Jump: