HP42S problem



#2

I have an HP42S that works perfectly except for one small little problem... it draws a continuous 75mA of current. This will suck the batteries dry in about an hour. I have opened up the machine and can find no components that seem to be shorted, etc (i.e. all the caps are good). Same for the LED (disconnecting it did not change anything).

Measuring the resistance between the battery contacts shows a nice high resistance. Neither the CPU or RAM chip seem to have a temperature rise indicating that they are sucking the power. I have not removed the CPU card yet to check if the LCD is the problem. Does anybody have any idea where my juice is flowing?


#3

75mA supply current is only about 1/3 W at the battery voltage of the 42S. I am not suprised you don't feel anything getting that hot with that sort of power
disipation.
I've seen a 42S that took excessive supply current, but in this case, the resistance between the battery contacts looked low when tested with an (analogue) ohmmeter. It turned out that the fault was the
100uF capacitor across the battery lines. You might try removing this -- the machine will work without it, but you get MEMORY LOST as soon as you remove the batteries, and I'd not trust printing either (due to the high current spikes taken by the IR transmitter). Of course if it is the capacitor, it's trivial to get a replacement.
I don't see how it can be the LCD. So I'd not remove the PCB at this stage. You mihgt try lifitng pin 28 (Vcc) of the RAM to see if that reduces the current consumption. If so, then change the RAM chip (it's a normal 6264-type thing).


#4

Disable your printing option, Your IR may be in continuous print mode. Worth a shot.


#5

I have pulled all the discrete components on the unit, disconnected the RAM and the LCD/keyboard and it still sucks the juice. I hooked it to a nicad pack and let it run for three hours and could feel the heat increase in the CPU chip... not a good sign.


#6

Indeed not. I've seen this failure mode with MOS devices before -- they work fine but take excessive supply current.
It looks like you need a new CPU chip (and of course the only source for that is another HP42S. Time to start looking for one with a broken display, I guess.


#7

Yes, the problem is usually caused by a floating CMOS inputs. It causes both the "P" and "N" channel transistors in a logic gate to come on at the same time creating what amounts to a short circuit between power and ground. I've checked all the pins to the CPU with no luck.

#8

I had a similar problem on an HP32SII. The batteries would die after a few days. Replaced the capacitor, no help. Finally put a switch in it. No continious memory, but it still works.


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP42S John Mosand 5 556 07-22-2012, 03:13 AM
Last Post: Les Koller
  HP42S graphics Han 2 362 07-20-2012, 12:23 AM
Last Post: Raymond Del Tondo
  HP42s ROM aurelio 18 1,624 06-26-2012, 09:36 AM
Last Post: Thomas Klemm
  x root y on hp42s David Griffith 14 958 04-08-2012, 12:43 PM
Last Post: Walter B
  HP42s - deal? Cristian Arezzini 26 1,550 02-19-2012, 10:05 AM
Last Post: Cristian Arezzini
  HP42S Dwight Sturrock 4 398 03-31-2011, 11:21 PM
Last Post: svisvanatha
  Sick HP42S Chuck Galloway 2 278 03-17-2010, 11:46 PM
Last Post: Geoff Quickfall
  Sick HP42S Chuck Galloway 4 398 03-17-2010, 04:58 AM
Last Post: Nicholas Cole
  HP42s Programming Mark Harvey 16 1,010 08-14-2008, 09:37 PM
Last Post: Ron Andrade
  New HP42S ce25593 6 486 06-30-2007, 02:26 AM
Last Post: Seth Morabito

Forum Jump: