HP50g Graph of 3rd root of x^2



#7

I hope sombody can shed some light on this for me. Whe I graph
Y1(X)=(X^2)^(1/3), I get the correct graph of both positive and negative values of X.

But, when I graph Y1(X)=3rd"Radical Symbol"(X^2), I only get the positive side of the equation.

I also only get half when I graph Y1(X)=X^(2/3)

I've tried changing my CAS settings, and I've not had any luck. Are there special rules for using the "Radical" symbol of the equation writer?

Thanks
David Batiz


#8

AFAIK the radical symbol (√) generally represents the positive real root. In other words, radical 4 is 2, not -2. If you want +/-2, you use +/- radical 4, or 2^(1/2).


#9

Here’s a subtle difference. If I take the third root of x, then square it, the graph works. But if I square x, then take the cube root, I only get half the graph. I think both processes should produce the same result. Is there anywhere I can read up on this to figure it out?

Thanks,
David


#10

David,

I found a hint in an old HP journal. It is on page 38:

Quote:
Why do I get a complex number when I evaluate '(-1)^(2/3)' ?
    The machine returns a complex principal solution for expressions with fractional exponents. To get a real-valued result to the above, use 'XROOT(3,(-1)^2)'
    ...

Complex numbers aren't plotted, of course.

If you switch to degrees and polar display, and use ->NUM to force a numeric result, you get (1.,<)120.) for (-1)^(2/3). Other possible solutions include (1.,<)-120.) and (1.,<)0.).

Marcus


#11

Marcus,

By pressing the edit button twice on my "Y=" screen, I edited my equation to "Y1(X)=XROOT(3,X^2)". I agree this should provide real-value results, but for some reason the calculator refuses to plot the left side of the graph.

The XROOT(3,X^2) works for both negative and positive values of X in the stack, but something keeps it from working in the graph. Also, it will not generate solutions in the "TABLE" for negative values of X. It returns "Undef."

Thanks for your replies,
David


#12

David,

Quote:
The XROOT(3,X^2) works for both negative and positive values of X in the stack, but something keeps it from working in the graph.

That's funny! I've just tried 'XROOT(3,SQ(X))' which works fine. The Exponent symbol "^" seems to cause the trouble. This is probably more of a bug than a feature.

Marcus


Possibly Related Threads...
Thread Author Replies Views Last Post
  [HP Prime] Using n-root symbol and exponent problem uklo 7 1,403 11-11-2013, 01:39 AM
Last Post: Alberto Candel
  My 2nd and 3rd Prime Programs Jeff O. 7 1,285 10-31-2013, 08:18 AM
Last Post: Jeff O.
  3rd order ODE diff eq Richard Berler 0 499 10-23-2013, 09:53 PM
Last Post: Richard Berler
  Sending from graph to home or CAS screen Richard Berler 6 1,183 10-06-2013, 03:29 PM
Last Post: Tim Wessman
  hp50g screen weird line Sok-khieng Chum Hun 2 736 09-10-2013, 08:11 AM
Last Post: Sok-khieng Chum Hun
  Documentation about Hp50g / 49g+ / 48gII and wikis Pier Aiello 9 1,452 09-10-2013, 04:22 AM
Last Post: Software49g
  Cubic root (-8) = 2 ? Gilles Carpentier 37 4,605 08-12-2013, 10:26 PM
Last Post: jep2276
  "A Penny for your thoughts" on the HP50g Tom Grydeland 3 872 08-01-2013, 03:57 AM
Last Post: Les Koller
  Is there a HP50g emulator for Linux? Matti Övermark 2 764 07-03-2013, 07:40 AM
Last Post: Matti Övermark
  HP50G advanced applications for mathematics CompSystems 0 583 06-17-2013, 08:38 AM
Last Post: CompSystems

Forum Jump: