More Prime problems - lost Apps key again


So, this is the second time that the calculator reboots every time I hit the Apps key. Last time I was able to recover by doing a C F O to utilities and reformat drive C. So I then hit Apps and all is fine. So, next I do a restore with the connectivity kit using my backup, but then it's doing it again. So how do I get back all my programs, data etc w/o bringing back the bad stuff that is apparently causing this problem ?

Edited: 15 Nov 2013, 9:52 p.m. after one or more responses were posted


This is crazy. The Emulator also crashes now when I hit the Apps key !

What on earth is the problem !!!!!!

Edited: 15 Nov 2013, 11:49 p.m. after one or more responses were posted


This has happened to me a few times too. It's due to a bad backup. Whatever causes the Apps key to warmstart got saved in the backup, and so it will happen any time you restore from that backup.

Two possible solutions come to mind. The faster one, but probably not as safe and not guaranteed to even work, is to backup a totally empty emulator, then open that backup in Windows (it's just a zipfile) and copy into it just the programs from the bad backup. Don't copy the settings files etc. Then see if that modified backup restores correctly. I give this a 40% chance of working (my uncertainly times Murphy's Ratio). I've never tried it; please let us know if it works.

Another solution, far more tedious, is to restore from the bad backup, copy each program to text and save them as external text files, then clear the machine, and then paste all your programs back one at a time from the text files. Ugh! But I know it works because I've done if a few times myself.

If you have more than just programs to save, then copy those too, of course.

What a pain! :-(


Thanks, Joe. But I'm so steamed right now that I'm doing a timeout with the Prime and putting it away in the closet for a while, and am not going to waste any more time on this hideously unstable product. This reminds me of the initial release of Windows 95 that was so bad that many people went back to Windows 3.1 or even MSDOS. HP really dropped the ball on this one.

Edited: 15 Nov 2013, 11:49 p.m.


Happened to me twice too, but I was not able to list the contents of the calculator from the Connectivity Kit (calculator disconnected itself and rebooted), format C: fixed it.

I thought it was because I was messing with the USB


Format C fixed mine too, but I lost all my programs and data. The backup was corrupt, so as soon as I did a restore, I was back to square one. Anyways, I'm done messing with it for now, and going back to my trusty HP 50g.


My Emulator crashes every time I press the Apps key, just like my real Prime was doing. I tried reinstalling it from the CD to no avail. I tried uninstalling it first and then doing a new install to no avail. I even tried doing a restore from a backup made with my reformatted physical Prime, that is now working properly w/o anything saved on it. It indeed is now a clone of the physical Prime; it even has the same name that I had assigned to the physical Prime. However, it still crashes and restarts every time I press the Apps key, so apparently doing a restore with a good backup will not fix a bad calculator.

Edited: 16 Nov 2013, 9:27 a.m.


If you are (still) willing, open up a explorer window and type in "%APPDATA%" in the path field. That will take you to a folder and there will be a "HP_Prime" folder. Please zip that up and email it to me. The reason we've been unable to fix this is nobody has ever been able to reproduce it here... :-(



What is your email ? Or if you don't want to post it, then message me so I can send you the file. BTW, I found two folders named HP_Prime and HP_Prime_1. The newest one is HP_Prime, which is the one I've zipped.

Edit. I deleted the HP_Prime folder and now the Emulator is working again. It started up in its new condition, requesting language selection, and created a new HP_Prime folder with the current date. So I guess that's the Emulator equivalent of reformatting the flash drive on the physical Prime.

Edited: 16 Nov 2013, 12:04 p.m.




Thank you.

BTW, "reset" in the menu clears the folder out.


So Reset on the Emulator is like Format flash drive on the calculator ?

Possibly Related Threads…
Thread Author Replies Views Last Post
  HP Prime: the drama of the Apps button, shutdown, formatting, nothing solves Davi Ribeiro de Oliveira 0 1,123 11-17-2013, 07:23 AM
Last Post: Davi Ribeiro de Oliveira
  HP Prime: the drama of the Apps button, shutdown, formatting, nothing solves Davi Ribeiro de Oliveira 1 1,364 11-16-2013, 11:26 PM
Last Post: Michael de Estrada
  HP Prime: do not send programs and shuts down by pressing Apps Davi Ribeiro de Oliveira 1 1,374 11-12-2013, 11:05 AM
Last Post: Joseph Ec
  HP Prime - EEX/X/Toolbox-key suggestions bluesun08 2 1,527 11-07-2013, 06:15 PM
Last Post: bluesun08
  HP Prime - Grouping Apps bluesun08 1 1,219 11-07-2013, 09:23 AM
Last Post: Tim Wessman
  Shutdown with the Apps key and more than 10 variables in a program. Davi Ribeiro de Oliveira 10 3,861 11-05-2013, 01:26 PM
Last Post: Han
  HP PRIME : strange behavior when trying user key capability Damien 12 3,936 11-03-2013, 11:02 AM
Last Post: Joe Horn
  HP PRIME: How to use [a b/c] key from a program Joseph Ec 4 1,903 10-29-2013, 06:18 PM
Last Post: Joseph Ec
  What does the Send menu key in the Apps window do? John Colvin 3 1,627 10-23-2013, 10:56 AM
Last Post: Tim Wessman
  PRIME Lockup after pressing Enter key in Solver. Harold A Climer 13 3,788 10-14-2013, 12:05 PM
Last Post: Tim Wessman

Forum Jump: