Hand Held Products RS232 to HP-IL


Does anyone have the manual for this? I just acquired a unit. Replaced the 6 AA Nicads, but it is not recognized on the HP-IL loop (ASSIGN IO). I presume it should work like other HP-IL devices, but the manual would be helpful to confirm.


So there was a third HPIL-to-RS232 interface adapter? I had forgotten. There was of course the HP82164A, and Firmware Specialists, Inc. had their FSI164A which was mostly instruction-compatible but it had anywhere from two to eight RS-232 channels instead of one, and optionally also ran on batteries. If the HHP unit is at least close to being instruction-compatible with these other two, you might be able to use their manuals. Both are on TOS. The FSI scan there is from my own manual.

Edited: 30 Aug 2013, 1:12 a.m.


So there was a third HPIL-to-RS232 interface adapter?
Actually there were some more than only 3 different Serial<->HP-IL interfaces.

1. HP 82164A

2. FSI 164A

3. HHP Serial<->HP-IL Interface

4. CMT Serial<->HP-IL Interface, built in several fashions, like with RAM disc, or even complete with HP-IL LCD and heater (Multicase)

5. W&W Serial<->HP-IL interface, for use with the HP 48. This is a special version where the IL part acts as a controller

6. GeoDAT 126/127. This has a built-in HP-IL module, HP-IL pass-through, and serial port for use with Geodimeter theodolites, IIRC

7. There may be more, check Matthias' site, and maybe J-F Garnier's site



After initiating the assign io command with either my hp71 or 75, it reports back there is a break in the hp-il loop. There was a little bit of nicad leakage that I cleaned. It does not appear to be bad enough to break any traces, but two were corroded. I checked them and they are okay. I tried two different set of cables.

If it is operational, should t it respond to the assign io command?

After turning on, both LEDs light for a few seconds. Then the T/R led goes out and the power led blinks. Is this normal or fault condition?

I assume the correct AC adapter is a 82059 or equiv.


While I am not familiar with this particular unit, in general if the handheld reports loop open when you do an I/O operation, for instance on a 71 if you do a 'RESTORE IO' with an open loop it responds "HPIL ERR: Loop Broken", what it is telling you is the commands it is sending out on the loop are not getting back to it. You can quickly check the integrity of you cables by connecting the ends that you would normally plug into your device together and then repeat the "RESTORE IO" and it should complete without error. Since you are getting a loop open that would suggest that either the controller in the device is not getting started or there is a fault in the HPIL circuitry in the device.

Re the adapter, is there any indication on the device what it expects for power? If it has the two square hole connector like the 71 or 75 that might be a fair assumption given it was designed to work with those handhelds and if it had different power requirements you would expect they would use a different connector. If the device is set up for AC power the leads from the power connector should go directly to a bridge rectifier, either discrete diodes or a module. Do the batteries seem to charge up? Maybe the flashing power is telling you the battery voltage is too low to operate. You could also check the power that some of the components in the device are receiving, for instance if it has the usual 1LB3 HPIL chip it should have 5V between 1(+) and 10(-).

If you could send me sharp detailed photos of both sides of the circuit board I could probably give you more guideance on what to look for.


Here you are Paul. I plugged the unit into a 82059A AC adapter I have. It seems pretty logical to me that it would be the correct one. Interestingly, when I did this, it discharged the pack on the TOP (first picture) of the unit. When I tried it after charging, the unit did not work. I replaced the dead pack and it works again as I described.

Edited: 31 Aug 2013, 8:55 a.m.


The unit won't work.

Someone removed the protective label from the EPROM window, so the EPROM is likely to be erased partly.

Try to get a working EPROM from a working unit.


Well I am sure there was a cover on the box and even if there was not it takes a long time in direct sunlight to erase an EPROM not to mention the fact that if it was in doors, window glass does not transmit short wave UV light very well that is why the window in an EPROM is made from quartz glass as are the tubes used to generate the short wave UV for EPROM erasers and germicidal lamps. In short I would think that the uncovered EPROM is not likely to be an issue.


When I made my first home-made computer in 1985, I didn't have an EPROM eraser, so I initially put the EPROMs out in direct sunlight to erase them completely for the next trial-and-error cycle. I found it took about a week in direct sunlight (outdoors) to erase the EPROM, so as you can imagine, I soon broke down and bought an eraser. Indoors under fluorescent lighting with no cover on the box and no label over the EPROM window, you might get a year. My first thought when I saw the pictures above though was that the EPROM should be refreshed, and you should keep a file of the contents for the possible future need to ever start over. EPROMs were only guaranteed to hold their data for something like 10-15 years if the window was kept in the dark, but obviously they usually go way beyond that. Still, I have refreshed mine on the FSI164 HPIL-to-RS232 interface converter and a few other things that have EPROMs in them.


Ok taking a quick look it does appear that there is a bridge rectifier module between the power connector and the switch so it looks like it is set up for AC power.

Are you sure those corroded lands are ok? the connections around R4 and R41 near the LEDs don't look good, but then they look lkike they may be the current limiters for the LEDs and you do say that they come on.

In the bottom picture to the right of where the battery packs are sitting there are two bigger resistors one of which is 100ohms the other is/was probably the same but has got quite hot at some time and may now be open, these are likely in the battery charging circuit and it one pack had gone short it may cause this. If they are part of the charging circuit then one side will likely be connected to one of the battery terminals.

The two chips in the bottom right corner the ICL7660 is a voltage convertor designed to generate -5V from a +5V supply, the input voltage is on pin 8 and the output is on pin 5. The other one appears to be an ICL7665 with is a over-voltage monitor pin 8 is the supply voltage, 4 is gnd and is used to monitor 2 voltages the outputs are pins 1 and 7 and they go low when they are tripped.

More later but I have to go out now.

What do you have for test equipment?


Thanks Paul,

I am pretty sure the lands are okay. I'll recheck. I traced them back to spots that could be probed and got good continuity/low resistance. I double checked and all three traces are okay.

I see that resistor. I'll pull it out and test.

I've got multimeter, PEAK testers (LCR, ESR & DCA)and an oscilloscope.


Ok I have looked at this and thought about this some more and here are my comments:

1. I trust you are now confident that your cables are ok, I would suppose you would even have other HPIL devices you could try them with to be sure but just joining the loose ends as I suggested previously is a pretty good indication.

2. I took out and plugged in one of my 82164As and observed that initially both lights are on but after a moment the T/R light goes out and it only flickers where the 82164 is actually sending or receiving so that may be a happy sign that the controller in your box is actually getting off the ground.

3. The flashing power light is probably just indicating low voltage that may or may not be fatal to the operation of the box.

4. I am concerned about that big resistor near the + terminal of the right battery pack I think you one pack may not be charging. Are the two packs connected in series? I would expect that they are as 3 NiCds is only 3.6V nominal, not enough for the logic on board. Did you try checking the power inside? I suspect that nearly everything runs on +5V probably the easiest point to check would be on the EPROM pin28 (+) pin 14 (-) same for the flat pack SRAM next to it but less convenient. I trust that you wired your packs to the board the same way as the originals where connected.

5. Have you looked at the underside of the board? There could be battery leakage damage there too.

6. Continuity on the HPIL connectors with an ohm meter on its lowest scale each pair of pins will look like nearly dead shorted but it is actually in the neighborhood of 0.5 ohms across the in and out pairs because the DC resistance of the windings on the transformer are quite low.

7. On the other side of the transformer between pins 17 and 18 of the ILB3 you should measure about 2 Ohms and each of these pins should measure around 7K0 ohms to ground. Each of these pins has a 15K resistor to ground but because of the low resistance of the transformer winding they are essentially in parallel. Between pins 19 an 20 you should measure around 700 to 760 ohms each of these pins has a 383 ohm resistor between the pin and the transformer. On TOS there is a a Technical Manual for the 82166C that contains the best schematic of the circuitry between the the ILB3 and the HPIL connectors. There are also some zeners and capacitors but they are not really critical unless thy go short.

I suspect you may have a double fault here, something wrong with the power supply and also a fault in the HPIL, unless of course the design is halt operation when there is a power fault such as a low battery.

Possibly Related Threads…
Thread Author Replies Views Last Post
  How to move lexfiles from PC to 71 w/o HP-IL? Joe Horn 9 3,259 10-18-2013, 03:50 PM
Last Post: Christoph Giesselink
  HP IL over wifi ... (ILPer & go71b) Olivier De Smet 12 4,102 08-20-2013, 05:44 AM
Last Post: Olivier De Smet
  New pictures of HP Prime in hand Mic 52 13,398 06-15-2013, 10:15 PM
Last Post: Peter Murphy (Livermore)
  Hand-in-Hand (har har) Dave Britten 4 1,864 07-19-2012, 01:03 PM
Last Post: Bill (Smithville, NJ)
  held breath, found tapes & drive working Garth Wilson 9 3,119 06-12-2012, 12:52 AM
Last Post: Garth Wilson
  HP-IL beginners question John Abbott (S. Africa) 4 1,782 05-28-2012, 05:45 PM
Last Post: Geoff Quickfall
  Hand Held Products Corp John W Kercheval 12 3,427 05-23-2012, 01:56 AM
Last Post: Matt Agajanian
  HP-IL SCSI Interface Richard Wagoner 15 4,301 02-19-2012, 07:39 PM
Last Post: Richard Wagoner
  HP 82165A HP-IL/GPIO Interface VS HP 82164A HP-IL/RS-232C Interface VS HP 82166A HP-IL Converter Fouad M. Kaadou 9 2,991 01-15-2012, 03:45 AM
Last Post: yves
  HP-IL ftp files robertoataulfo 4 1,753 12-04-2011, 04:34 PM
Last Post: robertoataulfo

Forum Jump: