Link for SAMBA v2.10 download


I cannot get SAMBA v2.11 to work. AMTEL no longer has v2.10 on their web site. Can somebody post a like for downloading SAMBA v2.10?

Thanks in advance



Edited: 29 May 2012, 2:04 a.m. after one or more responses were posted


Thanks, but that link did not work. Reported error 404


Oops. I tried again and it did work. Thanks


Why do you want to run SAM-BA instead of MySamba?


I have tried Mysamba with no success.

This was my first attempt at flashing my WP34S to load the new 3.1 image. I am using Windows 7 and I tried SAMBA 2.11 since it was targeted for Windows 7. I am using Eric's cable with an FTDI adapter. After installing the FTDI drivers and a few atttempts at finding the right keystrokes and ERASE RESET commands to prep the HP-30B I got it to connect. I pointed SAMBA at the correct file and selected the proper board. When I tried to send the file, the dialog box indicated only 1% of the file transferred and it showed "NO BOARD" on the bottom right of the box. Evidently, I could not get SAMBA to recognize the board or to accept the setting for the board.

Since then I cannot get anything to connect to the calculator. I have tried Mysamba (with XP SP2 compatibility), and now SAMBA 2.10 with no luck. I have installed new batteries and checked that Windows show the drivers. The blue lights on the cable do blink a few times, but all I get is connect failed messages.

So, I have a dead HP-30B and can't get it flashed.



Have you tried pressing reset on the cable, then ON on the calculator and then flashing?
That should work. MySAMBA is usually the easiest and quickest way to do this.
Good luck!

PS: The calculator may appear dead, but it most likely is not. You just need to find out what you are doing wrong in the flash process.


1) new batteries
RESET on cable
ON on HP-30B
Blue LED flashes 3 times
2) RESET on back of calculator
Blue LED flashes 3 times


After you have tried MySamba you will definitely need to do an ERASE again. MySambe set the boot bit first and then satrts the flashing process. If the latter fails, the firmware is flashed half way but the boot bit is set to start this broken image. ERASE will clear all flash and set the boot to SAM-BA.


Thanks for the quick response Marcus.

I tried various combination of RESET EERASE and ON with no success. The blue LED flashes 3 times and then the NO CONNECT message appears.

Possibly Related Threads…
Thread Author Replies Views Last Post
  HP Prime Emulator download John Colvin 2 2,119 12-14-2013, 05:54 PM
Last Post: John Colvin
  [Download] libhpcalcs: a toolkit for communicating with Prime calcs... debrouxl 13 4,472 11-18-2013, 05:22 AM
Last Post: debrouxl
  [Download] PrimeComm: Alternative small utility to upload/download programs to the HP Prime Erwin Ried 6 2,566 11-17-2013, 10:18 AM
Last Post: Erwin Ried
  Shutdown with the Apps key and more than 10 variables in a program. Davi Ribeiro de Oliveira 10 3,860 11-05-2013, 01:26 PM
Last Post: Han
  Updated PPC DVD Version 2.10: HP-41 Searchable Program Files and Scannable Barcode Jake Schwartz 3 1,888 09-27-2013, 09:51 PM
Last Post: Olivier (Wa)
  Rounding of 10^x Olivier De Smet 8 2,563 08-28-2013, 06:33 AM
Last Post: Dieter
  IR Link Problem: HP48 <-> PC Waon Shinyoe (China) 1 1,141 03-16-2013, 03:37 AM
Last Post: Eric Smith
  HHC 2012 RPN Programming Contest - 10-Step Way-After-Nashville Solution Jeff O. 32 6,886 10-12-2012, 01:41 AM
Last Post: Paul Dale
  Library 4 update on 10/2/2012 ? Gene Wright 10 3,115 10-11-2012, 02:31 AM
Last Post: Ángel Martin
  e^pi - pi + 9/10^4 + 1/(10^4*ln(2) + sqrt(10)/6)^2 Gerson W. Barbosa 47 11,751 08-08-2012, 10:58 PM
Last Post: Les Koller

Forum Jump: